FedoraForum.org - Fedora Support Forums and Community

View Poll Results: Did it work for you

Voters
945. You may not vote on this poll
  • Yes

    459 48.57%
  • No

    343 36.30%
  • Nearly worked

    143 15.13%
Page 3 of 326 FirstFirst 1 2 3 4 5 13 53 103 ... LastLast
Results 31 to 45 of 4882
  1. #31
    leigh123linux Guest
    Quote Originally Posted by tokegee
    Hi leigh123
    Thank you .. leigh123, I got fglrx driver installed and Beryl too. Well .. please let me ask more questions.
    After installing them, I lost my desktop effects. Although I tried with Beryl Manager, I got nothing effects.
    And all resolutions were changed from my current resolution 1024x768 to the 1280x1024. Although I could change my destop resolution to 1024x768, but Starting screen and Login screen are in 1280x1024. So how can I fix it and How can I get Desktop Effects?

    Best regards

    PS: have a nice day
    1. Did you edit your xorg.conf as described in section 3 ?
    2. Did you restart X or reboot as this is needed . ?
    3. did you use the new option to start XGL ?( gdm session type i.e Gnome + XGL )



    if the above steps fail post the output from

    glxinfo


    cat /var/log/Xorg.0.log | grep EE


    cat /var/log/Xorg.0.log | grep WW

  2. #32
    Join Date
    Apr 2007
    Location
    EU
    Posts
    76
    Yes, I did all, but only one thing left to do choosing GNOME+XGL. I chose GNOME, that was why I didn't get it. Forgive me!
    Right Now I get it all.

    Thank you so much indeed for giving me experiences on Fedora and for your kinds.

  3. #33
    Join Date
    Sep 2006
    Posts
    170
    Well, it half worked...

    I now have the desktop effects from compiz (wobbly windows, cube etc) working under gnome, which is progress and very nice.

    However, KDE seems a bit roughed-up: the ControlCenter menu item has gone, and other menu items have been re-organised, and I have to restart X to log out...

    And trying to select Beryl as window manager from beryl-manager just crashes X, whether in gnome or kde.

    It also changed my keyboard settings, but that was quick to change back.

    But overall it is progress... I'll install FC7 sometime soon and see if a vanilla install makes beryl work (i've tried several times before, so might be a hang over from that).

    FWIW I have an X1600 on acer 8204 with 2.6.20-1.2948.fc6

    thanks for the help
    M.

  4. #34
    leigh123linux Guest
    Quote Originally Posted by mps2006
    Well, it half worked...

    I now have the desktop effects from compiz (wobbly windows, cube etc) working under gnome, which is progress and very nice.

    However, KDE seems a bit roughed-up: the ControlCenter menu item has gone, and other menu items have been re-organised, and I have to restart X to log out...

    And trying to select Beryl as window manager from beryl-manager just crashes X, whether in gnome or kde.

    It also changed my keyboard settings, but that was quick to change back.

    But overall it is progress... I'll install FC7 sometime soon and see if a vanilla install makes beryl work (i've tried several times before, so might be a hang over from that).

    FWIW I have an X1600 on acer 8204 with 2.6.20-1.2948.fc6

    thanks for the help
    M.
    Ok try deleting the /home/*/.beryl folder and see if that helps.

    You may want to change the wildcard " * " for your username

    su
    rm -rf /home/*/.beryl
    If not can you post the results of these commands

    glxinfo


    cat /var/log/Xorg.0.log | grep EE


    cat /var/log/Xorg.0.log | grep WW

  5. #35
    Join Date
    Sep 2006
    Posts
    170
    Hi Leigh,
    Thanks for the advice.

    Deleting the contents of .beryl doesn't help unfortunately.

    Here is the output:

    Code:
    [root@moabi ~]# glxinfo
    name of display: :0.0
    Xlib:  extension "XFree86-DRI" missing on display ":0.0".
    display: :0  screen: 0
    direct rendering: No
    server glx vendor string: SGI
    server glx version string: 1.2
    server glx extensions:
        GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating, 
        GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method, 
        GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe, 
        GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig
    client glx vendor string: ATI
    client glx version string: 1.3
    client glx extensions:
        GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context, 
        GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample, 
        GLX_ATI_pixel_format_float, GLX_ATI_render_texture
    GLX version: 1.2
    GLX extensions:
        GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context, 
        GLX_ARB_multisample
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Mobility Radeon X1600
    OpenGL version string: 1.2 (2.0.6458 (8.36.5))
    OpenGL extensions:
        GL_ARB_multitexture, GL_ARB_texture_border_clamp, GL_ARB_texture_cube_map, 
        GL_ARB_texture_env_add, GL_ARB_texture_env_combine, 
        GL_ARB_texture_env_dot3, GL_ARB_transpose_matrix, GL_EXT_abgr, 
        GL_EXT_blend_color, GL_EXT_blend_minmax, GL_EXT_blend_subtract, 
        GL_EXT_texture_env_add, GL_EXT_texture_env_combine, 
        GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias
    
       visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
     id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
    ----------------------------------------------------------------------
    0x2c 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
    0x2d 24 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
    0x2e 32 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 Ncon
    0x2f 32 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 Ncon
    Code:
    [root@moabi ~]# cat /var/log/Xorg.0.log | grep EE
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (EE) Screen Screen1 doesn't exist: deleting placement
    (II) Loading extension MIT-SCREEN-SAVER
    Code:
    [root@moabi ~]# cat /var/log/Xorg.0.log | grep WW
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (WW) No FontPath specified.  Using compiled-in default.
    (WW) fglrx(0): board is an unknown third party board, chipset is supported
    (WW) LoadModule: given non-canonical module name "glesx.so"
    (WW) <default pointer>: No Device specified, looking for one...
    Can you make head or tail of that?

    thanks
    M.

  6. #36
    leigh123linux Guest
    Quote Originally Posted by mps2006
    Hi Leigh,
    Thanks for the advice.

    Deleting the contents of .beryl doesn't help unfortunately.

    Here is the output:

    Code:
    [root@moabi ~]# glxinfo
    name of display: :0.0
    Xlib:  extension "XFree86-DRI" missing on display ":0.0".
    display: :0  screen: 0
    direct rendering: No
    server glx vendor string: SGI
    server glx version string: 1.2
    server glx extensions:
        GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating, 
        GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method, 
        GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe, 
        GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig
    client glx vendor string: ATI
    client glx version string: 1.3
    client glx extensions:
        GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context, 
        GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample, 
        GLX_ATI_pixel_format_float, GLX_ATI_render_texture
    GLX version: 1.2
    GLX extensions:
        GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context, 
        GLX_ARB_multisample
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Mobility Radeon X1600
    OpenGL version string: 1.2 (2.0.6458 (8.36.5))
    OpenGL extensions:
        GL_ARB_multitexture, GL_ARB_texture_border_clamp, GL_ARB_texture_cube_map, 
        GL_ARB_texture_env_add, GL_ARB_texture_env_combine, 
        GL_ARB_texture_env_dot3, GL_ARB_transpose_matrix, GL_EXT_abgr, 
        GL_EXT_blend_color, GL_EXT_blend_minmax, GL_EXT_blend_subtract, 
        GL_EXT_texture_env_add, GL_EXT_texture_env_combine, 
        GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias
    
       visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
     id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
    ----------------------------------------------------------------------
    0x2c 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
    0x2d 24 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
    0x2e 32 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 Ncon
    0x2f 32 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 Ncon
    Code:
    [root@moabi ~]# cat /var/log/Xorg.0.log | grep EE
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (EE) Screen Screen1 doesn't exist: deleting placement
    (II) Loading extension MIT-SCREEN-SAVER
    Code:
    [root@moabi ~]# cat /var/log/Xorg.0.log | grep WW
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (WW) No FontPath specified.  Using compiled-in default.
    (WW) fglrx(0): board is an unknown third party board, chipset is supported
    (WW) LoadModule: given non-canonical module name "glesx.so"
    (WW) <default pointer>: No Device specified, looking for one...
    Can you make head or tail of that?

    thanks
    M.
    Well fglrx seems to be configured correctly , I would try a single monitor setup in your xorg.conf.

    Can you post your xorg.conf


    (EE) Screen Screen1 doesn't exist: deleting placement
    You have your laptop setup for dual screen ? ( you could try single monitor setup in your xorg.conf )

    [CODE][root@moabi ~]# glxinfo
    name of display: :0.0
    Xlib: extension "XFree86-DRI" missing on display ":0.0".
    display: :0 screen: 0
    direct rendering: No
    Did you run glxinfo with XGL active ? ( The output indicates you did )

  7. #37
    Join Date
    Sep 2006
    Posts
    170
    Hi Leigh,

    I am using an external display via the DVI port. Its in clone mode. I'd like to keep that if I can and its more important to me than the effects. I will test without the second screen though and see what happens.

    Here is the xorg.conf:

    Code:
    [malc@moabi ~]$ cat /etc/X11/xorg.conf
    # Xorg configuration created by system-config-display
    
    Section "ServerLayout"
            Identifier     "single head configuration"
            Screen      0  "aticonfig-Screen[0]" LeftOf "Screen1"
            InputDevice    "Keyboard0" "CoreKeyboard"
            InputDevice    "Synaptics" "CorePointer"
    EndSection
    
    Section "Module"
            Load  "freetype"
            Load  "dri"
            Load  "glx"
            Load  "extmod"
    EndSection
    
    Section "ServerFlags"
            Option      "AIGLX" "off"
    EndSection
    
    Section "InputDevice"
            Identifier  "Keyboard0"
            Driver      "kbd"
            Option      "XkbModel" "pc105"
            Option      "XkbLayout" "us"
    EndSection
    
    Section "InputDevice"
            Identifier  "Synaptics"
            Driver      "synaptics"
            Option      "Device" "/dev/input/mice"
            Option      "Protocol" "auto-dev"
            Option      "Emulate3Buttons" "yes"
    EndSection
    
    Section "Monitor"
    
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
            Identifier   "aticonfig-Monitor[0]"
            ModelName    "LCD Panel 1680x1050"
     ### Comment all HorizSync and VertSync values to use DDC:
            HorizSync    31.5 - 90.0
            VertRefresh  59.9 - 60.1
            Option      "dpms"
    EndSection
    
    Section "Device"
            Identifier  "aticonfig-Device[0]"
            Driver      "fglrx"
            Option      "VideoOverlay" "on"
    EndSection
    
    Section "Screen"
            Identifier "aticonfig-Screen[0]"
            Device     "aticonfig-Device[0]"
            Monitor    "aticonfig-Monitor[0]"
            DefaultDepth     24
            SubSection "Display"
                    Viewport   0 0
                    Depth     24
            EndSubSection
    EndSection
    
    Section "DRI"
            Mode         0666
    EndSection
    
    Section "Extensions"
            Option      "Composite" "False"
    EndSection
    
    [malc@moabi ~]$
    Thanks
    M.

  8. #38
    leigh123linux Guest
    Quote Originally Posted by mps2006
    Hi Leigh,

    I am using an external display via the DVI port. Its in clone mode. I'd like to keep that if I can and its more important to me than the effects. I will test without the second screen though and see what happens.

    Here is the xorg.conf:

    Code:
    [malc@moabi ~]$ cat /etc/X11/xorg.conf
    # Xorg configuration created by system-config-display
    
    Section "ServerLayout"
            Identifier     "single head configuration"
            Screen      0  "aticonfig-Screen[0]" LeftOf "Screen1"
            InputDevice    "Keyboard0" "CoreKeyboard"
            InputDevice    "Synaptics" "CorePointer"
    EndSection
    
    Section "Module"
            Load  "freetype"
            Load  "dri"
            Load  "glx"
            Load  "extmod"
    EndSection
    
    Section "ServerFlags"
            Option      "AIGLX" "off"
    EndSection
    
    Section "InputDevice"
            Identifier  "Keyboard0"
            Driver      "kbd"
            Option      "XkbModel" "pc105"
            Option      "XkbLayout" "us"
    EndSection
    
    Section "InputDevice"
            Identifier  "Synaptics"
            Driver      "synaptics"
            Option      "Device" "/dev/input/mice"
            Option      "Protocol" "auto-dev"
            Option      "Emulate3Buttons" "yes"
    EndSection
    
    Section "Monitor"
    
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
     ### Comment all HorizSync and VertSync values to use DDC:
            Identifier   "aticonfig-Monitor[0]"
            ModelName    "LCD Panel 1680x1050"
     ### Comment all HorizSync and VertSync values to use DDC:
            HorizSync    31.5 - 90.0
            VertRefresh  59.9 - 60.1
            Option      "dpms"
    EndSection
    
    Section "Device"
            Identifier  "aticonfig-Device[0]"
            Driver      "fglrx"
            Option      "VideoOverlay" "on"
    EndSection
    
    Section "Screen"
            Identifier "aticonfig-Screen[0]"
            Device     "aticonfig-Device[0]"
            Monitor    "aticonfig-Monitor[0]"
            DefaultDepth     24
            SubSection "Display"
                    Viewport   0 0
                    Depth     24
            EndSubSection
    EndSection
    
    Section "DRI"
            Mode         0666
    EndSection
    
    Section "Extensions"
            Option      "Composite" "False"
    EndSection
    
    [malc@moabi ~]$
    Thanks
    M.

    Does Gnome work ok?

    I have found some info for KDE

    Removing unnecessary stuff

    Depending on what you have configured, you won't need to follow all steps below. Check each section accordingly, please.
    Disabling Composite on your current Window Manager

    This step is important to avoid potential problems. Users have reported that KDE Compositing conflicts with Beryl and I don't use Gnome's Compositing but it probably must conflict with Beryl too.

    In KDE, run kcontrol and disable Use translucency/shadows under Translucency, as the image below.


    KDE users, please take the time to choose a simpler kwin-style like plastik. I don't know which themes are dangerous, but I've heard from KDE users that there seems to exist some incompatibilities between some themes and Beryl.
    http://www.nec.fct.unesp.br/marcos_u...l-desktop.html

  9. #39
    Join Date
    Sep 2006
    Posts
    170
    Gnome seems fine - better than before since I have a cube and wobbly windows. beryl would be nice, but this is a good start.

    Doesn't look good for KDE. I had translucency disabled in KDE anyway, since it kept crashing kWin (since compositing is turned off with fglrx).

    X1600 has no acceleration support in mesa yet, so can't go that route unfortuantely.

    thanks for the help
    M.

  10. #40
    leigh123linux Guest
    Quote Originally Posted by mps2006
    Gnome seems fine - better than before since I have a cube and wobbly windows. beryl would be nice, but this is a good start.

    Doesn't look good for KDE. I had translucency disabled in KDE anyway, since it kept crashing kWin (since compositing is turned off with fglrx).

    X1600 has no acceleration support in mesa yet, so can't go that route unfortuantely.

    thanks for the help
    M.
    Have you tried to select beryl in gnome with choosecompositeWM as described here

    http://forums.fedoraforum.org/showpo...0&postcount=18

  11. #41
    Join Date
    Jun 2007
    Location
    Poznan, Poland
    Age
    26
    Posts
    3
    hey i do like it's wrote but the X window was crash and when i do
    logout
    [lorek123@c4-57 ~]$ glxinfo
    glxinfo: error while loading shared libraries: /usr/lib/xorg/libGL.so.1: cannot restore segment prot after reloc: Permission denied
    OR
    [lorek123@c4-57 ~]$ fglrxinfo
    fglrxinfo: error while loading shared libraries: /usr/lib/xorg/libGL.so.1: cannot restore segment prot after reloc: Permission denied
    i have a Fedora 7 and radeon 9550

  12. #42
    leigh123linux Guest
    Quote Originally Posted by lorek123
    hey i do like it's wrote but the X window was crash and when i do


    i have a Fedora 7 and radeon 9550
    The howto is only for FC6 and will not work with FC7.

  13. #43
    Join Date
    Jun 2007
    Location
    Poznan, Poland
    Age
    26
    Posts
    3
    anyone can help me for install ati drivers on F7??

  14. #44
    leigh123linux Guest
    Quote Originally Posted by lorek123
    anyone can help me for install ati drivers on F7??

    Ok

    Try this.

    su -
    rpm -e livna-release-6.rpm
    rpm -Uhv http://rpm.livna.org/livna-release-7.rpm
    yum remove kmod-fglrx xorg-x11-drv-fglrx xorg-x11-drv-fglrx-libs-32bit
    yum install kmod-fglrx xorg-x11-drv-fglrx xorg-x11-drv-fglrx-libs-32bit
    yum update kmod-fglrx xorg-x11-drv-fglrx xorg-x11-drv-fglrx-libs-32bit
    service fglrx restart
    fglrx-config-display enable


    I dont know if the XGL script will work ( I have installed it on FC7 but I cant test due to my Nvidia graphics card )

  15. #45
    Join Date
    Jun 2007
    Location
    Poznan, Poland
    Age
    26
    Posts
    3
    thx for reply and a xorg.conf edit is the same as the for FC6??

Page 3 of 326 FirstFirst 1 2 3 4 5 13 53 103 ... LastLast

Similar Threads

  1. ATI Catalyst fglrx driver manual install on Fedora 12
    By Jeff72 in forum Guides & Solutions (Not For Questions)
    Replies: 15
    Last Post: 13th August 2010, 09:17 PM
  2. ATI Catalyst™ Display Driver v9.12
    By rich52 in forum Hardware & Laptops
    Replies: 1
    Last Post: 31st December 2009, 05:59 AM
  3. HOWTO - make less noise from video card while using fglrx driver
    By multescugeorge@ in forum Guides & Solutions (Not For Questions)
    Replies: 2
    Last Post: 3rd October 2009, 08:02 AM
  4. ATI Catalyst 9.x fglrx driver manual install on Fedora 11
    By Jeff72 in forum Guides & Solutions (Not For Questions)
    Replies: 25
    Last Post: 30th August 2009, 08:29 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •