FedoraForum.org - Fedora Support Forums and Community
Page 2 of 2 FirstFirst 1 2
Results 16 to 20 of 20
  1. #16
    Join Date
    Apr 2008
    Posts
    1

    LVM doesn't work

    I had the same problem using the Fedora 8 DVD

    When the lvm command doesn't react, you should use both lvm and lvresize commands in one line...

    example:
    sh-3.1# lvm lvresize --size 3G /dev/VolGroup00/LogVol00

    Hope this works for you!

  2. #17
    Join Date
    Dec 2005
    Posts
    54
    For FC5, I found the procedure needs one small change ...

    I had no problem unmounting /mnt/sysimage/*, but as the procedure notes, the rescue disk won't let you umount /mnt/sysimage (in my case, /dev/VolGroup00/LogVol00), and you have to add the "-l" ("lazy") argument.

    However the rescue disk's version of umount has a different meaning for the "-l" argument (something related to "loop"), and it wouldn't unmount. I worked around this by redefining my PATH variable, moving all of the /mnt/sysimage directories to the front of the list, before /sbin and /usr/sbin (etc), then I executed "umount -l /mnt/sysimage". After this, everything worked fine. You may want to play it safe, and copy /mnt/sysimage/bin/umount to somewhere like /. I bet that it would fully read /mnt/sysimage/bin/umount before umounting the file system that contained it; it did, but I may have just been lucky.

    I'd also suggest add all the commands you intend to use to a file saved to a thumb drive; also print out the file. Then when you're in the rescue shell, there's a lot less chance of error.

    For those nervous about whether a command has hung ("have I lost my file system?"), I saw these times on a logical volume which I resized from 271G to 240, then resized from 240 to 250:
    * "e2fsck -f /dev/VolGroup00/LogVol00": 5 minutes
    * "resize2fs /dev/VolGroup00/LogVol00 240G": 7 minutes
    * "lvm resize --size 250G VolGroup00/LogVol00: instant
    * "resize2fs /dev/VolGroup00/LogVol00": 1 minute

  3. #18
    Join Date
    Mar 2009
    Posts
    1
    well i fallowed the steps, and it seemed like it worked i used fedora unity feb release 64bit, and after reboot it seemed like everything was working, it was going and booting, and kernel panic happened, half way... i then tried again (reboot) same thing... i went into the rescue disk, to only find at the process to find my linux install that it said it could not find any...

    other commands showed that i had no more LVM at all, there wre no physical or anything left

    i dont know if software raid matters, but i had boot on raid 1, and then swap and then about a 60G raid 5, and lvm on top of that were everything else was installed.

    This was a test install, but still a pain to have lost it, and the biggest problem is i dont know why.

    only error i got, and i do not think its related because im using the drives as regular IDE's not fake raiding them... was when it is supposed to detect the linux install i get an error sil: raid type 253 not supported

    but it pauses and continues just fine, i could do the steps above, just after reboot it went poof

    the raid is there but no sign of lvm

  4. #19
    Join Date
    Apr 2009
    Posts
    1
    You will find there are different versions of lvm on different rescue disks.
    If you get nothing back when typing just 'lvm' then try sending the lvm command you need as a pram. As in:

    lvm lvresize --size 3G /dev/VolGroup00/LogVol00

    Hope this helps....

  5. #20
    Join Date
    Apr 2009
    Posts
    121
    I followed Markkuk's instructions several times to both extend/reduce logical volumes. It works great! But now I would like to install Windows MCE/XP in my unused space of my Volume Group. In order to do this, though, I must first reduce the entire Volume Group. I have never tried lvresize with an entire volume group but only for logical volumes within a volume group. I would simply try running lvresize on the Volume Group as a whole, but noticed in the Logical Volume Management program that my logical volume extents are separated, in my physical volume, by unused space (after recently reducing my /home volume). See my attached image. I wonder what will happen if I simply try running lvresize to reduce the entire Volume Group. Would it be necessary to first move volume extents?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Physical_volume.jpg 
Views:	100 
Size:	33.3 KB 
ID:	18146  
    Fedora 20 64-bit
    CPU AMD|PH II X2 545 3.0G AM3
    nVidia GeForce GT220 video card
    4GB DDR2 Memory

Page 2 of 2 FirstFirst 1 2

Similar Threads

  1. LiveCD Volume to Shrink Error
    By khskinsfan in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 20th June 2009, 07:22 PM
  2. Rescue mode-how to get root
    By SRT in forum Using Fedora
    Replies: 5
    Last Post: 6th August 2006, 07:23 PM
  3. Replies: 9
    Last Post: 30th April 2006, 01:21 PM
  4. Is it possible to shrink a Logical Volume?
    By ajwynn in forum Using Fedora
    Replies: 2
    Last Post: 7th May 2005, 03:11 AM
  5. Shrink volume group?
    By veritas in forum Using Fedora
    Replies: 2
    Last Post: 12th April 2005, 01:55 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •