FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    Join Date
    Sep 2006
    Posts
    17

    fc6 moving the root filesystem to anew partition

    I've installed FC6 on my computer a few months ago, but didn't allocated enugth space for the root flesystem.
    now I can't get any updates or install new software cose my partition is full.
    I've desided to remove windows move my root filesystem to the windows partition.
    so I booted from a live cd and cp -ax my root to the other partition, changed the fstab on the new patition
    and the grub.conf ,
    when I run the system from the new partition it seems to be working fine.
    I get only one warnning from the httpd about not being able to find the www folder under my user home folder.
    but I can't login to the system , trying to login from one of the terminals just jumps back to the login screen withouth showing any error or msg.
    I don't know if it has any thing to do with this but my /home folder is on another partition but every thing is defined in the fstab

  2. #2
    stevea Guest
    I suspect you dont have /home mounted for some reason. This
    would explain both problems.

    Go to a vga console (type ctrl+alt+f1) and login as root.
    Then type "mount" and see if everything is mounted correctly. Something may be
    wrong in /etc/fstab for the /home fs. Not obvious why. Try mounting it again
    "mount -a" and see what messages you get. Maybe the mountpoint "/home"
    is misssing or something.

    I assume you already solved this, but by default FCn mounts the root fs by partition
    label. In /boot/grub/grub.conf you have lines like
    kernel /boot/vmlinuz-2.6.19-1.2911.fc6 ro root=LABEL=/ rhgb quiet
    which must be changed to
    kernel /boot/vmlinuz-2.6.19-1.2911.fc6 ro root=/dev/sda1 rhgb quiet
    or else you'll have to relabel the partitions with e2label

    The same label issue appears in /etc/fstab as
    LABEL=/ / ext3 defaults 1 1
    which should be changed too.



    Note that you'll eventually have to do a grub-install if you have /boot included
    under "/" on the new "/" partition.

  3. #3
    Join Date
    Jan 2006
    Posts
    2,799
    I don't believe the cp command copies the security contexts if you are running Selinux. You can boot by appending selinux=0 to the grub kernel command line. Or you can boot from the linux cd in rescue mode and cd /mnt/sysimage
    touch .autorelabel

    Then boot the from system and it will recreate the file security contexts for selinux.

  4. #4
    Join Date
    Sep 2006
    Posts
    17
    @stevea
    of course I changed all the fstab and grub.conf to point t the righr partition ,an also let grub to take its conf from the new partition.
    any way I couldn't even login as root to see which paartitions were mounted.

    @ JEO
    added selinux=0 to the kernel command , and now the X login worked .
    all the partitions are mounted correctly , but I still get the httpd , error at startup.
    also I couldn't connect to the internet.
    my wirless setting are originally dodgy but worked.
    but running wpa_supplicant at the new filesystem seems to be working ok, but the connection doesn't work.
    also just affter running it wpa_cli can connect to wpa_supplicant with no problem , but if I access it about 30 sec later wpa_cli can't connect to wpa_supplicant even tho running "ps" shows its still running.
    ican also run another wpa_supplicant when the other is running , which is something I can't do when everything working fine

  5. #5
    Join Date
    Jan 2006
    Posts
    2,799
    For the httpd error, it sounds like a permissions problem with some www folder in your home directory. Search the forum I have seen this error before and there is a solution.

    As far as your wireless you might do a complete reinstall of your wireless driver and if that doesn't fix it start a new thread on that topic.

Similar Threads

  1. moving OS to another partition
    By razvan_vlad in forum Servers & Networking
    Replies: 1
    Last Post: 8th February 2007, 06:54 PM
  2. help moving LVM partition to end of harddrive
    By cfjgrind in forum Using Fedora
    Replies: 0
    Last Post: 5th October 2006, 06:15 AM
  3. xfs filesystem on root partition: except to have kernel crash
    By angusmojo in forum Fedora Core 5 - Dev
    Replies: 1
    Last Post: 25th January 2006, 06:15 PM
  4. Moving Root and bootloader
    By CTR_Mint in forum Installation, Upgrades and Live Media
    Replies: 10
    Last Post: 5th October 2005, 01:54 PM
  5. Problems moving root partition (FC4)
    By gryphon in forum Using Fedora
    Replies: 0
    Last Post: 30th June 2005, 09:13 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •