FC6 = Windows!
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 8 of 8
  1. #1
    Join Date
    Mar 2007
    Posts
    15

    Angry FC6 = Windows!

    Sorry, but my one-week experience trying to get FC6 working has me wondering if the DVD I have came from Seattle! I have a RH7.2 system that's been running since 2000, and a RH8 since 2005, but I don't consider myself a LInux expert, just reasonably competent. I'm trying to get FC6 on the RH8 machine (different partition), but if I leave it alone (no applications running) for an hour or two, it slows to a crawl and then eventually stops altogether (no response to any input). It won't even shutdown (hence, the analogy to Windows). I've reinstalled many times, I've installed all the upgrades and tried not installing any upgrades, and the result is always the same. It motors along fine for a while, as I busily copy my RH8 user files over (mailboxes, address book, bookmarks, images, etc.). Then, at some point, usually after walking away for a few hours, I'll come back, hit a key to get out of the screen saver, enter my password, and the machine will just sit there. If it eventually gives me the desktop, everything is excrutiatingly slow, to the point where I finally give up, power off and reboot to my RH8 installation.

    Machine is 1GB Pentium 4, installing FC6 on 64GB logical on hda (RH8 is on hdb). At various times, I would boot the install DVD (from "Fedora 6 and RHEL Bible" book) and the X-server would fail, but rebooting the DVD usually got it working, and once I got a successful install the X-server would never fail (another Windows-like quirk). The couple times I've been able to run the system monitor as it slows, it shows only 6-7 GB in use, and almost no swap in use, and nothing to indicate a system in distress.

    I'm stumped and frustrated, as I've never had this much trouble with a Linux installation before. Can anyone offer any suggestions on why this particular system can get so slow when nothing is happening?

  2. #2
    Join Date
    Feb 2007
    Posts
    318
    Turn off all services that you don't need. I had a similar problem and it turned out to be related to the cpuspeed service. It's a silly little thing, actually. Once I uninstalled it, the problem went away.

    Of course, you still want to go through and disable others that you don't need. That will just save a lot of resources.

  3. #3
    brentley Guest
    As mentioned, shut down all services that aren't necessary... you didn't do an "everything" install did you?

    Also, there is a service called "beagle" that indexes your drives... it is loaded when you log in, but doesn't start indexing untill several minutes after your login. Maybe the system is bogged down indexing your stuff. Given enough time, once everything is indexed, it shouldn't have any problems keeping up with new documents.

    Alternatively, figure out how to disable Beagle, and see if that helps.

  4. #4
    Join Date
    Feb 2007
    Posts
    318
    Ah, yes. Beagle. I hate that stupid thing. I shot that dog a long time ago.

    For me, I know where all my documents are. I don't need an indexing service.

  5. #5
    Join Date
    Jun 2005
    Location
    Westminster, Colorado
    Posts
    2,306
    "yum remove beagle" is one of the first things I do on any new installation. I hate that piece of crap.
    Registered Linux User #4837
    411th in line to get sued by Micro$oft
    Basically, to learn Unix you learn to understand and apply a small set of key ideas and achieve expertise by expanding both the set of ideas and your ability to apply them - Paul Murphy

  6. #6
    Join Date
    Sep 2004
    Age
    42
    Posts
    40
    Just a quick note on memory usage. Check if there really is some application using it. Since 2.6 kernel uses memory for cache and I/O buffer. So, even if its using alot, it will free if something needs memory. Its a way to make things faster...

    Have you read the Release Notes? Maybe there's something there regarding you system hardware. There are always (un)known issues... ALWAYS
    ---
    Proud GNU/Linux user since 1995.

  7. #7
    Join Date
    Mar 2007
    Posts
    15
    OK, I've removed cpuspeed and rebooted. So far, so good. However, after using "Add/Remove Software" a few times (had to go back to a previous version of Eclipse), now, when I click on that menu item, it requests the root password, the dialog closes, and then nothing happens! I then opened a terminal session, su'd to root, and entered "yum remove beagle", and it just sat there with a blinking cursor. I've been pretty busy today setting up my FC6, so I haven't had a chance to leave the system sitting for a few hours, but I'm hoping at least that problem is fixed. If anyone knows what the problem is with pirut, please let me know (or do I still have my FC6 = Windows problem, and I need to reboot ...).

  8. #8
    Brass Guest

    I had the same speed problem

    I had the same problem but.....

    I found that my ASUS laptop was hiding a bus behind another bus and that indeed the hidden bus was the AGP bus.

    added pci=assign-busses to the grub config imediately after the ro ( for read only ), problem solved.

    And your right it was slow enough to make you think the machine had crashed at times.

Similar Threads

  1. Windows XP & Fedora 11 dual-boot problem (using Windows bootloader)
    By zmdmw52 in forum Installation, Upgrades and Live Media
    Replies: 7
    Last Post: 9th August 2009, 07:29 AM
  2. Replies: 7
    Last Post: 24th January 2009, 11:28 PM
  3. Replies: 0
    Last Post: 15th May 2008, 02:13 PM
  4. Replies: 2
    Last Post: 1st October 2006, 06:40 PM
  5. Format the windows parttion and installing Windows 2000 server again with Fedroa
    By niloshima in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 22nd June 2004, 12:44 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •