MPlayer 1.0rc1 not load TTF
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 7 of 7
  1. #1
    urke Guest

    MPlayer 1.0rc1 not load TTF

    I have installed:

    mplayer-1.0-0.69.rc1.lvn6
    mplayer-fonts-1.1-4.lvn6
    mplayer-gui-1.0-0.69.rc1.lvn6
    freetype-2.2.1-16.fc6
    freetype-devel-2.2.1-16.fc6

    Until latest yum -y update all worked OK, but. From today morning mplayer won't load truetype fonts for subtitle display.

    Settings in ~/.mplayer/config that worked yesterday, today not work. Instead of Myriad Pro Condensed, mplayer loads some (default?) font that is wide (I think that is DejaVu), and ignore even if I specify mplayer -font /home/urke/.mplayer/myriad.ttf movie.avi.

    Do anyone else have this problem? What can be solution to this work again?

    And, yes, myriad.tty IS in my ~/.mplayer dyrectory, readable. There is no any warrning or error, just font is not loaded, not displayed. Mplayer is linked to freetype library:

    Code:
    [urke@urosevic Ignition]$ ldd /usr/bin/mplayer |grep freetype
            libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00d48000)
    [urke@urosevic Ignition]$ ll /usr/lib/libfreetype.so.6
    [urke@urosevic Ignition]$ ll /usr/lib/libfreetype.so.6
    lrwxrwxrwx 1 root root 21 Dec 10 23:10 /usr/lib/libfreetype.so.6 -> libfreetype.so.6.3.10
    Help me please. TIA

  2. #2
    alpha645 Guest
    http://forums.fedoraforum.org/showthread.php?t=146722

    Try the commands in the first post of this thread. High chance it's related.

  3. #3
    urke Guest
    I do that before starting this thread, but, no, that not helped

  4. #4
    alpha645 Guest
    Quote Originally Posted by urke
    I do that before starting this thread, but, no, that not helped
    Open a terminal and type:

    gmplayer

    Now, try to reproduce the error. And then, copy the entire terminal content inside this thread as a new post.

  5. #5
    urke Guest
    There is output from gmplayer:

    Code:
    MPlayer 1.0rc1-rpm.livna.org-4.1.1 (C) 2000-2006 MPlayer Team
    CPU: AMD Sempron(tm) Processor 2800+ (Family: 15, Model: 44, Stepping: 2)
    CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
    Compiled with runtime CPU detection.
    xscreensaver_disable: Could not find XScreenSaver window.
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support. You will not be able to use your remote control.
    
    Playing /home/urke/tmp/filmovi/01 NOVO/Ignition/Ignition.avi.
    AVI file format detected.
    Forced NON-INTERLEAVED AVI file format.
    VIDEO:  [DIV3]  640x360  24bpp  25,000 fps  919,2 kbps (112,2 kbyte/s)
    SUB: Detected subtitle file format: subviewer
    SUB: Read 835 subtitles.
    SUB: Added subtitle file (1): /home/urke/tmp/filmovi/01 NOVO/Ignition/Ignition.srt
    xscreensaver_disable: Could not find XScreenSaver window.
    ==========================================================================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffdivx] vfm: ffmpeg (FFmpeg DivX ;-) (MS MPEG-4 v3))
    ==========================================================================
    ==========================================================================
    Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
    AUDIO: 44100 Hz, 2 ch, s16le, 96,0 kbit/6,80% (ratio: 12000->176400)
    Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
    ==========================================================================
    AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
    Starting playback...
    VDec: vo config request - 640 x 360 (preferred colorspace: Planar YV12)
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is undefined - no prescaling applied.
    VO: [xv] 640x360 => 640x360 Planar YV12
    A: 281,4 V: 281,4 A-V:  0,002 ct:  0,001 7037/7037  3%  1%  0,9% 1 0
    And there is my testing subfont (Cambria) and what I see in gmplayer/mplayer:


  6. #6
    alpha645 Guest
    Try disabling your screensaver, but I doubt that will help. And try this:
    http://www.mplayerhq.hu/DOCS/HTML/en/fonts-osd.html

  7. #7
    urke Guest

    Thumbs up Solved!

    Thanks man. That is it. fontconfig is compiled so subfont.ttf have not effect, but this help:
    Code:
    mplayer -font 'Myriad Pro Cond' movie.avi
    Now I put in ~/.mplayer/config this:
    Code:
    font = 'Myriad Pro Cond'
    And now mplayer use Myriad Pro Cond for OSD font.

    Thanks a lot!

Similar Threads

  1. mplayer cannot load subtitles
    By ilbh in forum Using Fedora
    Replies: 1
    Last Post: 2nd June 2006, 03:51 PM
  2. Replies: 2
    Last Post: 12th May 2006, 05:48 PM
  3. Replies: 0
    Last Post: 2nd April 2006, 04:39 AM
  4. FC4 install hangs at load aic7xxxx driver load
    By jboris in forum EOL (End Of Life) Versions
    Replies: 0
    Last Post: 14th March 2006, 08:32 PM
  5. Replies: 2
    Last Post: 16th January 2005, 02:25 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •