spamd/spamc-combination MUCH too slow
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    Bear Knuckle Guest

    spamd/spamc-combination MUCH too slow

    Hi!

    I am using evolution for my mails and spamassassin to filter junk.

    As I recognized (long time before on SuSE 8.2) using "spamassassin" for filtering is very slow, so I started the "spamd"-daemon and used "spamc" to communicate with the daemon to filter the mails. That worked pretty fast compared to "spamassassin".

    Now I installed Fedora Core 1 and used apt-get to install spamassassin 2.63. Started the "spamd"-service and evolution and the filtering is soooooo slow... using "spamassassin" can not be slower.

    I don't know how to fix this. Any suggestions?

  2. #2
    Jman Guest
    What are the specs of the machine you're using, especially processor and memory?

    I've found out that spamd is in perl. Try running a resource monitor like top or System Tools > System Monitor. While filtering perl should take up a lot of memory and cpu.

  3. #3
    Bear Knuckle Guest
    Originally posted by Jman
    What are the specs of the machine you're using, especially processor and memory?

    I've found out that spamd is in perl. Try running a resource monitor like top or System Tools > System Monitor. While filtering perl should take up a lot of memory and cpu.
    I had working it better on slower machines. At the moment I have a Athlon XP 2800+ and 1024MB RAM.

    But I think I found it. I disabled the firewall and now it seems to be as fast as I expect it to be. I don't know much about firewalls under Linux, I was just surprised that it is activated by default under fedora for I know it is not as easy to administrate a firewall under Linux as under Windows. So I will take a closer look at firewalls now, but until I don't understand em and they slow my traffic-processing I will have it deactivated.
    Last edited by Bear Knuckle; 20th April 2004 at 09:04 AM.

  4. #4
    Jman Guest
    With that machine, I'm not suprised it was the firewall. I'm jealous.

    Your network requests must have timed out or been denied or something.

    I recommend Firestarter to configure a firewall. It's See my recent howto on installing it.

  5. #5
    Bear Knuckle Guest
    Originally posted by Jman
    With that machine, I'm not suprised it was the firewall. I'm jealous.

    Your network requests must have timed out or been denied or something.


    Thats the thing I don't understand. The filtering worked correctly, it was just very very slow. I don't know how the packets could get stuck like that.

    I recommend Firestarter to configure a firewall. It's See my recent howto on installing it.
    Thx for that, I will take a look at that.

  6. #6
    skennedy Guest
    Heh, found this in a google cache, and I have no idea how old it is....

    Oh well, my advice is still good.

    If you want to see a marked improvement in speed with the spamd/spamc pair, you need to set them up to use a pipe.

    So you'd start spamd like this:

    /usr/bin/spamd --socketpath=/tmp/spamd

    and then use this option on spamc

    spamc -U /tmp/spamd < message

    Testing it out right now ( on single messages, mind you ), I'm seeing a three fold speed increase ( approx ).

    Enjoy

Similar Threads

  1. SPAMC not working when SPAMD started with -A
    By gvarney in forum Using Fedora
    Replies: 0
    Last Post: 4th October 2005, 12:13 AM
  2. Problem with SPAMC/SpamAssassin
    By gvarney in forum Using Fedora
    Replies: 0
    Last Post: 14th April 2005, 06:49 PM
  3. find ./ -exec spamc < {} \; <-- Not working
    By skennedy in forum Using Fedora
    Replies: 1
    Last Post: 4th June 2004, 07:58 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •