FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    Nov 2006
    Posts
    22

    I have multiple version of QT installed, but qmake uses the oldest one

    I have version 3.3.7 of QT, and one of the packages I want to install requires 4 or higher. I downloaded qt4 through yum, and now in my /usr/lib/ directory there is qt-3.3.7/ and qt4/. I also build the newest version from source, and that installed to /usr/local/Trolltech/Qt-4.2.2/.

    When I try to install the 3.3.7 version of QT through yum, it tells me it will have to remove a bunch of packages that depend on it. I don't really want to have to reinstall tons of stuff.

    Also, yum sees qt-3.3.7 as a different package than qt4, and it also doesn't have any available upgrades for qt-3.3.7.

    At the very least, how can I make my system start using QT-4.2.2 instead of 3.3.7? I changed the $QTDIR variable but that didn't really help. I would like to untangle all of this and just have one, new version of QT that works correctly.

  2. #2
    Join Date
    Nov 2006
    Posts
    22
    Bump .

  3. #3
    Join Date
    Nov 2006
    Posts
    22
    Anyone????

  4. #4
    Join Date
    Jul 2005
    Location
    Roma
    Age
    75
    Posts
    210
    if you install qt, qt-devel and qt4, qt4-devel you will have qmake (from qt-devel) and qmake_qt4
    (from qt4-devel)
    Bruno Taglienti

Similar Threads

  1. qmake or qmake-qt4 x86_64 QT4?
    By Anniedog in forum Programming & Packaging
    Replies: 4
    Last Post: 20th March 2011, 06:59 AM
  2. Replies: 4
    Last Post: 21st July 2008, 10:55 PM
  3. qmake/qt version to old?
    By stephanie.steve in forum Using Fedora
    Replies: 2
    Last Post: 25th June 2007, 05:25 AM
  4. Replies: 3
    Last Post: 30th April 2007, 04:15 AM
  5. multiple version of packages installed
    By bakwas_internet in forum Using Fedora
    Replies: 1
    Last Post: 21st March 2004, 07:53 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •