problem with mod_auth_mysql , apache 2.2
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    jre Guest

    problem with mod_auth_mysql , apache 2.2

    Hi I am having a problem with using mod_auth_mysql with apache 2.2

    I have managed to get authentication working but whenever anyone accesses the areas of the site which are protected the error log file is filled with

    [error] Internal error: pcfg_openfile() called with NULL filename


    The appropriate bits of the httpd.conf look like

    #Stuff for Munit monitoring

    ScriptAlias /monitoring/cgi "/usr/local/munin/var/www/cgi/"
    Alias /monitoring "/usr/local/munin/var/www/"

    <Directory /usr/local/munin/var/www/>
    #mod_auth_mysql stuff

    AuthName "xxxxx"
    AuthType Basic
    AuthBasicAuthoritative Off
    AuthMySQLHost localhost
    AuthMySQLDB http_auth
    AuthMySQLPasswordField user_passwd
    AuthMySQLUserTable http_auth_users
    AuthMySqlUser xxxx
    AuthMySqlPassword xxxx
    AuthMySQLEnable On
    AuthMySQLPwEncryption MD5
    AuthMySQLAuthoritative On
    require valid-user

    </Directory>

    <Directory /usr/local/munin/var/www/cgi>
    AllowOverride none
    Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all



    </Directory>


    Anyone have any ideas why its giving this error message

    Thanks

    J.

  2. #2
    cyfdecyf Guest
    Try to add the following in <Directory ...> ... </Directory>

    AuthUserFile /dev/null

    If that makes your authentication fail, then consider using apache 2.0.

    When I am using apache 2.2.3, besides the message you got, I've also got the following

    [error] [client 127.0.0.1] (9)Bad file descriptor: Could not open password file: (null)

    My authentication doesn't work either. I've battled it for several days and at last solved this problem under windowz with xampp 1.5.0. Under Linux however, xampp doesn't contain the module and I have to compile the module by myself. And finally the problem was solved under Linux (I am not using FC so I don't have the precompiled module)

    When I was googling this problem, I found there are many people with this problem and their configuration are almost the same. So I guess mod_auth_mysql works well with apache 2.0 but not apache 2.2. ( I even wasn't able to compile the module against apache 2.2, always have compile error) Maybe I am wrong.
    Last edited by cyfdecyf; 26th October 2006 at 02:54 AM.

  3. #3
    jre Guest
    Your suggestion does stop the error messages and authentication still works.

    I used an unofficial patch to mod_auth_mysql to get it to compile with apache 2.2.2.

    Thanks for the help

    J.

  4. #4
    cyfdecyf Guest
    You are welcome.

    And I am interested with the patch to make mod_auth_mysql work with apache 2.2, I will give it a try.

    Is the patch you used from Andrew's diary? here
    Last edited by cyfdecyf; 27th October 2006 at 01:51 PM.

Similar Threads

  1. APACHE problem
    By jeesan in forum Servers & Networking
    Replies: 16
    Last Post: 30th August 2008, 09:16 AM
  2. mod_auth_mysql on FC4
    By bruno.vernay in forum Servers & Networking
    Replies: 0
    Last Post: 4th October 2006, 11:09 AM
  3. mod_auth_mysql
    By scobbiescott in forum Using Fedora
    Replies: 0
    Last Post: 7th October 2005, 06:57 PM
  4. apxs -i mod_auth_mysql.so question
    By Secret Agent in forum Servers & Networking
    Replies: 5
    Last Post: 23rd January 2005, 10:43 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •