FedoraForum.org - Fedora Support Forums and Community
Page 4 of 20 FirstFirst ... 2 3 4 5 6 14 ... LastLast
Results 46 to 60 of 291
  1. #46
    Join Date
    Dec 2007
    Posts
    23
    Quote Originally Posted by Reindeer
    I have the very same question.
    Yum is giving me an error when I try to install the latest round of nVidia drivers:


    --> Running transaction check
    ---> Package kmod-nvidia-96xx.x86_64 0:96.43.01-1.2.6.23.8_34.fc7 set to be updated
    --> Processing Conflict: xorg-x11-drv-nvidia-96xx conflicts xorg-x11-drv-nvidia
    --> Processing Conflict: xorg-x11-drv-nvidia conflicts xorg-x11-drv-nvidia-96xx
    --> Restarting Dependency Resolution with new changes.
    ---> Loop Number: 2
    --> Running transaction check
    --> Finished Dependency Resolution
    Error: xorg-x11-drv-nvidia-96xx conflicts with xorg-x11-drv-nvidia


    Looking at some of the troubles that others are having installing the latest nVidia drivers,
    I am loathe to upset my working system.
    Does anyone know which drivers are the right ones for 64bit Fedora 7 ?

    I'm currently using 100.14.19 on Xorg version 1.3.0 with a GeForce 7600 GT
    From experience it seems to me that if you want to switch from one flavour (kmod-nvidia, kmod-nvidia-96xx, kmod-nvidia-legacy) of driver to another, that you have to remove the old drivers first, then install. That worked for me.

    Also, while I do not claim to be expert on this, if I was choosing drivers for another nvidia card, I'd start with the newest ones and move to older ones until I found one that worked. There are only three choices really.

  2. #47
    Join Date
    Jan 2008
    Posts
    13
    wtf is a cc tool?
    i've tryed to install nvidia driver and it gives me a error: cannotfind cc tool (or smth)

  3. #48
    Join Date
    Feb 2008
    Posts
    1
    I don't know if this was previously talked about, but I noticed that my fedora 8 server wasn't booting up without a monitor screen attached to it. I googled around and found out that Apple Computers (makes sense since they are also Unix Based) have the same "problem". The solution: install an external video card. I used an ATI Rage 128 and it seems that even if I turn off the computer, without a screen and even cutting power to power supply and then restart the whole thing: the x-server still boots to login screen perfectly.
    Please bear in mind that the PC boots automaticaly to a user, with remote desktop running. From there I control it through a VNC viewer. The problem I had resulted in x-server saying my resolution wasn't ok, and hung at that point. I couldn't never connect in such condition and it was not feasible to leave a monitor with the PC for the sole purpose of allowing the boot.

  4. #49
    Join Date
    Feb 2008
    Location
    WA.
    Posts
    3

    Nvidia graphics card still wont work

    ok, i am brand new to linux, so barney style answers and tips will be great, but at this point i will take anything.

    i have read everything i can find on problems with the nvidia graphics cards, i have tried everything i have read but i am still having no luck.

    Nvidia GeForce Go 7900 GS is the make and model, fedora core 7 gnome is the version of linux, on an alienware m9750 laptop.

    just to clarify.... the "yum -y install kmod-nvidia glx-utils" didnt work
    "yum install kmod-nvidia-96xx" didnt work

    and the driver downloaded from nvidia with the "/sbin/telinit 3" ......ect didnt work either (and i have done a yum install of kernel-devel)

    i tried reading all i can and searching for the answer so i wouldnt have do put another nvidia graphics card post up but i dont know what else to do at this point. please help

  5. #50
    Join Date
    Sep 2006
    Location
    Connellsville, PA, USA
    Posts
    11,307
    Hello:

    First, if you have tried to install the binary driver provided by nvidia from their website, you have probably screwed up your install - see the link in the very first post of this thread. If true, you will probably need to re-install all the OpenGL-type stuff. Sad, but true.

    Second, please clarify "...didn't work..." Did kmod-nvidia and/or glx-utils fail to install? If so, why, failed dependencies? Or were the packages not found (you must first install the Livna repo). BTW, your card is supported by the latest driver, so don't use the kmod-nvidia-96xx legacy driver.

    Last, you may need to read a little more: http://forums.fedoraforum.org/showthread.php?t=99285.
    See also: http://www.mjmwired.net/resources/mj...f7.html#nvidia.

    Regards,
    V

  6. #51
    Join Date
    Feb 2008
    Location
    WA.
    Posts
    3
    so i tried the first link Hlingler gave me and this is exactly what the outcome was, i do not know where to go from here. this is the same end result i recieved when i attempted the kmod-nvidia glx-utils install.

    [kbryan@localhost ~]$ su -
    Password:
    [root@localhost ~]# rpm -Uhv http://rpm.livna.org/livna-release-7.rpm
    Retrieving http://rpm.livna.org/livna-release-7.rpm
    warning: /var/tmp/rpm-xfer.RDtAq6: Header V3 DSA signature: NOKEY, key ID a109b1ec
    Preparing... ########################################### [100%]
    1:livna-release ########################################### [100%]
    [root@localhost ~]# yum install kmod-nvidia xorg-x11-drv-nvidia xorg-x11-drv-nvidia-libs-32bit
    Loading "installonlyn" plugin
    Setting up Install Process
    Parsing package install arguments
    livna 100% |=========================| 2.1 kB 00:00
    primary.sqlite.bz2 100% |=========================| 190 kB 00:52
    Resolving Dependencies
    --> Running transaction check
    ---> Package xorg-x11-drv-nvidia-libs.i386 0:169.09-3.lvn7 set to be updated
    ---> Package xorg-x11-drv-nvidia.i386 0:169.09-3.lvn7 set to be updated
    Importing additional filelist information
    filelists.sqlite.bz2 100% |=========================| 1.1 MB 07:18
    http://ftp.gts.lug.ro/fedora/linux/r...ts.sqlite.bz2: [Errno 4] Socket Error: timed out
    Trying other mirror.
    filelists.sqlite.bz2 100% |=========================| 344 kB 05:55
    http://mirror.lib.ucdavis.edu/fedora...ts.sqlite.bz2: [Errno 4] Socket Error: timed out
    Trying other mirror.
    filelists.sqlite.bz2 100% |=========================| 6.4 MB 37:50
    filelists.sqlite.bz2 100% |=========================| 268 kB 01:53
    filelists.sqlite.bz2 100% |=========================| 1.9 MB 11:13
    http://ftp.uni-bayreuth.de/linux/fed...ts.sqlite.bz2: [Errno 4] Socket Error: timed out
    Trying other mirror.
    filelists.sqlite.bz2 100% |=========================| 5.0 MB 39:39
    ---> Package kmod-nvidia.i686 0:169.09-3.2.6.23.14_64.fc7 set to be updated
    --> Processing Dependency: kernel-i686 = 2.6.23.14-64.fc7 for package: kmod-nvidia
    --> Processing Dependency: livna-config-display for package: xorg-x11-drv-nvidia
    --> Restarting Dependency Resolution with new changes.
    --> Running transaction check
    ---> Package kernel.i686 0:2.6.23.14-64.fc7 set to be updated
    ---> Package livna-config-display.noarch 0:0.0.20-1.lvn7 set to be updated
    --> Processing Dependency: mkinitrd >= 6.0.9-7.1 for package: kernel
    --> Restarting Dependency Resolution with new changes.
    --> Running transaction check
    ---> Package mkinitrd.i386 0:6.0.9-7.1 set to be updated
    --> Processing Dependency: nash = 6.0.9-7.1 for package: mkinitrd
    --> Restarting Dependency Resolution with new changes.
    --> Running transaction check
    ---> Package nash.i386 0:6.0.9-7.1 set to be updated

    Dependencies Resolved

    ================================================== ===========================
    Package Arch Version Repository Size
    ================================================== ===========================
    Installing:
    kmod-nvidia i686 169.09-3.2.6.23.14_64.fc7 livna 2.6 M
    xorg-x11-drv-nvidia i386 169.09-3.lvn7 livna 1.9 M
    xorg-x11-drv-nvidia-libs i386 169.09-3.lvn7 livna 5.0 M
    Installing for dependencies:
    kernel i686 2.6.23.14-64.fc7 updates 16 M
    livna-config-display noarch 0.0.20-1.lvn7 livna 65 k
    Updating for dependencies:
    mkinitrd i386 6.0.9-7.1 updates 91 k
    nash i386 6.0.9-7.1 updates 158 k

    Transaction Summary
    ================================================== ===========================
    Install 5 Package(s)
    Update 2 Package(s)
    Remove 0 Package(s)

    Total download size: 26 M
    Is this ok [y/N]: y
    Downloading Packages:
    (1/7): livna-config-displ 100% |=========================| 65 kB 00:30
    (2/7): xorg-x11-drv-nvidi 100% |=========================| 312 kB 03:21
    http://rpm.livna.org/fedora/7/i386/x...lvn7.i386.rpm: [Errno 4] Socket Error: timed out
    Trying other mirror.
    (2/7): xorg-x11-drv-nvidi 100% |=========================| 5.0 MB 37:37
    (3/7): kernel-2.6.23.14-6 100% |=========================| 16 MB 91:26
    (4/7): mkinitrd-6.0.9-7.1 100% |=========================| 91 kB 00:44
    (5/7): kmod-nvidia-169.09 100% |=========================| 2.6 MB 16:54
    (6/7): nash-6.0.9-7.1.i38 100% |=========================| 158 kB 00:58
    (7/7): xorg-x11-drv-nvidi 100% |=========================| 1.9 MB 10:33
    warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID a109b1ec
    Importing GPG key 0xA109B1EC "Livna.org rpms <rpm-key@livna.org>" from /etc/pki/rpm-gpg/RPM-GPG-KEY-livna
    Is this ok [y/N]: y
    warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
    Importing GPG key 0x4F2A6FD2 "Fedora Project <fedora@redhat.com>" from /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
    Is this ok [y/N]: y
    Running Transaction Test
    Finished Transaction Test
    Transaction Test Succeeded
    Running Transaction
    Updating : nash ######################### [1/9]
    Updating : mkinitrd ######################### [2/9]
    Installing: kernel ######################### [3/9]
    Installing: livna-config-display ######################### [4/9]
    Installing: xorg-x11-drv-nvidia-libs ######################### [5/9]
    Installing: kmod-nvidia ######################### [6/9]
    Installing: xorg-x11-drv-nvidia ######################### [7/9]
    Cleanup : nash ######################### [8/9]
    Cleanup : mkinitrd ######################### [9/9]

    Installed: kmod-nvidia.i686 0:169.09-3.2.6.23.14_64.fc7 xorg-x11-drv-nvidia.i386 0:169.09-3.lvn7 xorg-x11-drv-nvidia-libs.i386 0:169.09-3.lvn7
    Dependency Installed: kernel.i686 0:2.6.23.14-64.fc7 livna-config-display.noarch 0:0.0.20-1.lvn7
    Dependency Updated: mkinitrd.i386 0:6.0.9-7.1 nash.i386 0:6.0.9-7.1
    Complete!
    [root@localhost ~]# yum -y update kmod-nvidia xorg-x11-drv-nvidia xorg-x11-drv-nvidia-libs-32bit
    Loading "installonlyn" plugin
    Setting up Update Process
    fedora 100% |=========================| 2.1 kB 00:00
    livna 100% |=========================| 2.1 kB 00:00
    primary.sqlite.bz2 100% |=========================| 191 kB 00:46
    ftp://mirror.cs.princeton.edu/pub/mi...ta/repomd.xml: [Errno 4] IOError: [Errno ftp error] 421 Sorry, mirror already has 22 users logged on. Try again in 10 minutes.
    Trying other mirror.
    updates 100% |=========================| 2.3 kB 00:00
    Could not find update match for kmod-nvidia
    Could not find update match for xorg-x11-drv-nvidia-libs-32bit
    Resolving Dependencies
    --> Running transaction check
    filelists.sqlite.bz2 100% |=========================| 268 kB 01:26
    ---> Package xorg-x11-drv-nvidia.i386 0:169.09-4.lvn7 set to be updated
    --> Processing Dependency: xorg-x11-drv-nvidia = 169.09-3.lvn7 for package: xorg-x11-drv-nvidia-libs
    --> Processing Dependency: xorg-x11-drv-nvidia-libs = 169.09-4.lvn7 for package: xorg-x11-drv-nvidia
    --> Restarting Dependency Resolution with new changes.
    --> Running transaction check
    ---> Package xorg-x11-drv-nvidia-libs.i386 0:169.09-4.lvn7 set to be updated

    Dependencies Resolved

    ================================================== ===========================
    Package Arch Version Repository Size
    ================================================== ===========================
    Updating:
    xorg-x11-drv-nvidia i386 169.09-4.lvn7 livna 1.9 M
    Updating for dependencies:
    xorg-x11-drv-nvidia-libs i386 169.09-4.lvn7 livna 5.0 M

    Transaction Summary
    ================================================== ===========================
    Install 0 Package(s)
    Update 2 Package(s)
    Remove 0 Package(s)

    Total download size: 6.9 M
    Downloading Packages:
    (1/2): xorg-x11-drv-nvidi 100% |=========================| 5.0 MB 24:28
    (2/2): xorg-x11-drv-nvidi 100% |=========================| 1.9 MB 08:24
    Running Transaction Test
    Finished Transaction Test
    Transaction Test Succeeded
    Running Transaction
    Updating : xorg-x11-drv-nvidia-libs ######################### [1/4]
    Updating : xorg-x11-drv-nvidia ######################### [2/4]
    Cleanup : xorg-x11-drv-nvidia ######################### [3/4]
    Cleanup : xorg-x11-drv-nvidia-libs ######################### [4/4]

    Updated: xorg-x11-drv-nvidia.i386 0:169.09-4.lvn7
    Dependency Updated: xorg-x11-drv-nvidia-libs.i386 0:169.09-4.lvn7
    Complete!
    [root@localhost ~]# service nvidia restart

    [root@localhost ~]# service nvidia restart
    Checking for module nvidia.ko: [FAILED]
    nvidia.ko for kernel 2.6.20-2925.9.fc7xen was not found. [WARNING]
    The nvidia driver will not be enabled until one is found. [WARNING]
    Driver already disabled.
    You have new mail in /var/spool/mail/root

    what do i do to fix or undo this?

  7. #52
    Join Date
    Sep 2006
    Location
    Connellsville, PA, USA
    Posts
    11,307
    Reboot to the new kernel - your new kmod-nvidia driver module is for that kernel only.

    V

  8. #53
    Join Date
    Feb 2008
    Location
    WA.
    Posts
    3
    well if thats the case then i would love to give it a shot...... but how exactly do i reboot to the new kernel? dummy steps please, im new at this

  9. #54
    Join Date
    Feb 2005
    Location
    Ottawa ,Canada
    Posts
    459
    When you reboot the newest kernel is at the top of the list but that is only if you hit a key to stop the default kernel boot which is the latest one.
    Welcome to circleland it should be that simple

    Enjoy the Choice
    Enjoy the Choice:)
    Q8200/Asus P5QDLDX/8G ram/500G HD f10/Zotac gt640 2G
    XP2500 Barton/AsusA7N8X Deluxe/768M RAM/6800gt 128M WinXPpro SP3 120 Gb ntft f10 80 Gb ext3

  10. #55
    Join Date
    Sep 2006
    Location
    Connellsville, PA, USA
    Posts
    11,307
    Quote Originally Posted by kbryan
    well if thats the case then i would love to give it a shot...... but how exactly do i reboot to the new kernel? dummy steps please, im new at this
    Find the button somewhere on the menu that says "Shutdown", and press it. You should be given a choice to logout, restart, or shutdown. Choose restart. When the computer reboots, you will first see the BIOS loading, followed by GRUB (the bootloader) - it's a very blue background. It lists the available boot choices (different kernels and/or operating systems). You have a few seconds to make a choice before it loads the default item. Make sure that the newest kernel is highlighted, or use the arrow keys to pick the newest kernel. Hit <enter>.

    If the latest kernel was not highlighted by default, you can change that behavior, too. Once you're all logged in and back at a running desktop, find on the menus: Bootloader config. It's a very simple GUI - it lists the same choices that you saw when GRUB was loading, and you get to pick the default item and the countdown timer setting. That's all there is to it.

    Regards,
    V

  11. #56
    Join Date
    Feb 2008
    Posts
    9
    I have a nvidia 4000 mx series card. Installed livna legacy drivers. How to configure xorg.conf? It looks like this now..
    # Xorg configuration created by system-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    EndSection

    Section "Files"
    ModulePath "/usr/lib/xorg/modules"
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "off"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us+inet"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "nvidia"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "Extensions"
    Option "Composite" "Disable"
    EndSection

    Please Help.

  12. #57
    Join Date
    Sep 2006
    Location
    Connellsville, PA, USA
    Posts
    11,307
    Quote Originally Posted by snm_cal
    I have a nvidia 4000 mx series card. Installed livna legacy drivers. How to configure xorg.conf? It looks like this now..
    It usually helps to know what flavor of Fedora you're running, since this can make a difference.

    There is an excellent HOWTO by the guy that builds the Livna nvidia drivers (FireWing1) here: http://forums.fedoraforum.org/showthread.php?t=99285. NOTE the first line (in red) redirecting you to his own website for the latest revisions of the HOWTO for F7/8. I strongly recommend that you consult them (they're actually fairly short and simple). If you have problems after that, you can post to that thread, where FireWing1 will see your post and hopefully respond.

    Regards,
    V

  13. #58
    Join Date
    Feb 2008
    Location
    CA
    Posts
    141
    so i have geforce 7150m and im haveing problems hahah i cant get it to work sometimes. i have to reinstalland re configure the driver everytime.. i tried to dl kmod-nvidia

    Code:
    WARNING: /lib/modules/2.6.23.15-137.fc8/kernel/sound/drivers/opl3/snd-opl3-synth.ko needs unknown symbol strlcpy
    WARNING: /lib/modules/2.6.23.15-137.fc8/kernel/sound/drivers/opl3/snd-opl3-synth.ko needs unknown symbol param_set_bool
    WARNING: /lib/modules/2.6.23.15-137.fc8/kernel/sound/drivers/opl3/snd-opl3-synth.ko needs unknown symbol printk
    WARNING: /lib/modules/2.6.23.15-137.fc8/kernel/sound/drivers/opl3/snd-opl3-synth.ko needs unknown symbol memset
    WARNING: /lib/modules/2.6.23.15-137.fc8/kernel/sound/drivers/opl3/snd-opl3-synth.ko needs unknown symbol jiffies
    WARNING: /lib/modules/2.6.23.15-137.fc8/kernel/sound/drivers/opl3/snd-opl3-synth.ko needs unknown symbol sprintf
    WARNING: /lib/modules/2.6.23.15-137.fc8/kernel/sound/drivers/opl3/snd-opl3-synth.ko needs unknown symbol _spin_lock_irqsave
    WARNING: /lib/modules/2.6.23.15-137.fc8/kernel/sound/drivers/opl3/snd-opl3-synth.ko needs unknown symbol mutex_unlock
    WARNING: /lib/modules/2.6.23.15-137.fc8/kernel/sound/drivers/opl3/snd-opl3-synth.ko needs unknown symbol del_timer
    WARNING: /lib/modules/2.6.23.15-137.fc8/kernel/sound/drivers/opl3/snd-opl3-synth.ko needs unknown symbol __mod_timer
    WARNING: /lib/modules/2.6.23.15-137.fc8/kernel/sound/drivers/opl3/snd-opl3-synth.ko needs unknown symbol kmalloc_caches
    WARNING: /lib/modules/2.6.23.15-137.fc8/kernel/sound/drivers/snd-mtpav.ko needs unknown symbol strcpy
    WARNING: /lib/modules/2.6.23.15-137.fc8/kernel/sound/drivers/snd-mtpav.ko needs unknown symbol free_irq
    
    unknown symbol __kmalloc
    WARNING: /lib/modules/2.6.23.15-137.fc8/kernel/sound/synth/emux/snd-emux-synth.ko needs unknown symbol kmalloc_caches
    a lttle sample of the errors im getting

    big old error huh? any one wanna help?
    Model: HP Pavillion dv6748us
    CPU: AMD T-60 2.0 ghtz 64 x2
    Videocard:Nvidia GeForce 7150M
    Wifi:BCM4328 802.11a/b/g/n
    Display:1280x800
    OS:Fedora 8 x86_64 Werewolf

    Registered Linux User #466240
    Registered Linux Box #374667

  14. #59
    Join Date
    Sep 2006
    Location
    Connellsville, PA, USA
    Posts
    11,307
    Hello:

    Much more info is needed. You obviously are running F8 with a geforce 7150m, but what exactly have you done/tried, and what exactly are the problems/results? BTW, is that an on-board chip, or a card? When you say: "i tried to dl kmod-nvidia", do you really mean that you actually downloaded it, or did you try to install it with yum?

    The errors that you posted don't make sense - they appear to be sound-related, not video.

    I think that your best option is to follow the HOWTO (see link in my previous post), and post any problems/questions to that thread, where they will get the most attention.

    Regards,
    V

  15. #60
    Join Date
    Feb 2008
    Location
    CA
    Posts
    141
    sorry yeah i used yum to install

    it is an on board chip

    oh ive followed the how to's

    my biggest problem i have to reinstall my driver everytime i reboot. it sux.

    i tried posting on anohter thread but it died i belive
    Model: HP Pavillion dv6748us
    CPU: AMD T-60 2.0 ghtz 64 x2
    Videocard:Nvidia GeForce 7150M
    Wifi:BCM4328 802.11a/b/g/n
    Display:1280x800
    OS:Fedora 8 x86_64 Werewolf

    Registered Linux User #466240
    Registered Linux Box #374667

Page 4 of 20 FirstFirst ... 2 3 4 5 6 14 ... LastLast

Similar Threads

  1. 3D acceleration not working with Nvidia binary drivers
    By bjrosen in forum Fedora 13 Development Branch
    Replies: 10
    Last Post: 20th May 2010, 04:57 PM
  2. F12, two graphics cards and nVidia binary drivers
    By eoghan in forum Using Fedora
    Replies: 0
    Last Post: 14th April 2010, 06:24 PM
  3. Nvidia binary drivers and Fedora 10, do they work?
    By bjrosen in forum Hardware & Laptops
    Replies: 2
    Last Post: 25th November 2008, 10:41 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •