How to use native bcm43xx support for Broadcom BCM4318 [AirForce One 54g] in FC5
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 9 1 2 3 ... LastLast
Results 1 to 15 of 132
  1. #1
    smfinley Guest

    How to use native bcm43xx support for Broadcom BCM4318 [AirForce One 54g] in FC5

    Be sure you have a fully updated Fedora Core 5 system with the most recent kernel. (Do a "yum -y update" as root and then reboot when the update finishes.)

    Go to ftp://ftp.support.acer-euro.com/note...0_5020/driver/ and get ftp://ftp.support.acer-euro.com/note...ver/80211g.zip.

    Unzip 80211g.zip. (Use the command "unzip 80211g.zip".) Do a "cp ./80211g/bcmwl5.sys ~/".

    Install the fwcutter package from Fedora Extras by doing a "yum -y install bcm43xx-fwcutter" as root.

    Extract the firmware from bcmwl5.sys by doing a "/usr/bin/bcm43xx-fwcutter -w /lib/firmware bcmwl5.sys" as root in the directory in which you saved bcmwl5.sys (in our case your home directory). You can verify that fwcutter extracted the firmware to /lib/firmware by doing a "ls /lib/firmware".

    Set up Network Manger to automatically connect to your wireless and wired connections with the following commands, entering your root password as prompted after each command:
    Code:
    su -c '/sbin/chkconfig --level 345 NetworkManager on'
    Code:
    su -c '/sbin/chkconfig --level 345 NetworkManagerDispatcher on'
    Code:
    su -c '/sbin/service NetworkManager start ; /sbin/service NetworkManagerDispatcher start'
    Reboot your machine. The network manager icon will appear on your panel and you will be prompted to enter a gnome keyring password and your wireless network WPA key and other information.

    Note: You may have to change your wireless router's network mode from G only to mixed in order to connect.
    Last edited by smfinley; 8th July 2006 at 06:15 AM.

  2. #2
    LaChild Guest
    The instructions worked perfectly. Thanks!

  3. #3
    Join Date
    Mar 2006
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It seems I came real close but didn't make it...

    Followed the instructions and got to the point where I could see the SSID of my wireless network.
    After clicking on my SSID and providing the WEP key my whole system froze.
    I had to go into rescue mode and manually delete the files in /lib/firmware to relog into my system.
    I tried to fwcut both the downloaded file "provided" in this how-to and the "bcmwl5.sys" file in my windows folder.

    I'm running a x86_64 fedora. Could that be the problem? I guess the windows bcmwl5.sys drivers are 32bit?

    <this linux vs. broadcom thing is such a showstopper >

  4. #4
    Join Date
    Jul 2006
    Location
    Transgression
    Age
    42
    Posts
    1,182
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What is the difference between this tutorial and the one for the NDIS wrapper?
    I haven't gotten either of them to work, not sure which one is right for me.

  5. #5
    Mordacil Guest
    Ok, I did all of the above, but when I tried to activate eth1, I got the message:

    Device eth1 does not seem to be present, delaying initialization.

    I have an integrated card, a broacom air force one 54g 4318. The drivers were right, fwcutter worked fine, but it isn't working.

  6. #6
    Join Date
    Jul 2006
    Location
    Transgression
    Age
    42
    Posts
    1,182
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hey, i know this is going to hurt you more than it hurts me, but chances are you have tried to get this running for quite a while now, and there's a lot of junk leftover from previous unsucessful attempts that is conflicting with it.

    I had the same problem you had getting this working with mine, plus many MANY others, but i got it working anyway... after a fresh install. Remeber, i've only been using Linux for a few days now, so i don't know much at all about it, but if i can get it to work for me, i'm sure we can get it to work for you.

    So...
    Either reinstall and follow the directions that i will post when i get back from the store, or if you have enough experience with Ferdora, remove every single item and driver that you have attempted to install for this device. But even if you know how to do this, i'd still reinstall (just to make damned sure that all that junk is cleared out).

    Like i said, i can post the method i used when i get back later, unless you're not willing to reinstall, or have solved the problem. By the way, what kind of laptop are you using? I know it doesn't matter because it's the drivers for the chipset that we're worried about, but i'm just curious.

    Seeya.
    Last edited by Vector; 23rd July 2006 at 01:08 AM.

  7. #7
    Mordacil Guest
    Gateway 3300+

    Edit: I tinkered around with my router settings, and now the wireless is working. Thanks to all.
    Last edited by Mordacil; 23rd July 2006 at 11:29 PM.

  8. #8
    ike_27 Guest
    Quote Originally Posted by Alex-Grim
    Hey, i know this is going to hurt you more than it hurts me, but chances are you have tried to get this running for quite a while now, and there's a lot of junk leftover from previous unsucessful attempts that is conflicting with it.

    I had the same problem you had getting this working with mine, plus many MANY others, but i got it working anyway... after a fresh install. Remeber, i've only been using Linux for a few days now, so i don't know much at all about it, but if i can get it to work for me, i'm sure we can get it to work for you.

    So...
    Either reinstall and follow the directions that i will post when i get back from the store, or if you have enough experience with Ferdora, remove every single item and driver that you have attempted to install for this device. But even if you know how to do this, i'd still reinstall (just to make damned sure that all that junk is cleared out).

    Like i said, i can post the method i used when i get back later, unless you're not willing to reinstall, or have solved the problem. By the way, what kind of laptop are you using? I know it doesn't matter because it's the drivers for the chipset that we're worried about, but i'm just curious.

    Seeya.
    can u post the steps abt how to cleanup old installs, download and install ndiswrapper and lastly did u use the fwcutter or u just blacklisted bcwxxx?

  9. #9
    Join Date
    Jul 2006
    Location
    Transgression
    Age
    42
    Posts
    1,182
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Sorry, completely forgot about this one...
    I would NOT recommend using the fwcutter, it F*CKED my system UP.
    Even multiple restarts wouldn't clear whatever it did, i had to reinstall.
    BUT, this may have been an isolated incident, who knows...

    Ok, what i did was a fresh install of the system.
    But if you do the following it might help:
    *Uninstall the ndis wrapper that you already tried to install (ndiswrapper -e bcmwl5),
    *Go into 'Network' settings and delete any device that says it's wireless (on the FIRST tab, NOT the second one),
    *Go into the /etc/modprobe.d/ and add 'blacklist bcm43xx' to both the blacklist docs (not sure if you REALLY need the 2nd one),
    *Go into /etc/ and open 'modprobe.config' and remove any line that has 'alias eth1 bcm43xx', or any 'bcm43xx' line at all,
    *Reboot.

    After logging back in:
    *First install the ndiswrapper (yum ndiswrapper),
    *Then install the driver (ndiswrapper -i /root/Desktop/wherever/the/hell/you/put/this/bcmwl5.inf)
    *Terminal-> modprobe ,
    *Terminal-> ndiswrapper -m ,
    *Terminal-> dmesg to see if it says anything about the device wlan or ndiswrapper (NOT bcm*),
    *Then add the wlan/ndiswrapper to 'System->Administration->Network' (leave all options default, you can specify wep keys later),
    *Do NOT try to activate it,
    *Then edit the device to start when the system starts, and to be able to toggle on and off),
    *Save settings and close the window,
    *Go to System->Administration->Server Settings->Services,
    *Click the boxes to enable the top two options (net NetworkManager, NetworkManagerDispatch),
    *Click File->Save,
    *Select the first NetworkManager service, click start,
    *Do the same thing for the second NetworkManagerDispatch service,
    *Go down to the 'Network' service (~= five clicks down on the scroll bar),
    *Restart it,
    *Terminal-> 'dhclient ndiswrapper'
    *In the system tray, click on the networkManager,
    *Select a wireless network,
    *Enter your credentials (correctly; ASCII != HEX || Phrase)

    If you can see your wlan device in the modprobe, and have removed the apropriate entries from the apropriate files, and you still don't have a wireless option, reboot.
    I had to do alllllllllllllllllllll that ****, and then reboot.
    When you're bootin up, at the progress screen hit 'alt + d' for details, and watch what it says when it get's to the 'wlan' part (right after eth0), and if it simply says 'Done', you're good.
    If it doesn't say that, i've still had my device work, so i don't completely understand WHY my device is working sometimes, lmmfao, but it does, and i'm just happy that i can remember how to do this after a re-install.

    This may not be the best way, but it's what got me working when this tutorial didn't work 100% for me (it's still a good tutorial none-the-less )

    If i remember anything else relevant to this, i will update accordingly, but remember, if this doesn't work, i am definately NOT the person you want to ask for help, because i've only been using Fedora for about a week now, and i'm even less experienced than you are at it, so i could offer you no help beyond this little bit that i figured out (sorry).

    Good luck, i know it was a pain in the ass for me too.
    Last edited by Vector; 25th July 2006 at 08:32 AM. Reason: 7 Edits: Because i can ;)

  10. #10
    Join Date
    Mar 2006
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Thumbs up

    Installed FC5 i386 and followed smfinleys instructions. Now it works. TY

  11. #11
    dfifita Guest
    smfinley,

    I followed your instructions and it came up OK, recognizing the network I need to connect to. However, when I tried to connect, it failed. The network I need to connect to is 80211b. Are your instruction compatible for b networks? Is there another .sys file to use to make it work, or should it work based on the instructions you gave.

    thanks,

    Troy

  12. #12
    Join Date
    Jul 2006
    Location
    Transgression
    Age
    42
    Posts
    1,182
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yeah, i had the same problem, and it was really pissing me off because i knew that i was using the correct wireless mode and wep key. If your router is configured to allow b network mode, then it should work, well as far as Fedora goes it should work regardless of what your router is set to, you just won't connect to it if the router doesn't accept b mode.
    What i eventually tried was the option at the bottom, that asks you if it is open authentication or not. It SHOULD'VE been the first option, but after trying everything else, i finally tried changing that to the second option and for some stupid reason it worked.
    I'm not on Gnome right now, but i'll switch to it later and take a screenshot of what i'm talking about and edit this post to include that.

    But try that, and it should work (hopefully).
    Last edited by Vector; 18th December 2008 at 11:28 AM.

  13. #13
    forbes Guest
    I followed these instructions to the t, but after a reboot, it's like nothing happened. No eth1 is listed, doesn't even exist. Nothing pops up...nada. Any ideas?

  14. #14
    timmn Guest
    I'm trying to get the Broadcom BCM4318 wireless circuitry working in my Acer Aspire 3000 laptop with FC5.

    I first tried fwcutter, then the computer would boot, the light on the front of the computer would flash on and off (yellow) and then peroidically flash. After putting in my network information, when I tried to activate it, I got a message stating "No link present. Check cable?".

    I did a reinstall of FC5 and then tried ndiswrapper, that did nothing at all.

    As much as I dislike Windows, it does have one thing going for it, the wireless circuitry on this laptop works with it.

  15. #15
    Join Date
    Mar 2006
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by timmn
    As much as I dislike Windows, it does have one thing going for it, the wireless circuitry on this laptop works with it.
    Aye! There lies the rub!

    I'm too am held hostage by windows

    I've been "looking" at linux over the last 10 years, always some technicality (or: my own linux shortcomings) that keeps me strung out on windows.

    As long as hardware manufacturers need money (!) and therefore won't allow the open linux world to look closely at their cards, we'll run into this little difficulty.

    It's a bit of a "catch 22". I'm not at all kicking at the open software world, it's just a normal computer user's pragmatic view.

    Maybe in another 10 years everyone will provide linux drivers?

    <sigh>

Page 1 of 9 1 2 3 ... LastLast

Similar Threads

  1. Replies: 2
    Last Post: 19th September 2009, 11:08 AM
  2. Replies: 19
    Last Post: 23rd June 2008, 03:17 PM
  3. Replies: 24
    Last Post: 20th April 2008, 05:24 PM
  4. How to install ndiswrapper for Broadcom BCM4318 [AirForce One 54g] (bcmwl5) in FC5
    By smfinley in forum Guides & Solutions (Not For Questions)
    Replies: 52
    Last Post: 18th July 2007, 06:10 AM
  5. Replies: 5
    Last Post: 15th March 2007, 01:43 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •