Fglrx driver install - "direct rendering: No", Xlib: extension "XFree86-DRI" missing
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 10 of 10
  1. #1
    Squeaks Guest

    Fglrx driver install - "direct rendering: No", Xlib: extension "XFree86-DRI" missing

    Hey all,

    I'm not very familiar with the driver system in FC5, so I could use some help because the fglrx driver's aren't working properly. How do I check if I have multiple driver's conflicting? The fedorafaq.org instructions said to remove any nvidia driver's, but I don't know how to check for them. I have a feeling there may be something old still left that needs to be disable/removed.

    My computer is a Thinkpad T41 with ati radeon 9000, I followed the fedorafaq.org instructions. My system gets an average of 115fps running glxgears. My hope was to get my system up to speed so that my 2d performance is as good as it can be, because I notice menus and other window-related stuff is slow. The following is what I attempted, outputs, and my xorg.conf and X.org log. I'm at a loss because I followed the directions, and then googled for my issue but there were few hits. The issue being "Xlib: extension "XFree86-DRI" missing on display ":0.0"."

    yum install kmod-fglrx
    // turned off SELinux entirely
    init 3
    (logged in as root)
    ati-fglrx-config-display enable
    ati-fglrx-config-display enabledri
    init 5

    [root@blackbox ~]# rpm -qa | grep fglrx
    xorg-x11-drv-fglrx-8.25.18-1.lvn5
    kmod-fglrx-8.25.18-1.2.6.16_1.2122_FC5

    [root@blackbox ~]# fglrxinfo
    Xlib: extension "XFree86-DRI" missing on display ":0.0".
    display: :0.0 screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (1.5 Mesa 6.4.2)

    [root@blackbox ~]# glxinfo
    name of display: :0.0
    Xlib: extension "XFree86-DRI" missing on display ":0.0".
    display: :0 screen: 0
    direct rendering: No
    server glx vendor string: SGI
    server glx version string: 1.2
    server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGIS_multisample, GLX_SGIX_hyperpipe, GLX_SGIX_swap_barrier,
    GLX_SGIX_fbconfig
    client glx vendor string: ATI
    client glx version string: 1.3
    client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
    GLX_ATI_render_texture
    GLX version: 1.2
    GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_multisample
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (1.5 Mesa 6.4.2)
    OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
    GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
    GL_EXT_texture_lod_bias
    glu version: 1.3
    glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

    visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
    id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
    ----------------------------------------------------------------------
    0x23 24 tc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
    0x24 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
    0x25 24 tc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
    0x26 24 tc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
    0x27 24 dc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
    0x28 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
    0x29 24 dc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
    0x2a 24 dc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
    [root@blackbox ~]#
    [root@blackbox ~]# grep -i dri /var/log/Xorg.0.log |grep -vE "driver|drmOpenDevice"
    X.Org Video Driver: 0.8
    ABI class: X.Org Video Driver, version 0.8
    ABI class: X.Org Video Driver, version 0.8
    Module class: X.Org XInput Driver
    (II) LoadModule: "dri"
    (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
    (II) Module dri: vendor="X.Org Foundation"
    (II) Loading extension XFree86-DRI
    Module class: X.Org Video Driver
    ABI class: X.Org Video Driver, version 0.7
    Module class: X.Org XInput Driver
    Module class: X.Org XInput Driver
    (II) ATI Proprietary Linux Driver Version Identifier:8.25.18
    (II) ATI Proprietary Linux Driver Release Identifier: LGDr8.25g1
    (II) ATI Proprietary Linux Driver Build Date: May 18 2006 09:54:44
    ABI class: X.Org Video Driver, version 0.8
    ABI class: X.Org Video Driver, version 0.8
    ABI class: X.Org Video Driver, version 0.8
    ABI class: X.Org Video Driver, version 0.8
    ABI class: X.Org Video Driver, version 0.8
    ABI class: X.Org Video Driver, version 0.8
    (==) fglrx(0): NoDRI = YES
    (==) fglrx(0): OpenGL ClientDriverName: "atiogl_a_dri.so"
    (==) fglrx(1): bNoDRI = YES (copy from primary screen)
    ABI class: X.Org Video Driver, version 0.8
    (WW) fglrx(0): * DRI initialization disabled! *
    (WW) fglrx(1): * DRI initialization disabled! *


    [root@blackbox ~]# dmesg | grep agp
    Linux agpgart interface v0.101 (c) Dave Jones
    agpgart: Detected an Intel 855PM Chipset.
    agpgart: AGP aperture is 256M @ 0xd0000000
    agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
    agpgart: Putting AGP V2 device at 0000:00:00.0 into 1x mode
    agpgart: Putting AGP V2 device at 0000:01:00.0 into 1x mode


    [root@blackbox ~]# dmesg | grep drm
    [drm] Initialized drm 1.0.1 20051102
    [drm] Initialized radeon 1.22.0 20051229 on minor 0
    [drm] Loading R200 Microcode
    [drm] Module unloaded


    [root@blackbox ~]# grep "Direct rendering" /var/log/Xorg.0.log
    (II) fglrx(0): Direct rendering disabled
    (II) fglrx(1): Direct rendering disabled
    Last edited by Squeaks; 3rd June 2006 at 11:44 PM.

  2. #2
    Squeaks Guest

  3. #3
    matthewruno Guest
    I'm having the exact same problem, with the same hardware (except in desktop form).

    Any progress? I can't really find anything.

  4. #4
    greenleaf108 Guest
    Exact same problem here. I swear I will never buy another sucktackular ATI product again. It's been nothing but hassle to get their graphics cards working under Linux, yet with EVERY nVidia card I've tried, it worked fine first shot.

  5. #5
    Join Date
    Jan 2005
    Location
    Tunisia
    Age
    43
    Posts
    47
    It used to work, these latest updates are getting me nut !
    Zydoon, registred linux user #99395.
    Wisdom : share what you know, learn what you don't.

  6. #6
    Join Date
    Jan 2005
    Location
    Tunisia
    Age
    43
    Posts
    47
    HI again,
    I went through the xorg log file and i found that the cmposite estensio nis enabled ---> disabling DRI
    we need to disable it:
    in xorg.conf
    look for the Extensions section and add "false", like this :

    Section "Extensions"
    Option "Composite" "false"
    EndSection

    init 3 ; init 5
    and fglrxinfo should give you this :
    [#########~]$ fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: RADEON X300/X550 Series Generic
    OpenGL version string: 2.0.6065 (8.29.6)
    Zydoon, registred linux user #99395.
    Wisdom : share what you know, learn what you don't.

  7. #7
    greenleaf108 Guest

    Not to be a troll but . . .

    I switched to Ubuntu and 3-d ATI driver works almost right out of the box.

    1. Install ubuntu
    2. Install easyubuntu
    3. fglrx works perfectly

  8. #8
    Join Date
    Jan 2005
    Location
    Tunisia
    Age
    43
    Posts
    47
    Tha'ts not becasue of Fedora or livna, it's just the driver that doesn't support activating composite extension and DRI
    look at your xorg.conf on ubuntu, and am pretty sure you'll find the composite extension disabled.
    anyway I like ubuntu too ;-)
    Zydoon, registred linux user #99395.
    Wisdom : share what you know, learn what you don't.

  9. #9
    Join Date
    Mar 2004
    Location
    Montreal, PQ, Canada
    Posts
    140
    Quote Originally Posted by zydoon
    Tha'ts not becasue of Fedora or livna, it's just the driver that doesn't support activating composite extension and DRI
    look at your xorg.conf on ubuntu, and am pretty sure you'll find the composite extension disabled.
    anyway I like ubuntu too ;-)
    with the 8.25 drivers, he is using, the composite option is off by default.

    As an example, here's a copy of my working /etc/X11/xorg.conf file:

    Code:
    # XFree86 4 configuration created by pyxf86config
    
    Section "ServerLayout"
    	Identifier     "Default Layout"
    	Screen      0  "aticonfig-Screen[0]" 0 0
    	Screen         "aticonfig-Screen[1]" RightOf "aticonfig-Screen[0]"
    	InputDevice    "Mouse0" "CorePointer"
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    	FontPath     "unix/:7100"
    EndSection
    
    Section "Module"
    	Load  "dbe"
    	Load  "extmod"
    	Load  "fbdevhw"
    	Load  "glx"
    	Load  "record"
    	Load  "v4l"
    	Load  "freetype"
    	Load  "type1"
    	Load  "dri"
    EndSection
    
    Section "InputDevice"
    
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "ca(fr)"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "IMPS/2"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "ZAxisMapping" "4 5"
    	Option	    "Emulate3Buttons" "yes"
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[1]"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Gamma        1.9
    	Option	    "DPMS" "true"
    EndSection
    
    Section "Device"
    	Identifier  "aticonfig-Device[0]"
    	Driver      "fglrx"
    	Option	    "VideoOverlay" "on"
    	Option	    "OpenGLOverlay" "off"
    	Option	    "UseInternalAGPGART" "no"
    	BusID       "PCI:2:0:0"
    EndSection
    
    Section "Device"
    	Identifier  "aticonfig-Device[1]"
    	Driver      "fglrx"
    	Option	    "VideoOverlay" "on"
    	Option	    "OpenGLOverlay" "off"
    	Option	    "UseInternalAGPGART" "no"
    	BusID       "PCI:2:0:0"
    	Screen      1
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]"
    	Device     "aticonfig-Device[0]"
    	Monitor    "aticonfig-Monitor[0]"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    		Modes	  "1600x1200"
    	EndSubSection
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[1]"
    	Device     "aticonfig-Device[1]"
    	Monitor    "aticonfig-Monitor[1]"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    		Modes	  "1600x1200"
    	EndSubSection
    EndSection
    
    Section "DRI"
    	Group        0
    	Mode         0666
    EndSection

  10. #10
    Join Date
    Jun 2005
    Posts
    12

    Using fglrx 8.28 with kernel 2.6.18

    Since the person who started this topic is using a Radeon 9000 card, and I am using a 9200 card, we are in the same situation of not being able to use the latest releases of the fglrx driver (thank-you ATI).. The ATI 8.28 installer will not by default create a working fglrx module with the 2.6.18 kernel. However, by following the instructions from this Polish site http://forum.slackware.pl/viewtopic.php?t=11672, I now have it working under the latest FC5 kernel. All kudos to the person who wrote the original English instructions.

    Firstly, extract the fglrx components to a temporary directory:

    ./ati-driver-installer-8.28.8.run - -extract tmp

    cd tmp/common/lib/modules/fglrx/build_mod

    chmod +w make.sh

    edit make.sh, replace line src_file=$linuxincludes/linux/version.h with src_file=$linuxincludes/linux/utsrelease.h, and save change

    patch < ../../../../../packages/Fedora/ATI-fglrx-kernel-2.6.18.diff

    cd back to your tmp directory: cd ../../../../..

    as root: ./ati-installer.sh 8.28.8 - -install

    This should start the usual ATI GUI install

    Good luck!

Similar Threads

  1. Xlib: extension "XFree86-DRI" missing on display ":0.0".
    By keatonvictor in forum Using Fedora
    Replies: 5
    Last Post: 9th November 2008, 03:05 PM
  2. xlib:extension "xfree86-misc" missing on display ":0:0"
    By Sicily1918 in forum Using Fedora
    Replies: 4
    Last Post: 3rd January 2007, 09:30 PM
  3. Replies: 3
    Last Post: 1st October 2006, 04:40 AM
  4. Replies: 9
    Last Post: 18th April 2005, 02:10 PM
  5. Xlib: extension "XFree86-DRI" missing on display ":0.0".
    By IneedHelp1111 in forum Using Fedora
    Replies: 2
    Last Post: 21st March 2005, 07:36 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •