FedoraForum.org - Fedora Support Forums and Community
Results 1 to 8 of 8
  1. #1
    T777 Guest

    FC5 - Cannot mount partition at boot: fstab ignored

    Hi folks,

    I've just re-built my server and switched from SuSE 9.2 to Fedora Core 5 and I'm having problems with mounting a hard disk partition automatically at boot. I previously had three partitions on the drive under SuSE: a SWAP partition (/dev/hda1), a / partition (/dev/hda2) and a 100Gb data partition (/dev/hda5) which contains all my files). This was actually a file server and the 100Gb data partition was actually mounted as /home on the SuSE setup.

    I have tried to replicate this setup whilst installing Fedora Core 5 and kept all partitions the same size but re-formatted the SWAP and / partitions. Obviously I left the 100Gb partition well alone in order to preserve my data. However, I now find that this 100Gb partition will not automatically mount under Fedora Core 5. I can mount it manually anywhere I like using, for example:

    Code:
    mount /dev/hda5 /common
    and I can see all of my files. However, it disappears again when the machine is rebooted. I have edited the fstab file (and in fact, the installer did so based on my answers during installation) to read as follows:

    Code:
    LABEL=/                 /                       ext3    defaults        1 1
    devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
    tmpfs                   /dev/shm                tmpfs   defaults        0 0
    /dev/hda5               /common                reiserfs defaults        1 2
    proc                    /proc                   proc    defaults        0 0
    sysfs                   /sys                    sysfs   defaults        0 0
    LABEL=SWAP-hda1         swap                    swap    defaults        0 0
    but it is just ignored by the system and is not mounted when the system is rebooted.

    It will even mount if I do:

    Code:
    mount -a
    but yet the fstab is still ignored at boot. I did notice an error during the boot process which says "Mounting other filesystems: mount: Operation not supported", but why?

    The output of fdisk -l is as follows:

    Code:
    Disk /dev/hda: 120.0 GB, 120034123776 bytes
    255 heads, 63 sectors/track, 14593 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/hda1               1         129     1036161   82  Linux swap / Solaris
    /dev/hda2   *         130        1526    11221402+  83  Linux
    /dev/hda3            1527       14592   104952645    f  W95 Ext'd (LBA)
    /dev/hda5            1527       14592   104952613+  83  Linux
    I would be very grateful for any help or guidance anyone can offer.

    Thanks

  2. #2
    Seve's Avatar
    Seve is offline Retired Community Manager
    Join Date
    Oct 2004
    Location
    The GTA, Ontario, Canada
    Age
    60
    Posts
    12,371
    Hello:
    Just from a quick scan of what you posted it may have to do with the reiserfs file system on /dev/hda5?
    No hard experience, however I was wondering if you had SELinux enabled? From the release notes: http://www.fedorafaq.org/#reiserjfs
    Also, if you have not already done so, you should install reiserfs-utils .... from the package description :
    PHP Code:
    The reiserfs-utils package contains a number of utilities for
    creatingcheckingmodifying, and correcting any inconsistencies in
    ReiserFS filesystems
    including reiserfsck (used to repair filesystem
    inconsistencies
    ), mkreiserfs (used to initialize a partition to
    contain an 
    empty ReiserFS filesystem), debugreiserfs (used to examine
    the internal structure of a filesystem
    to manually repair a corrupted
    filesystem
    , or to create test cases for reiserfsck), and some other
    ReiserFS filesystem utilities
    .

    You should install the [B]reiserfs-utils [/B]package if you want to use
    ReiserFS on any of your partitions.

    reiserfs-utils contains reiserfsck (used to repair filesystem
    Seve
    Registered Linux User: #384977
    .................................................. ............
    See the Links below for more Help and those much wanted extras ... :)


  3. #3
    Join Date
    Dec 2005
    Posts
    909
    If I were you I would get the data off that partition and convert it to ext3 double quick as reiserfs is not supported by Fedora so the results are likely to be unreliable.
    Best regards,
    Jim Bannon
    (Registered Linux User #405603 :) )

  4. #4
    Join Date
    Feb 2005
    Posts
    599
    I have the same problem and it results from the combination of reiserfs and selinux. If I disable selinux at boot (selinux=0 on the kernel line in grub.conf), the reiserfs partitions mount properly. I have installed reiserfs-utils and enabled the reiserfs contexts kernel parameters, but I still have not figured out how to set the selinux contexts on the reiserfs partitions so they mount at boot.

    Actually I'm slowly moving my partitions over to ext3. Not because of any stability/reliability issues, reiserfs has worked great for me, but because it's not in the fedora mainstream distribution and the advantage that originally led me to reiserfs, the handling of large numbers of small files, is no longer so apparent.

    Daniel

  5. #5
    T777 Guest
    Thanks guys, you were right. It turns out I did have SELinux enabled. Disabling it allowed the partition to mount at boot. However, it still unmounted after the initial user logged off. I therefore took your advice and backed everything up, re-installed everything with SELinux disabled and the partition formatted as Ext3. Works fine now.

    Thanks very much for all your help. :-)

    Regards,

    Stuart

  6. #6
    Join Date
    Dec 2005
    Posts
    909
    That's the thing I miss about Gentoo where reiserfs, jfs and xfs were all supported directly by the kernel rather than as an afterthought. Reiserfs was a good deal faster in my case, especially on my external iomega usb zip drive and was very reliable in the 2.6 kernel. You could also have it with the hardened tool chain and Selinux, though that had to be specially ordered.
    Best regards,
    Jim Bannon
    (Registered Linux User #405603 :) )

  7. #7
    Join Date
    Feb 2005
    Posts
    599
    Quote Originally Posted by T777
    I therefore took your advice and backed everything up, re-installed everything with SELinux disabled and the partition formatted as Ext3. Works fine now.
    I'd be hesitant to run with selinux disabled. My suggestion to disable it was just to verify you had the same problem as I did. With the partitions formatted as ext3, you should be able to leave selinux enabled. I do and the partitions mount at boot as they should.

    Daniel

  8. #8
    T777 Guest
    Thanks Daniel. I've re-enabled SELinux now. Had to run system-config-securitylevel and tell it to exempt smbd and nmbd from SELinux though before I could get Samba to run as a daemon. However, everything now works great and I'm really pleased.

    Thanks to you and everyone else for all their help.

    Stuart

Similar Threads

  1. partition auto-mount, editing fstab
    By jadube in forum Using Fedora
    Replies: 3
    Last Post: 4th June 2008, 03:34 AM
  2. Replies: 13
    Last Post: 16th September 2007, 03:06 AM
  3. partition/mount point inconsistencies in /etc/fstab
    By leonard in forum Using Fedora
    Replies: 10
    Last Post: 27th March 2007, 02:01 PM
  4. Fstab won't mount my windows Partition
    By deltaFee in forum Using Fedora
    Replies: 1
    Last Post: 10th January 2007, 06:03 AM
  5. Replies: 7
    Last Post: 5th April 2006, 01:23 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •