i've had some problems with my Swiss French keyboard and Fedora Core 5 when running X11. Neither the AltGr nor Alt keys where working and that with GNOME and also with KDE. This was a strange behaviour and I didn't know why because at the installation I mentioned a Swiss French keyboard.
Happily I found out why and I'll tell you why. Xorg has changed the layout for keyboard and now the line Options "XkbLayout" "fr_CH" does no more use a Swiss french keyboard. Instead you've to add 2 lines:

Options "XkbLayout" "ch" --> the layout should be a swiss keyboard
Options "XkbVariant" "fr" --> the variant of the swiss layout should be French

This is also the case with de_CH keyboard and maybe also others. I think people working on Fedora haven't realized that till now and need to change their installation procedure for keyboard mapping.

LAUER Edouard