X11 error: BadAlloc (insufficient resources for operation)
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    shawnrgr Guest

    X11 error: BadAlloc (insufficient resources for operation)

    this error pluages all my video players... totem-xine, mplayer, vlc. Nothing will work and all of them spit this error back out at me. no one seems to want to help me on irc, apperantly im an idiot as one of them called me because "its obviously an xorg problem" Thats all well and good but that doesn't help me because I've only been using linux for 1 week. All i want to do is play my avi's Can anyone PLEASE help me on this... some say its the ram.. I have 1 gig. then they say "so what" lol. if 1 gig of ram isn't enough to play a 20 minute avi file than linux isn't all its cracked up to be. However I don't believe this is true. Some say its a ****ty video card. I can play doom 3 on max res and med settings so it can't be THAT bad.

    Please... someone knowledgable with the willingness to help others would be nice. I'm not a linux wiz, Im just a normal guy that needs some help. Anything would be good at this point.

    Code:
    VLC Media Player
    ------------------------------------------------------------------
    [shawn@localhost video]$ vlc csp-jeremy.hotz.avi
    VLC media player 0.8.4a Janus
    X Error of failed request:  BadAlloc (insufficient resources for operation)
      Major opcode of failed request:  140 (XVideo)
      Minor opcode of failed request:  19 ()
      Serial number of failed request:  85
      Current serial number in output stream:  86
    [shawn@localhost video]$
    
    
    
    Totem-xine
    ------------------------------------------------------------------
    [shawn@localhost ~]$ totem
    The program 'totem' received an X Window System error.
    This probably reflects a bug in the program.
    The error was 'BadAlloc (insufficient resources for operation)'.
      (Details: serial 87 error_code 11 request_code 140 minor_code 19)
      (Note to programmers: normally, X errors are reported asynchronously;
       that is, you will receive the error a while after causing it.
       To debug your program, run it with the --sync command line
       option to change this behavior. You can then get a meaningful
       backtrace from your debugger if you break on the gdk_x_error() function.)
    
    
    
    MPlayer
    ------------------------------------------------------------------
    [shawn@localhost video]$ mplayer csp-jeremy.hotz.avi
    Using GNU internationalization
    Original domain: messages
    Original dirname: /usr/share/locale
    Current domain: mplayer
    Current dirname: /usr/share/locale
     
    MPlayer dev-CVS--4.1.0 (C) 2000-2006 MPlayer Team
    CPU: Advanced Micro Devices Athlon 64 Clawhammer; Athlon 64 X2 Toledo; Turion Newark,Lancaster (Family: 15, Stepping: 10)
    CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
     
    Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
    Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
    Opening joystick device /dev/input/js0
    Can't open joystick device /dev/input/js0: No such file or directory
    Can't init input joystick
    Setting up LIRC support...
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support.
    You will not be able to use your remote control.
    Playing csp-jeremy.hotz.avi.
    AVI file format detected.
    VIDEO:  [DX50]  320x240  24bpp  29.970 fps  578.0 kbps (70.6 kbyte/s)
    ==================================================  ========================
    Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
    AUDIO: 22050 Hz, 2 ch, s16le, 56.0 kbit/7.94% (ratio: 7000->88200)
    Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
    ==================================================  ========================
    ==================================================  ========================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
    ==================================================  ========================
    alsa-init: using device default
    alsa: 48000 Hz/2 channels/4 bpf/65536 bytes buffer/Signed 16 bit Little Endian
    AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
    Starting playback...
    VDec: vo config request - 320 x 240 (preferred colorspace: Planar YV12)
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
    VO: [xv] 320x240 => 320x240 Planar YV12
    X11 error: BadAlloc (insufficient resources for operation)?,?% 1 0
     
     
    MPlayer interrupted by signal 6 in module: vo_check_events
    - MPlayer crashed. This shouldn't happen.
      It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
      gcc version. If you think it's MPlayer's fault, please read
      DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
      won't help unless you provide this information when reporting a possible bug.
    alsa-uninit: pcm closed
    [shawn@localhost video]$

  2. #2
    robertmcnaught Guest
    did you find a solution to this? i am having the same problem with mplayer too

  3. #3
    metalworm Guest

  4. #4
    tallfred Guest

    Use a different output mode

    The failure is insufficient memory on the video card, or more probably bugs in your video driver. The work around is to not use the problematic mode (XVideo). Run vlc like this...
    Code:
    vlc --vout x11
    The other output modes are documented at http://www.videolan.org/doc/vlc-user-guide/en/ch02.html

  5. #5
    kristux Guest

    Use this script to embed mplayer in your shell

    Save this file as 'mplay.sh'
    -----------------------------------------------------------------------------------------------------
    #!/bin/bash

    INP_FILE=$1

    if [ -f "$INP_FILE" ] ;then
    echo NOW PLAYING .... $INP_FILE
    else
    if [ -d "$INP_FILE" ] ;then
    echo $INP_FILE SEEMS TO BE A DIRCTORY, I NEED A FILE TO PLAY
    else echo NO INPUT FILE, GIVE ME THE ABSOLUTE PATH OF FILE TO PLAY
    fi
    echo Exiting ... && sleep 5
    exit 1
    fi

    mplayer -vo x11 -loop 0 -zoom -framedrop "$INP_FILE"
    ---------------------------------------------------------------------------------------------------------------
    execute command : chmod 755 mplay.sh
    now your new launcher for mplayer is ready.

    to use this type " ./mplay.sh <absolute path or name of video or audio file>\

    you can also make a symbolic link for this file to a PATH added directory and execute mplay.sh from anywhere ( use 'ln -s' command for this ; see 'man ln' for more ).
    OR add the path of directory for mplay.sh to environment variable PATH / .bashprofile file .

    Ofcourse u need to have mplayer installed on your Linux system.
    Last edited by kristux; 24th January 2009 at 08:14 PM. Reason: spelling mistakes

Similar Threads

  1. video players fail with BadAlloc error
    By navaburo in forum Alpha - Beta (Fedora 9 Only)
    Replies: 4
    Last Post: 30th April 2008, 01:06 AM
  2. x11 error mplayer - insufficient resources
    By robertmcnaught in forum Using Fedora
    Replies: 9
    Last Post: 1st July 2007, 03:29 AM
  3. Replies: 0
    Last Post: 25th August 2006, 12:38 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •