RP-PPPoE :
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    yshsu168 Guest

    RP-PPPoE :

    Dear All:

    I am using FC5 as the PPPoE server, I have two NICs. eth0 is for internet access and eth1 is where PPPoE server listened on. I use "pppoe-server -I eth1 -S xxx" to initiate the server.
    I did not invoke RADIUS. I think it is more easy to diagnose.
    By sniffing the packet, it seems that the PPPD is no responde to the PPPoE client's PPP LCP: Configuration Request.
    Could anyone suggest me some tips??
    Thank you.

    /etc/ppp/pppoe-server-options
    # PPP options for the PPPoE server
    # LIC: GPL
    require-chap
    login
    lcp-echo-interval 10
    lcp-echo-failure 2
    proxyarp
    ms-dns 168.95.1.1
    ps -aux | grep ppp
    [samuel@localhost ppp]$ ps -aux | grep ppp
    Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.6/FAQ
    root 2990 0.0 0.0 1620 448 ? S 15:48 0:00 pppoe-server -I eth1 -S T-Online
    root 2992 0.0 0.0 1600 436 ? S 15:48 0:00 /usr/sbin/pppoe -n -I eth1 -e 1:00:13:d4:6b:08:53T-Online - S
    root 3003 0.0 0.0 1604 436 ? S 15:48 0:00 /usr/sbin/pppoe -n -I eth1 -e 1:00:13:d4:6b:08:53T-Online - S
    root 3022 0.0 0.0 1600 440 ? S 15:49 0:00 /usr/sbin/pppoe -n -I eth1 -e 2:00:13:d4:6b:08:53T-Online - S
    root 3040 0.0 0.0 1600 440 ? S 15:49 0:00 /usr/sbin/pppoe -n -I eth1 -e 2:00:13:d4:6b:08:53T-Online - S
    samuel 3104 0.0 0.1 4128 684 pts/0 S+ 15:56 0:00 grep ppp
    /var/log/messages
    Apr 10 15:49:44 localhost pppd[3021]: Connect: ppp0 <--> /dev/pts/4
    Apr 10 15:49:49 localhost pppd[3021]: tcflush failed: Bad file descriptor
    Apr 10 15:49:49 localhost pppd[3021]: Exit.
    Apr 10 15:49:49 localhost pppoe-server[2990]: Session 2 closed for client 00:13:d4:6b:08:53 (10.67.15.2) on eth1
    Apr 10 15:49:49 localhost pppoe-server[2990]: Sent PADT
    Apr 10 15:49:49 localhost pppoe-server[2990]: Sent PADT
    Apr 10 15:58:39 localhost pppoe-server[3120]: Session 1 created for client 00:13:d4:6b:08:53 (192.168.0.100) on eth1 using Service-Name 'T-Online'
    Apr 10 15:58:39 localhost pppd[3120]: pppd 2.4.3 started by root, uid 0
    Apr 10 15:58:39 localhost pppd[3120]: Using interface ppp0
    Apr 10 15:58:39 localhost pppd[3120]: Connect: ppp0 <--> /dev/pts/1
    Apr 10 15:59:10 localhost pppd[3120]: LCP: timeout sending Config-Requests
    Apr 10 15:59:10 localhost pppd[3120]: Connection terminated.
    Apr 10 15:59:10 localhost pppd[3120]: Using interface ppp0
    Apr 10 15:59:10 localhost pppd[3120]: Connect: ppp0 <--> /dev/pts/2
    Apr 10 15:59:15 localhost pppd[3120]: tcflush failed: Bad file descriptor
    Apr 10 15:59:15 localhost pppd[3120]: Exit.
    Apr 10 15:59:15 localhost pppoe-server[3119]: Session 1 closed for client 00:13:d4:6b:08:53 (192.168.0.100) on eth1
    Apr 10 15:59:15 localhost pppoe-server[3119]: Sent PADT
    Apr 10 15:59:15 localhost pppoe-server[3119]: Sent PADT
    Apr 10 15:59:43 localhost pppoe-server[3119]: Terminating on signal 15 -- killing all PPPoE sessions
    [samuel@localhost ~]$ sudo tail -n 40 /var/log/messages
    Apr 10 15:48:20 localhost pppoe-server[2991]: Session 1 created for client 00:13:d4:6b:08:53 (10.67.15.1) on eth1 using Service-Name 'T-Online'Apr 10 15:48:20 localhost pppd[2991]: pppd 2.4.3 started by root, uid 0
    Apr 10 15:48:20 localhost pppd[2991]: Using interface ppp0
    Apr 10 15:48:20 localhost pppd[2991]: Connect: ppp0 <--> /dev/pts/1
    Apr 10 15:48:51 localhost pppd[2991]: LCP: timeout sending Config-Requests
    Apr 10 15:48:51 localhost pppd[2991]: Connection terminated.
    Apr 10 15:48:51 localhost pppd[2991]: Using interface ppp0
    Apr 10 15:48:51 localhost pppd[2991]: Connect: ppp0 <--> /dev/pts/2
    Apr 10 15:48:56 localhost pppd[2991]: tcflush failed: Bad file descriptor
    Apr 10 15:48:56 localhost pppd[2991]: Exit.
    Apr 10 15:48:56 localhost pppoe-server[2990]: Session 1 closed for client 00:13:d4:6b:08:53 (10.67.15.1) on eth1
    Apr 10 15:48:56 localhost pppoe-server[2990]: Sent PADT
    Apr 10 15:48:56 localhost pppoe-server[2990]: Sent PADT
    Apr 10 15:49:12 localhost pppoe-server[3021]: Session 2 created for client 00:13:d4:6b:08:53 (10.67.15.2) on eth1 using Service-Name 'T-Online'Apr 10 15:49:12 localhost pppd[3021]: pppd 2.4.3 started by root, uid 0
    Apr 10 15:49:12 localhost pppd[3021]: Using interface ppp0
    Apr 10 15:49:12 localhost pppd[3021]: Connect: ppp0 <--> /dev/pts/3
    Apr 10 15:49:43 localhost pppd[3021]: LCP: timeout sending Config-Requests
    Apr 10 15:49:43 localhost pppd[3021]: Connection terminated.
    Apr 10 15:49:44 localhost pppd[3021]: Using interface ppp0
    Apr 10 15:49:44 localhost pppd[3021]: Connect: ppp0 <--> /dev/pts/4
    Apr 10 15:49:49 localhost pppd[3021]: tcflush failed: Bad file descriptor
    Apr 10 15:49:49 localhost pppd[3021]: Exit.
    Apr 10 15:49:49 localhost pppoe-server[2990]: Session 2 closed for client 00:13:d4:6b:08:53 (10.67.15.2) on eth1
    Apr 10 15:49:49 localhost pppoe-server[2990]: Sent PADT
    Apr 10 15:49:49 localhost pppoe-server[2990]: Sent PADT
    Apr 10 15:58:39 localhost pppoe-server[3120]: Session 1 created for client 00:13:d4:6b:08:53 (192.168.0.100) on eth1 using Service-Name 'T-Online'
    Apr 10 15:58:39 localhost pppd[3120]: pppd 2.4.3 started by root, uid 0
    Apr 10 15:58:39 localhost pppd[3120]: Using interface ppp0
    Apr 10 15:58:39 localhost pppd[3120]: Connect: ppp0 <--> /dev/pts/1
    Apr 10 15:59:10 localhost pppd[3120]: LCP: timeout sending Config-Requests
    Apr 10 15:59:10 localhost pppd[3120]: Connection terminated.
    Apr 10 15:59:10 localhost pppd[3120]: Using interface ppp0
    Apr 10 15:59:10 localhost pppd[3120]: Connect: ppp0 <--> /dev/pts/2
    Apr 10 15:59:15 localhost pppd[3120]: tcflush failed: Bad file descriptor
    Apr 10 15:59:15 localhost pppd[3120]: Exit.
    Apr 10 15:59:15 localhost pppoe-server[3119]: Session 1 closed for client 00:13:d4:6b:08:53 (192.168.0.100) on eth1
    Apr 10 15:59:15 localhost pppoe-server[3119]: Sent PADT
    Apr 10 15:59:15 localhost pppoe-server[3119]: Sent PADT
    Apr 10 15:59:43 localhost pppoe-server[3119]: Terminating on signal 15 -- killing all PPPoE sessions
    Regards,
    Samuel Hsu

  2. #2
    Join Date
    Nov 2006
    Age
    42
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    I have this problem too in FC6

    I have this problem too in FC6. Please help everybody!

  3. #3
    Join Date
    Nov 2006
    Age
    42
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I have discovered a solution!!!

    http://www.carricksolutions.com/cgi-...Print;f=5;t=31

    I meets the same problem, it seems that ppp-2.4.3 conflict with syslog, shutdown syslog service and try again ?
    (just kill syslogd and klogd daemon)

    I tried ppp-2.4.2 works fine,
    ppp-2.4.3 and ppp-2.4.4 do not make success, the error message is the same as you shown.

    It is work!

  4. #4
    yshsu168 Guest
    hi. EXuDHA:

    Thanks for your solution. I will revision to 2.4.2
    Thanks.

    Regards,
    Samuel Hsu

  5. #5
    ruwanindika Guest
    Thanks MAN , I was straggling with this problem for weeks finally saw ur post !!! thanks a million ,

    I would really appreciate if you can tell me where I can find Document about the parameters for reconfiguring PPPoE configure file ,

    thanks
    Ruwan Indika

  6. #6
    Join Date
    Nov 2006
    Age
    42
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi Ruwan Indika.
    I see ur post in http://www.voy.com/41165/4135.html
    but I think this forum is not good I find there only questions but not answers.
    I am a Russian and I find all information in Russian forums.
    Maybe this help you
    http://www.netup.biz/article-pppoe-server.php
    http://wrath.geoweb.ge/pppoe-server.html
    http://www.carricksolutions.com/cgi-...Print;f=5;t=31
    http://poptop.sourceforge.net/dox/redhat-howto.phtml
    or tell me ur questions about configurations and I try help you.
    Sorry for my poor English.

    Regards,
    EXuDHA

Similar Threads

  1. Need some help with PPPoE
    By knascent in forum Servers & Networking
    Replies: 1
    Last Post: 28th June 2009, 12:47 PM
  2. pppOe
    By justtini in forum Servers & Networking
    Replies: 2
    Last Post: 27th December 2008, 09:48 PM
  3. PPPoE help
    By chrishunt in forum Using Fedora
    Replies: 0
    Last Post: 29th September 2008, 06:08 PM
  4. FC5 pppoe
    By stroon in forum Servers & Networking
    Replies: 1
    Last Post: 22nd March 2006, 08:17 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •