View Single Post
Old 27th August 2005, 10:48 PM
Big Calhoun Offline
Registered User
Join Date: Aug 2005
Posts: 13
Post Quick Recap

Pleased to say that I have the Libretto L5W up and running on Fedora Core 4. Overall. wasn't a bad task...but very challenging. A quick recap in hopes this will help someone in a similar situation.

Background: The Libretto L5W has no native optical drive and is not sold with a native floppy drive. Compatiable drives that have the ability to boot from a CD exist but are hard to find and expensive. After trying other methods, I decided on doing a network install. The network install was done from a another Fedora 4 installation on a Fujitsu P7010D connected to a router. The Libretto was also connected to the router with standard CAT-5. To network boot from a Libretto L5W, you can either press the sideway directional keys or hold F12 as you power on.

The setup was to install a working version of Fedora on a host machine (P7) in order to boot the Libretto so the installation could be started. Once installed, I ultimately created a dhcpd.conf file in /etc:

allow booting;
allow bootp;

subnet netmask {
option subnet-mask;

host pxeclient {
hardware ethernet 00:00:00:00:00:00;
filename "pxelinux.0";
option broadcast-address;

ddns-update-style ad-hoc;

This setup ultimately enabled me to boot the Libretto with a fixed address of and load the pxe boot file.

Next was to setup the TFTP directory and parameters. The /tftpboot directory on the working Fedora P7 machine has the following files and folders:


Now, the first 3 files can be obtained from the Fedora DVD and I imagine several of the other boot ISOs. /pxelinux.fcfg is a folder inside of the /tftpboot directory. 'default' is the default configuration file and has the same contents as C0A80137. PXE booting instructions can be allocated to all machines that attempt to connect or certain IPs. C0A80137 is actually the IP of the Libretto ( in Hex format. Not knowing where the TFTP was going to look for it's instructions first, I created both files to cover all angles. That being said, both /pxelinux.cfg/default and /pxelinux.cfg/C0A80137 have the same contents:

SERIAL 0 9600
label vm
kernel vmlinuz
append initrd=initrd.img ramdisk_size=10000

There is a confiuration file for the TFTP daemon at /etc/xinetd.d/tftp. By default, the server is disabled. This is quickly remedied by opening the file in a text editor and changing the 'disable' option to no.

Before you can begin using the services you must make sure they are activated. By going to Desktop >> System Settings >> Server Settings > Services, I was able to confirm that the tftp and dhcpd services were part of the start up.

After all of the changes, I decided to reboot the P7 to start using the new config. The services should start with bootup if setup correctly although you can also manually start and stop them. To test your DHCPD config, you can simply open a terminal and issue the dhcpd command. If there are errors in the config file, it'll let you know. Otherwise you'll notice it states that a server is already running, among other information.

So I was able to bootup the Libretto and it loaded the appropriate start up files. From the initial setup screen, I actually chose to manually input the IP information (even though DHCP was configured) and I used a public HTTP server for the installation. You'd pick up more speed setting up your own local FTP, HTTP, or NFS server and using that; I had just gotten to a certain...point!

Now this could be specific to the Libretto but, you never know. On my initial connection, the installation went south after formatting and partitioning, as the installation began to read the packages. I had encountered the error before using another boot-up method (GRUB for DOS/NT to install from HTTP server) but never jotted down the error. When I ran into the same situation this time, I recieved the error message (unhandled exception error) but there was no text or code indicating what the actual problem was. I simply rebooted the Libretto and tried again. The second time everything went off without a hitch. Wierd.

So I hope that sums everything up in a concise and usable manner. If you are in a similar situation, this should give you a working setup to use. Among the many things I learned is you have to watch out for the TFTP server; because the config file contains a parameter that specifies the TFTP root directory, adding the full path to your PXE configuration files causes an error that the file couldn't be found.

The first boot-up is kind of slow and I've noticed an error concerning /etc/fstab and something else about fonts, but the main task is succesfully completed. The post config seemed to correctly identify the sound card but I don't here anything. Looking forward to tweaking this machine, sharing the results, and learning more...
Reply With Quote