View Single Post
Old 19th December 2011, 03:18 AM
premudriy Offline
Registered User
Join Date: Dec 2006
Posts: 312
Re: Dell 15z Touchpad

Hello, guys! I have the exact same Dell XPS 15z and struggled a lot trying to solve all the quirks with this laptop. At this point I solved all of the major problems. So, here it comes:

1) To make touchpad working all you need to do is add "psmouse.proto=exps" to the kernel options. For now I just added it at the end of the line starting with "linux /vmlinuz......" in /boot/grub2/grub.cfg

This makes touchpad work, but only in "basic" mode, i.e. no multi-touch. The scrolling on the right side dragging works too.

NOTE: Remember that modifying /boot/grub2/grub.cfg is not permanent and will be overwritten when kernel updates. I'm new to Grub 2 and have to read how to make changes that stick though kernel upgrades, but for now modifying that file at least makes things work.

2) Since Fedora 15 I was noticing that my laptop gets extremely hot and fan runs on high all the time. I found this happens because CPU frequency scaling governor does not load. Therefore CPU always sits at highest frequency. Furthermore, the PowerBoost does work in Fedora which results in CPU constantly running at whooping 3.4GHz.

I have traced this problem to the following: if option "acpi=off" is present in kernel boot options, then CPU is not recognized properly (shows only 1 core). Also, a whole bunch of other acpi-related things don't work like battery charge, suspend, etc.

BUT, if I was to remove "acpi=off" from the kernel options the Fedora would not boot. Then I noticed that removing "acpi=off" and adding "noacpi" instead made things mostly work except the keyboard didn't work (big bummer).

So, after more tinkering I have found the solution that worked:
- simply remove "acpi=off" (and/or "noacpi") from kernel boot option (same file as in 1) and add only "pci=noacpi".

Now my XPS works cool and quiet.

3) Finally, some people can't get WiFi to work no matter what in this 15z, even though the iwl6000b2g driver is installed. I have noticed that the hardware switch to toggle WiFi in Fedora doesn't work, i.e. you can't turn on WiFi with Fn+F2. Therefore, you must boot to windows to turn on the WiFi with Fn+F2. In other words you must make sure that wireless hardware is on before you boot fedora, otherwise even after doing "rfkill unblock all" the "rfkill list" will still show that wireless card is hard-blocked.

I hope this helps!

EDIT: PS: I have noticed that original poster inquired about F15. I am now on F16 with latest updates to date and all the tweaks work. I didn't try these teaks in F15. I just waited though F15 without doing anything, hoping that these issues will be remedied, but they didn't, so I started looking into it myself.

Also, one more quirk about Dell XPS 15z: if you disable "Virtualization Tech" in BIOS, then you will not be able to install Fedora no matter what, it will say something like "...kernel is corrupt and can't load..." or similar. Just a thing to watch out for.

Last edited by premudriy; 19th December 2011 at 03:25 AM.
Reply With Quote