FedoraForum.org (https://forums.fedoraforum.org/index.php)
-   Installation, Upgrades and Live Media (https://forums.fedoraforum.org/forumdisplay.php?f=6)
-   -   can't install fedora 16 KDE (https://forums.fedoraforum.org/showthread.php?t=276737)

bbb13 21st February 2012 01:02 PM

[SOLVED]can't install fedora 16 KDE
first of all, i'm glad to join your community.

can anyone tell me what am i doing wrong and can't install fedora 16 KDE edition??

my system is: ASUS M4A77TD, AMD 6xCore HDT55TFB,12GB DDR3,ASUS GTX 560 TI, 2xWD SATA (each one has a win7x64 installed)

anaconda 16.25 exception report
Traceback (most recent call first):
File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicelibs/swap.py", line 93, in swapon
raise SwapError("swapon failed for '%s'" % device)
File "/usr/lib/python2.7/site-packages/pyanaconda/storage/formats/swap.py", line 133, in setup
swap.swapon(self.device, priority=self.priority)
File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 2085, in turnOnSwap
File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1326, in turnOnSwap
File "/usr/lib/python2.7/site-packages/pyanaconda/packages.py", line 151, in turnOnFilesystems
File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 373, in dispatch
self.dir = self.steps[self.step].target(self.anaconda)
File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 241, in go_forward
File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1201, in nextClicked
SwapError: swapon failed for '/dev/sdb3'

Local variables in innermost frame:
pagesize: 4096
argv: ['/dev/sdb3']
priority: None
num: 4096
rc: 255
device: /dev/sdb3
fd: 27

Anaconda instance, containing members:
_instClass: DefaultInstall instance, containing members:
_intf: InstallInterface instance, containing members:
_intf._initLabelAnswers: {}
_intf._warnedUnusedRaidMembers: []
_intf.anaconda: Already dumped (Anaconda instance)
_intf.installProgress: None
_intf.icw: InstallControlWindow instance, containing members:
_intf.icw._main_loop_running: True
_intf.icw.handle: 2723
_intf.icw.window: Window instance, containing members:
_intf.icw.reloadRcQueued: 0
_intf.icw.currentWindow: PartitionWindow instance, containing members:
_intf.icw.currentWindow.checkmark_pixbuf: Pixbuf instance, containing members:
_intf.icw.currentWindow.intf: Already dumped (InstallInterface instance)
_intf.icw.currentWindow.lock_pixbuf: Pixbuf instance, containing members:
_intf.icw.currentWindow.messageGraph: MessageGraph instance, containing members:
_intf.icw.currentWindow.messageGraph.canvas: Canvas instance, containing members:
_intf.icw.currentWindow.messageGraph.message: Please Select A Device
_intf.icw.currentWindow.messageGraph.canvas_text: None
_intf.icw.currentWindow.storage: Storage instance, containing members:
_intf.icw.currentWindow.storage.clearPartChoice: custom
_intf.icw.currentWindow.storage._intf: None
_intf.icw.currentWindow.storage._platform: None
_intf.icw.currentWindow.storage.anaconda: Already dumped (Anaconda instance)
_intf.icw.currentWindow.storage.dasd: DASD instance, containing members:
_intf.icw.currentWindow.storage.dasd.dasdfmt: /sbin/dasdfmt
_intf.icw.currentWindow.storage.dasd.commonArgv: [-y, -d, cdl, -b, 4096]
_intf.icw.currentWindow.storage.dasd.started: True
_intf.icw.currentWindow.storage.dasd.totalCylinder s: 0
_intf.icw.currentWindow.storage.dasd._maxFormatJob s: 0
_intf.icw.currentWindow.storage.dasd._devices: []
_intf.icw.currentWindow.storage.dasd._completedCyl inders: 0.0
_intf.icw.currentWindow.storage.dasd._dasdlist: []
_intf.icw.currentWindow.storage.autoPartEscrowCert : None
_intf.icw.currentWindow.storage.autoPartAddBackupP assphrase: False
_intf.icw.currentWindow.storage.escrowCertificates : {}
_intf.icw.currentWindow.storage.fsset: FSSet instance, containing members:
_intf.icw.currentWindow.storage.fsset.origFStab: None
_intf.icw.currentWindow.storage.fsset._usb: None
_intf.icw.currentWindow.storage.fsset.devicetree: DeviceTree instance, containing members:

nonamedotc 21st February 2012 04:14 PM

Re: can't install fedora 16 KDE
Did you try installing without swap space? It looks like it is experiencing some problem in creating the swap space.

---------- Post added at 09:14 AM ---------- Previous post was at 09:12 AM ----------

I did a quick search and got these two ...

1. Installing the OS without enabling swap space. You can enable it after Fedora is successfully installed. Same/similar problem addressed in LinuxQuestions.org

2. Try installing with DVD instead of Live CD as noted in this bug report.

Hope this helps.

bbb13 21st February 2012 04:36 PM

Re: can't install fedora 16 KDE
no i already made a swap space. anyway, i'll try the above methods and post back results. thnx

bbb13 23rd February 2012 04:06 PM

Re: can't install fedora 16 KDE
fedora dvd doesnt start at all after media checking...

EDIT: Successfully installed from KDE CD but without swap.

nonamedotc 23rd February 2012 04:50 PM

Re: can't install fedora 16 KDE
Glad it worked! Cheers.

All times are GMT +1. The time now is 08:56 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.