FedoraForum.org (https://forums.fedoraforum.org/index.php)
-   Guides & Solutions (Not For Questions) (https://forums.fedoraforum.org/forumdisplay.php?f=12)
-   -   Install Fedora 11 on an Asus X61SV (https://forums.fedoraforum.org/showthread.php?t=227616)

superfougere 3rd August 2009 02:46 PM

Install Fedora 11 on an Asus X61SV
1 Attachment(s)
Last month I bought a new laptop, an Asus X61SV. I tried to install Ubuntu, but both ethernet and wifi didn't work. So I decided to install Fedora 11, and I encountered many troubles. Now it works fine ! :)

Here is a little howto that can be useful if you wants to install F11 on your X61SV :

- Warning : if you want to keep Vista on your computer, thus having a dual boot, make sure you update Vista with SP2 before installing another system. Because once the bootmanager is changed, windows can't install SP2 anymore and so you've got to reinstall windows bootmanager, update Vista, and reinstall grub ...
- Warning 2 : the Ethernet card won't work after Fedora installation, you'll have to change the driver, so make sure you've got a wifi network available.

- 1) Install Fedora :
- download Fedora 11 live-cd, and burn it. Be carreful, only the x86_64 version (for 64 bits processor) will work : http://download.fedoraproject.org/pu...86_64-Live.iso
- boot on the cd, and press Tab for boot options : add pci=nomsi to the command line, otherwise the live-cd won't boot
- follow the instructions ;)
- 2) Install additional repository :
- connect the WiFi
- update the system : in a terminal, type # yum update
- install yumex : in a terminal, type # yum install yumex
- install rpm-fusion free repository : in a terminal, type # rpm -ivh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
- install rpm-fusion non-free repository : in a terminal, type # rpm -ivh http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
- launch yumex (type # yumex or go to Applications->System Tools->Yum Extender ) and accept updates proposed for rpm repository
- 3) Install Nvidia driver (if not, sleep and hibernate won't work) :
- to know the version of your kernel : in a terminal, type # uname -r
- in yumex, install kmod-nvidia, kmod-nvidia-version_of_your_kernel, xorg-x11-drv-nvidia, xorg-x11-drv-nvidia-devel, and xorg-x11-drv-nvidia-libs
- DO NOT QUIT YUMEX, and uninstall xorg-x11-drv-nouveau
- reboot
- 4) Install Ethernet card (sis191 chip) :
- note : the driver sis190 provided in the kernel 2.6.29 doesn't work, but the one provided by kernel 2.6.31 is OK
- in yum (or yumex) install the package kernel-devel, and gcc
- download sources of the kernel (check the version of your kernel, and then go to : http://www.kernel.org/pub/linux/kernel/ I used http://www.kernel.org/pub/linux/kern....6.29.6.tar.gz )
- extract the sources : in a terminal, go in the download directory (# cd /home/my_user/my_download_directory) type # tar xzvf name_of_the_downloaded_targz
- now log as root : in a terminal, type # su - and enter the root password
- move untared files in the sources directory : in a terminal, go in the download directory, and type # mv linux-version_untared/* /usr/src/kernels/version_of_the_kernel/ (if the directory doesn't exists, type # mkdir /usr/src/kernels/version_of_the_kernel )
- go into the src directory ( # cd /usr/src/kernels/version_of_the_kernel ), and type # make menuconfig ... choose "exit", and "save"
- download sources of kernel 2.6.31-rc5 ( http://www.kernel.org/pub/linux/kern....31-rc5.tar.gz ) and extract sis190.c (or use the file joined to this post)
- copy sis190.c to the sources directory : from the download directory type # cp sis190.c /usr/src/kernels/version_of_the_kernel/drivers/net
- compile the driver : in a terminal, go to /usr/src/kernels/version_of_the_kernel, and type # make drivers/net/sis190.ko
- unload old driver, and load the new one :
- type # rmmod drivers/net/sis190.ko
- type # cp drivers/net/sis190.ko /lib/modules/`uname -r`/kernel/drivers/net/
- type # modprobe sis190
- Now it should work ! Check in dsmesg ( in a terminal, type # dmesg ) you should see the following entries :
eth0: auto-negotiating...
eth0: mii ext = 0000.
eth0: mii lpa=41e1 adv=01e1 exp=0007.
eth0: link on 100 Mbps Full Duplex mode.
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
- 5) Configure the hotkeys :
- Note : most of the hotkeys work, except "Touchpad off", a strange key "S", and the hotkey for energy saving. You must reconfigure "media player stop", and "webcam".
- Go into System->Preferences->Keyboard Shortcuts
- Modify Sound->Stop
- Add a new entry for the webcam at the end of the list : use the commande cheese).
That's all folks ;)
Hope it will help someone. If you've got question or remark, I'll be glad to read it.

PS : Sorry for language mistakes (not my native).

JohnnyLinux 3rd August 2009 05:58 PM

Could you do me a big favor and try running Blender (3d app).

Thanks. I want to see if it will open with the install of the Nvidia drivers you did.

superfougere 3rd August 2009 10:24 PM

I installed blender with Yumex : it seems to work perfectly (I don't know how to use it, but it lauch, and I can draw something).

I use kernel ...

JohnnyLinux 4th August 2009 04:55 AM

Thanks. I just wanted to know if it would launch at all because I haven't been able to configure my Nvidia drivers to work with anything 3d. It's kind of frustrating having a good GPU just sitting there doing 2D work. Thanks.

All times are GMT +1. The time now is 02:57 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.