PDA

View Full Version : Desktop (X Server?) simply crashes



kewlemer
16th March 2006, 04:29 AM
I am running FC4 on a Xeon Dell Precision WorkStation 670. Its graphic card is Nvidia FX1400.

The problem I am having is that my desktop breaks after some time of logging in. I felt the easiest way to describe this is to show screen shots:-

[img=http://img225.imageshack.us/img225/1521/bugshot18ke.th.png]

[img=http://img131.imageshack.us/img131/9756/bugshot26ab.th.png]

[img=http://img131.imageshack.us/img131/4274/bugshot37ms.th.png]


I updated the Nvidia drivers from:-
http://www.nvidia.com/object/unix.html
It seemed fixed for a couple of days but then the problem recurred.

I have multiple versions of Python because of which system-display-config would not open and would complain about python2 missing. My python installation probably removed /usr/bin/python2. I then put symlink for python4 (default for my system) in /usr/bin/ as python2 and then system-display-config worked. The dell monitor is of 1280X1024 and my display settings are also set to this. I also don't see anything wrong with my xorg.conf file which is in the end.

I also changed the work-station, thinking it may be a hardware issue, but no use.

I initially had a Sony monitor which had a higher resolution (1600X1200) and I had the same problem with that too.

I tried using 2 different DVI cables and also a VGA-DVI converter, but the problem persisted (the workstation only has a DVI output and so right now I am using a VGA-DVI converter).

The problem occurs both in GNOME and KDE, though it pops up faster in KDE.

Updating X11 also did not help. But the display crash seemed different:-

[img=http://img125.imageshack.us/img125/3041/afterupdate0hc.th.png]

I just goy this python error when I tried to open yumex :-


[root@localhost ~]# yumex
Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
Traceback (most recent call last):
File "/usr/share/yumex/yumex.py", line 24, in ?
import gtk
File "/usr/src/build/535819-i386/install/usr/lib/python2.4/site-packages/gtk-2 .0/gtk/__init__.py", line 37, in ?
RuntimeError: could not open display
[root@localhost ~]#
Can it be a python issue?

Any help or suggestions are welcome.


My xorg.conf file :-


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Sony SDM-X202 (Digital)"
HorizSync 30.0 - 92.0
VertRefresh 55.0 - 65.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA Quadro FX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

kewlemer
16th March 2006, 04:36 AM
Sorry, the image links seem to have a problem. Please try these links for the crash screen shots:-

http://img225.imageshack.us/img225/1521/bugshot18ke.th.png (http://img225.imageshack.us/my.php?image=bugshot18ke.png)

http://img131.imageshack.us/img131/9756/bugshot26ab.th.png (http://img131.imageshack.us/my.php?image=bugshot26ab.png)

http://img131.imageshack.us/img131/4274/bugshot37ms.th.png (http://img131.imageshack.us/my.php?image=bugshot37ms.png)

http://img125.imageshack.us/img125/3041/afterupdate0hc.th.png (http://img125.imageshack.us/my.php?image=afterupdate0hc.png)

Thanks,
K

tashirosgt
16th March 2006, 04:43 AM
The magi c cookie business is often related to the .Xauthority file in the users home directory being corrupt. Do you get magic cookie errors if you run as root or as a newly created user?

kewlemer
16th March 2006, 04:51 AM
Its as root (prompt also shows that above).

Thanks,
K

tashirosgt
16th March 2006, 03:30 PM
You said that you downloaded the Nvidia driver. It's instructions say the driver name in the xorg.conf file should be "nvidia". But in you xorg.conf file you are still using "nv".

kewlemer
16th March 2006, 07:37 PM
You said that you downloaded the Nvidia driver. It's instructions say the driver name in the xorg.conf file should be "nvidia". But in you xorg.conf file you are still using "nv".
Thanks, tashirosgt. That was the problem. I had messed that while messing around with my xorg.conf.

Regards,
Harsha