PDA

View Full Version : sonypi problem 2.6.15-1.1831_FC4



blimbo
1st March 2006, 10:02 PM
I can't seem to load the sonypi module anymore with kernel 2.6.15-1.1831_FC4:

[root@VAIO tim]# modprobe sonypi
FATAL: Error inserting sonypi (/lib/modules/2.6.15-1.1831_FC4/kernel/drivers/char/sonypi.ko): Device or resource busy

dmesg says:

sonypi: misc_register failed

/dev/sonypi exists. This worked before but I've only just noticed the module failing to load at start up and I'm not sure what I did to break it!

Any help much appreciated,
Cheers
Tim

code_astronomer
1st March 2006, 10:19 PM
Have you recently updated your kernel? Did you have to build the module yourself?
It could be that you need to rebuild the module if the kernal has been updated.

blimbo
1st March 2006, 10:26 PM
I'm pretty sure it worked after my last kernel update (via yum)..

How do I go about rebuilding a module anyway? I'm not sure where to find the source

code_astronomer
1st March 2006, 10:44 PM
How did you install it? Did it just work?

The only reason I mentioned rebuilding the module is because I have had similar problems in the past, and I had to rebuild my driver module (for a wireless modem)...but I had to downloaded the source in the first place.

If you didn't build it anyway, I don't think you would have to rebuild it now. Unless something changed in the kernel. I can't be sure, sorry. It was just a suggestion. Perhaps this is not a solution for you.

blimbo
1st March 2006, 10:49 PM
I didn't build it, I think it has come with the kernel as standard for a while now. When it worked I just did a simple modprobe sonypi and it worked fine. Since then I've done a bit of fiddling with the driver that uses the module so something has probable messed it up. Might go and try some earlier kernels and see if it works there. Cheers tho

code_astronomer
1st March 2006, 10:52 PM
you could always try removing it and adding it again using:

rmmod sonypi
and then

modprobe -v sonypi
replace sonypi with whatever the real name is if this is incorrect.

blimbo
1st March 2006, 11:02 PM
Haha you helped me crack it with your -v on the modprobe!

It wasn't loaded so the rmmod wasn't going to do any good.

I read somewhere else that I needed to edit this into modprobe.conf:
alias char-major-10-63 sonypi

the modprobe -v sonypi

gave me this:
insmod /lib/modules/2.6.15-1.1831_FC4/kernel/drivers/char/sonypi.ko minor=63

so I figured it had to be something to do with that 63. So took that line out of modprobe.conf and now it works..cheers!

Now I better find out what it means/what I should replace it with

code_astronomer
1st March 2006, 11:21 PM
oh good :)
I have no idea about the minor=63 unless it's the build revision of the module.
but I'm glad it's working now :) Good luck with the last bit! :)