PDA

View Full Version : yum not working on FC4 install



smacv
26th February 2006, 07:53 PM
I was under the impression that yum came installed as standard on FC4. However on trying to get the latest yum.conf I get the following:-

[root@ etc]# rpm -Uvh http://www.fedorafaq.org/yum
Retrieving http://www.fedorafaq.org/yum
error: Failed dependencies:
yum is needed by yum-fedorafaq-4-2006.02.03.noarch

I was more than a little surprised - I can't find yum anywhere on my FC4 installation.

Ideas? Suggestions? Explanations?

Thnx in advance,
Steve.

bob
26th February 2006, 08:14 PM
Open a terminal and type "whereis yum" - response should be something like this:
yum: /usr/bin/yum /etc/yum /etc/yum.conf~ /etc/yum.conf /usr/share/man/man8/yum.8.gz

Then, try something simple, like 'yum clean all' and see if you get a response.

smacv
26th February 2006, 08:22 PM
No joy. It just reports location of conf file.

whereis yum
yum: /etc/yum.conf

I wonder if my install of FC4 screwed up somewhere but I've been using it for a couple of weeks now (this is the first time I've played around with yum and up2date).

bob
26th February 2006, 08:35 PM
Yes, it's supposed to be there - something is definately messed up. Try going here: http://rpm.pbone.net/index.php3/stat/4/idpl/2489488/com/yum-2.4.1-1.fc4.noarch.rpm.html
and pressing the "check requires' button. That will give you any dependency issues.

bob
26th February 2006, 08:54 PM
WOW! Tried doing that myself - I'm missing all sorts of things on my working yum. So, obviously that isn't a perfect system! Well, try going to a mirror site for Fedora and simply downloading a yum.rpm and then 'rpm -Uvh yumwhatever.rpm'.

smacv
27th February 2006, 10:46 AM
cheers, will do. Thnx for the help.

Steve.

smacv
28th February 2006, 12:19 AM
Tried that. Now I am getting the following:-

rpm -Uvh yum-2.4.2-1.src.rpm
warning: yum-2.4.2-1.src.rpm: Header V3 DSA signature: NOKEY, key ID 69886cc7
1:yum warning: user skvidal does not exist - using root
warning: group skvidal does not exist - using root
warning: user skvidal does not exist - using root)
warning: group skvidal does not exist - using root

obviously I am new to all this :-)

smacv
28th February 2006, 12:27 AM
tried using both the gz and rpm files (not really knowing what I am doing with either). Tried building the gz in the normal fashion (make install) and for the rpm used

rpmbuild --rebuild yum*.src.rpm

Tried doing a 'yum list' and got the following:--

There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

No module named rpmUtils

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.4.1 (#1, May 16 2005, 15:19:29)
[GCC 4.0.0 20050512 (Red Hat 4.0.0-5)]

FAQs not a big help to me - what I need is to be led through the nose on this one. Thnx.

bob
28th February 2006, 12:48 AM
Try going here: ftp://mirror.linux.duke.edu/pub/fedora/linux/core/4/i386/os/Fedora/RPMS and download yum-2.3.2-7.noarch.rpm then:
'su -' and password
"cd /home/skvidal"
"rpm -Uvh yum-2.3.2-7.noarch.rpm"
Let's see if that gets it installed.

smacv
28th February 2006, 08:48 PM
Got a later version and tried it:-

error: Failed dependencies:
python-elementtree is needed by yum-2.4.2-1.noarch
python-sqlite is needed by yum-2.4.2-1.noarch

Grinding my teeth in frustration now. I am assuming I am seeing all these problems as I upgraded from RH9 to FC4. Perhaps the upgrade did not pull in things like yum and the Python files. Suggestions? (Add/Remove Applications? - which ones :-)

Thanks again bob for your continuing help (and patience!)

smacv
28th February 2006, 09:05 PM
bit the bullet and installed said rpms (still not sure what I am doing here - especially looking at the SRPMS and SOURCE dirs.

But it seems like it works. What I'd like to know is how come FC4 didn't install all these packages in the first place since yum is supposed to come as standard. Was it because I had went from RH9 to FC4 directly? Did the upgrade to the OS simply upgrade apps and files already there and no install new packages unless I specifically ordered it to.

Still , it is enjoyable figuring all this stuff out :-)

smacv
28th February 2006, 09:17 PM
spoke too quickly - now its

Error: Missing Dependency: licq = 1.2.3 is needed by package licq-gnome
Error: Missing Dependency: qt = 1:3.1.1-6 is needed by package qt-Xt
Error: Missing Dependency: libdb-4.0.so is needed by package openoffice-libs
Error: Missing Dependency: mh is needed by package exmh
Error: Missing Dependency: gcc-java = 3.2.2 is needed by package jdkgcj
Error: Missing Dependency: php = 4.2.2-17 is needed by package php-manual
Error: Missing Dependency: libdb_cxx-4.0.so is needed by package openoffice-libs
Error: Missing Dependency: licq = 1.2.3 is needed by package licq-text
Error: Missing Dependency: licq = 1.2.3 is needed by package licq-qt
Error: Missing Dependency: libgcj = 3.2.2 is needed by package jdkgcj

:-(

Firewing1
28th February 2006, 09:19 PM
RH9 > FC update...
That's it. It's always better to format & fresh install in FC and not "upgrade" as then problems like these occur.
What I did is on my FC3 install I decidec I have my /home folder on a seperate partition. I backed up, erased all, and then told "Custom Partitioning" with this layout:
MOUNTPOINT --> SIZE TYPE
/boot --> 100MB ext3
<swap> --> [double your RAM's size] swap
/home --> 1/2 remaining space
/ --> Rest of drive (the other 1/2 remaining)
Then, on a new install, I say custom layout, and mount / as /, formatting, /boot as /boot, formating, swap as swap, formating, and /home as /home WITHOUT format. This effectively preserves all preferences and documents. If you'd also like to store RPMS you can do this on your old system:

rpm -qa --qf '%{NAME} ' > rpms_yum.txt
When it finished you will find a rpms_yum.txt file. Back it up, install, (with /home on a seperate partition, it's better...) then transfer it back to the new system & install the correct yum repos. Run this:

cd /path/to/where/rpms_yum.txt/is/stored
su
yum install $(cat rpms_yum.txt)
This will clone packages installed.
Firewing1

smacv
28th February 2006, 09:30 PM
thanks for the detailed post! I know you are going to want to throttle me after this but its probably a little beyond my technical abilities at this point. From what I have seen elsewhere I could do a yum remove on the packages causing the dependency errors but since I don't know what these are I am not sure what that could affect!

Firewing1
28th February 2006, 09:39 PM
lol... I never do a yum remove as sometimes it tries to uninstall 1/2 your system :eek:
I do
rpm -e packagename packagename2
to remove my packages.
Firewing1

smacv
28th February 2006, 10:01 PM
Well, yum is now working after doing the yum remove - and you are right, I think it blew openoffice completely out of the water but once its done doing its 'thang' I'll try and reinstall it and hopefully dependencies will be gone.

Tough going this Linux.