PDA

View Full Version : Qmail error on SMTP



Swaytech
27th January 2006, 11:23 AM
I've gone thropugh the install on Qmail from the website and up to this points its almost working

http://www.qmailrocks.org/start_qmail.htm

I can tenet into the pop and smtp and I sent an email to a user on the domain and it was picked up in the list command.

I then used another pc on the network, I set up the account in Outlook express to retrieve the test email and hey presto it was there..

I then though I'd send and email back.... however when I did this I get the following error

The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was 'stuartp_uk@hotmail.com'. Subject 'test', Account: 'Gateway, Server: '192.168.0.100', Protocol: SMTP, Server Response: '553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)', Port: 25, Secure(SSL): No, Server Error: 553, Error Number: 0x800CCC79

this is the second time I've tried this I first tried it using the domain of the server this time I used the LAN ip, but it still had the same error

I've sent the logwatch out as a test from the server via the command line and that works fine..

Any idea's I'm sure its something simple that I've missed

Thanks Stuart

Swaytech
27th January 2006, 01:25 PM
OK I've edited the /var/qmail/control/rcpthosts and added in a few usual domains, but I dont want to do this every time


Is there a way I can permit all domains but have a file that denys domains as that would surley be a shorter list

Swaytech
27th January 2006, 01:51 PM
Hows about wildcards *.com *.co.uk etc




"Don't call me Shirley"

maruz
27th January 2006, 04:30 PM
i suggest you:
http://www.lifewithqmail.org/lwq.html
your issue maybe is something related to this?? -> 2.8.2.3. SMTP Access Control

Swaytech
30th January 2006, 08:32 AM
MMM I have the localhost 127.0 addy allready set

According to this this should happen:-

http://www.lifewithqmail.org/lwq.html#smtp-reject

but sureley if I allow the domains anyone can send out through my server on those trusted domains?

Is there anyway I can permit all from my Local NIC 192.168.0.100
(it has 2 NICs 1WAN 1LAN)

Swaytech
30th January 2006, 08:35 AM
yep just checked from another external account and manged to send an email to one of the trusted domains through this server.....

Swaytech
30th January 2006, 08:41 AM
Cheers maruz

Deleted all the trusted domains from rcpthosts

and ran an extra relay

echo '192.:allow,RELAYCLIENT=""' >> /etc/tcp.smtp

thats that part working ..... great .....