PDA

View Full Version : fc4 new install problems



fdtdmab
26th January 2006, 04:16 PM
I just installed fedora core 4, but am having difficulty installing my software. There seems to be some problem with accessing shared libraries, but I have no idea how to solve it.

I was unable to start the installer for matlab due to:

/tmp/6239tmwinstall/update/bin/glnx86/xsetup: error while loading shared libraries: /tmp/6239tmwinstall/update/bin/glnx86/libmwins.so: cannot restore segment prot after reloc: Permission denied

I have a similar problem with Mathematica:
/usr/local/Wolfram/Mathematica/5.2/SystemFiles/Kernel/Binaries/Linux/MathKernel: error while loading shared libraries: /usr/local/Wolfram/Mathematica/5.2/SystemFiles/Libraries/Linux/libmkl.so: cannot restore segment prot after reloc: Permission denied

any thoughts?

grndplane
26th January 2006, 04:41 PM
Go to this site. http://stanton-finley.net/fedora_core_4_installation_notes.html

I did almost everything on that site and my install is working great.
Good Luck

fdtdmab
26th January 2006, 04:45 PM
I did most of the stuff on http://stanton-finley.net/fedora_co...tion_notes.html too.

everything else works perfectly on the install. i just can't seem to install these programs properly

dbacklund
19th March 2006, 08:29 PM
I was having the same problem as you so I did some research and found this. Hope it helps :)

--------------------------------------------------------------------
Newer Linux distributions have enabled new kernel security extensions from the SELinux project at the NSA. These extensions allow finer-grained control over system security. However, SELinux also changes some default system behaviors, such as shared library loading, that can be problematic to third party programs.
If you receive the error message "cannot restore segment prot after reloc: Permission denied" when launching IDL, then your SELinux configuration is preventing IDL from launching.
To rectify this issue, you can either:

Change the default security context for IDL by issuing the command:

chcon -t texrel_shlib_t /usr/local/rsi/idl_6.1/bin/bin.linux.x86/*.so

Disabling SELinux altogether by setting the line

SELINUX=disabled

in your /etc/sysconfig/selinux file.
---------------------------------------------------------------------------------

a thing
19th March 2006, 08:51 PM
Also don't get comfortable and customize it all yet, since FC5 is coming tomorrow.

thingfish
16th April 2006, 08:53 PM
wotcha,

hope you've solved the prob., but if you haven't, i recently put mathematica 5.0 on an FC 4 system & had similar probz; there's a brief howto solving the problem of shared libraries memory protection for Mathematica which cna be found at:

http://support.wolfram.com/mathematica/systems/linux/general/selinux.html

hope this helps, it sorted the mathematica problem for me. dunno about the other software tho ...