PDA

View Full Version : libc.so.6 required for Alsa-lib...this has to do with gcc how?



Dumbledore
22nd January 2006, 05:57 AM
I'm trying to install gcc on my computer (Fedora Core 4, i386) but everytime I try, I run into a dependency issue of the gcc installer, that says it can't find libc.so.6 which is needed for Alsa-lib. First of all, how does alsa fit into this? It's a sound application, I'm trying to install a C compiler. Second, libc.so.6 is on my computer, in two differnt locations; /lib/libc.so.6 and /lib/i686/nosegneg/libc.so.6. So what is the problem? :confused:

jim
22nd January 2006, 05:59 AM
ost all the steps you are typing as well as any command line output you recieve

Dumbledore
22nd January 2006, 05:37 PM
Okay, I've tried

[root@localhost dumbledore]# yum install gcc.i386

and that just brings up this error:

Error: Missing Dependency: glibc-common = 2.3.5-10.3 is needed by package glibc
Error: glibc-common conflicts with glibc < 2.3.90
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package alsa-lib

Now, I know for a fact that I have glibc-common and glibc installed. Here's what happens when I try to install the rpm package I downloaded:

[root@localhost dumbledore]# rpm -i /home/dumbledore/My_Documents/Downloads/gcc-4.0.2-8.fc4.i386.rpm
error: Failed dependencies:
glibc-devel >= 2.2.90-12 is needed by gcc-4.0.2-8.fc4.i386

This is what happened when I tried to install glibc-devel using yum:

[root@localhost dumbledore]# yum install glibc-devel.i386
...
Error: Missing Dependency: glibc-common = 2.3.5-10.3 is needed by package glibc
Error: glibc-common conflicts with glibc < 2.3.90
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package alsa-lib

That is exactly what I did. Any suggestions other than forget about it, you're not going to be a C programmer?