PDA

View Full Version : updated hal fail on boot (help)



lazlow
19th January 2006, 01:54 PM
Still Noob

Ok, I yumed hal (been fighting a new dvdwriter) and everthing went ok. On reboot I get a hal failure. Screen goes black with hourglass and stays there.

How do I get back up running?

FC4

Thanks
lazlow

lazlow
19th January 2006, 11:06 PM
hal0.5.6-1.1 updated libsvg to 2.12.7-2.1 which caused the screen hang
Backed hal to 0.5.2-2 and hal is working
So fixed (sort of)

hal0.5.6-1.1 entered fstab as dvdrecorder
hal0.5.2-2 enters fstabab as cdrecoreer

Is this why I am have DVDwriter problems? CDwriter(same drive) works fine

lazlow

lazlow
25th January 2006, 12:53 AM
Hi Back Again. According to SmartPM 0.41:

Package hal-0.5.6-2.1.fc4.nr@i386 can't coexist with hal-0.5.2-2.fc4.1@i386
Unsatisfied dependency: librsvg2-2.9.5-2@i386 requires libgsf-1.so.1
Package librsvg2-2.12.7-2.1.fc4.nr@i386 can't coexist with librsvg2-2.9.5-2@i386

And so Hal is down again. I had hoped with the newer Hal this would be cured.

Any Help? (Please)

lazlow
25th January 2006, 03:33 AM
Ok libsvg2 problem first:

The install was looking for /etc/gtk-2.0/i386-redhat-linux-gnu/
I had /etc/gtk-2.0/i686-redhat-linux-gnu/

I copied the directory and renamed it i386 as above.

This cured this problem. (I hope I have not mad another)

Hal Fix (stolen from JEO's post)

The problem with hal not loading is due to having Selinux enabled. The Gnome 2.12 update also updates hal (hald haldaemon, fstab-sync) and there is no updated selinux-policy-targeted rpm to go along with it. The way I got hal to work is to change selinux into permissive mode. To do that select Desktop, System Settings, Security Level, SELinux tab, and uncheck the checkbox next to Enforcing: Current and hit OK. Reboot, and hal will load. You will still see error messages from SELinux in the # dmesg log but since enforcing is now off it will not prevent hal from doing its 'thing" and devices will show up in gnome-volume-manager. Like /media/floppy, /media/cdrom, /media/cdrecorder, etc.

Not my favorite way to fix but it works