PDA

View Full Version : Segmentation faults and relocation errors



kembuco
17th January 2006, 04:19 AM
Hello,

I think I might be in some hot water. First off I have Fedora Core 2 installed. So, I used yum to upgrade cvs. I did: yum upgrade cvs . It asked me to update some dependencies. When it was finished I was getting a relocation error when trying to run the cvs command. I then, for some reason, used yum to upgrade up2date. Again it asked to update some dependencies and I said yes. This leads me to the problems I am having now. I get a segmentation fault when I try to run yum, up2date, su, cvs. So I tried installing apt-get to update the whole system. However I am getting this error when trying to run this command:


[kburke@host downloads]$ sudo rpm -Uvh apt-0.5.15cnc6-1.1.fc2.fr.i386.rpm
sudo: relocation error: /lib/libpam.so.0: symbol __sprintf_chk, version GLIBC_2.3.4 not defined in file libc.so.6 with link time reference

I'm not terribly familiar with linux administration, but I need to know if there is anything I can do besides a fresh install. Live and learn I guess.

Thanks a bunch,
Kevin