PDA

View Full Version : Installing on a G3 300Mhz



sycomonkeys
13th January 2006, 01:22 AM
I am having issues trying to get Fedora 4 to install. I am starting to wonder if the fact this G3 has a Motorola processor would cause any problems. Help, I'm a newb to Linux.

Spoon!
13th January 2006, 02:41 AM
First of all, make sure you have the PPC version of Fedora Core. Is it beige (Old World) or blue and white (New World)? If it is the latter then it should be easy; if it is the former then it is a lot harder.

sycomonkeys
13th January 2006, 04:37 PM
It is a blue and white G3. Any particular hard drive format I should be using? I have also downloaded ALL of the ISO's in the PPC and burned them using Toast and Disk Utility.

big_mac126
14th January 2006, 03:48 AM
make sure u have an Apple bootstrap partition...follow the directions on the guide in the forum list

sycomonkeys
14th January 2006, 09:25 PM
When running anaconda it is attempting to start native X server
It freezes here:
"mini-wm:Fatal IO error 104 (Connection reset by peer) on X serrver :1.0."

help?

sycomonkeys
14th January 2006, 11:22 PM
I found how to fix this problem.

But I am now getting partition errors, my friend gave me an old harddrive and is there a certain formatting style I should use?

tomcat
15th January 2006, 12:35 AM
Just erase the partitions on it again and set up new, clean ext3 formatted ones. If you still get partition errors you should check the health status of the drive. If it's very old it could well be that some clusters are corrupt and need to be zero'd. If you are very unlucky, the drive might be dead in some months.

sycomonkeys
15th January 2006, 02:56 AM
The error message I get is "The partition's data region doesn't occupy the entire partition"

tomcat
15th January 2006, 12:50 PM
http://www.terrasoftsolutions.com/support/solutions/ydl_2.3/install_oldmachine.shtml
http://forums.fedoraforum.org/showthread.php?t=67544
http://www.livejournal.com/users/jwulf/2372.html

These should help. Read all of them carefully, especially the last one that has links to working, patched cds.

sycomonkeys
16th January 2006, 07:17 PM
Okay I got it installed, Thanks tomcat... But now I ran in to another issue
It fails in the booting...
When checking filesystems
Error reading black 25 (Attempt to read block from filesystem resulted in short read).

/dev/VolGroup00/LogVol00: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY


Help?

Error403
17th January 2006, 04:55 PM
Hi there, I got myself two beige G3s and I'm wondering if I can mege the two to a "uber-mac". Problem is, they got fdisked and now I can't boot to anything at all. They were given to me and the owners did not have the Mac OS 8/9 cds. Any help? Thanks