View Full Version : NFS File size limit exceeded

10th January 2006, 07:04 AM

This is *not* a standard question why I can't copy my file that is 2,5Gb
over NFS, no. ;)

On the w2k box a NFS export is configured (with some commercial app) so
that a NAS share that is 550Gb size is exported to Linux boxes.

The problem is that every time user wants to copy a file to this
exported share, he get "File size limit exceeded" error. However, it is
possible to copy from this share but not the other way around.

This was working just fine until the win admin didn't enlarge this NAS
share from 350 --> 550Gb.

I've tried with all kinds of mount options, but still the same error.
"df -h" shows the correct values, and "ulimit -a" shown correct numbers.
There is no quota setup on the shares. The client is Redhat 9. with
kernel 20.4.20-8 and nfs-utils 1.0.1-3.9. The NFS permissions are ok.
Writing and reading to other shares that are also exported on NAS are
working fine.

Don't know what went wrong here? Are there any NFS limitation for 2.4.x kernel that I should know about?
Any help is appreciated.