PDA

View Full Version : FC4 Annoyances



tux_fighter
17th December 2005, 11:25 AM
Hi Guys,
I have been using linux since a year now...........but somethings always annoy me.........
I got a new system a few months back.......config goes like this.........
Athlon64 3000+(socket939)
512 MB DDR 400 ram
MSI RS480m2-IL Motherboard
Ati Xpress200 onboard Graphics card
160GB PATA IDE drive
.................................................. .
now i have a dual boot with windows xp,and i have fedora core 4 installed in the last 10 gb.Now i can't get xine and mplayer to work...........everythin else works fine,i have ati proprietry drivers installed.............
Can u plz help me out here :)

tomcat
17th December 2005, 12:46 PM
What problems did you encounter? Did you follow the instructions of the Fedora-FAQ?

linmix
17th December 2005, 08:54 PM
What is it mplayer and xine don't do you expext them to do? Did you install the codecs?

tux_fighter
22nd December 2005, 10:03 AM
well, first of all thnks fr replyin..........
i had to install them using the --nodeps n --nosignature flag..........as the rpm asked for some dependencies also totem frontend doesn't find find the xine-lib even after installing it............i hav tried changing ld.so.conf.same problem with mplayer it asks for libmp3lame........

brunson
22nd December 2005, 05:25 PM
The dependencies are there for a reason, it's because the package *DEPENDS* on them. If you don't have the proper dependencies, you shouldn't expect the software to work.

P.S. Your period key seems to stick, you should look into that.

Lord_Kaos
22nd December 2005, 06:03 PM
tux_fighter, like brunson is implying, you should have done the install via YUM rather than RPM. YUM will make sure that the dependencies are accounted for and notify you of anything else that is required before installing and will install those dependencies for you as well. It really prevents these headaches that you are describing.

brunson
22nd December 2005, 07:10 PM
If you have an RPM version that is different from what is in the yum repos, then you can still get yum to resolve the dependencies by using "yum localinstall <rpmfilename>"

tux_fighter
24th December 2005, 11:39 AM
well,don't you guys think i know all that :confused: ,I can't use yum because I don't have an internet connection at home.Surprised!!! you should be cuz lesser mortals like me who live in india don't hav that kind of broadband connection..............
Please tell me something that can be done offline.I have to ise a public computer even for these posts.

I am almost fighting my way thru to use linux(that's why the name).

Everybody here thinks that I am a geek with nothin better to do :rolleyes: .
Please help guys I have clean install of core 4 .Where do i get these dependencies.It asks something like libxvmcw.so.........n some other files.
Everything else works fine :confused: .I have xmms working flawlessly n X works really fast on my system.Please help.

tux_fighter
24th December 2005, 11:43 AM
hi linmix,
thanks for the reply.there are some dependencies that are asked for like libxvmc.so etc
can u tell me where i can get these,i don't hav a connection with my linux box as it doesn't support my soft modem.stuck with dialup:-((.Xmms works fine and so does eveything else if i could just get my xine to work I could abandon windows once n for all

linmix
24th December 2005, 12:21 PM
I'm on dial-up myself, with an external serial modem...
To find which rpms contain the dependencies you need check out www.rpmseek.com and use the 'what provides' option to search out the necessary packages.

Even so, your best option is to do a full install of fc4 (there are more packages in the full install then when you seeverything in the list one by one!!)

Lord_Kaos
25th December 2005, 06:23 AM
Alternately, you can uninstall the programs that you installed improperly and use the add/remove programs within the Gnome or KDE interface. This will allow you to install via the installation source which i would assume is CD. It will pull all of the dependant files from the CD. For newbie users, there shouldn't be a real reason to stray too far from the add/remove programs application or YUM. RPM isn't exactly user friendly for a new user.