PDA

View Full Version : NRPMS repo blowing up



esemtee
12th December 2005, 07:44 PM
When I try to update evolution with Yumex, it constantly ends with an error. It seems the only repo with the Evolution update is NRPMS.

Is there something I need to change? Or something I am not doing right? I am still pretty new to Linux, so any help will be great. Please give it to me in Laymans' terms though!

nlkrio
12th December 2005, 07:50 PM
open terminal as root and use yum:
yum --enablerepo=NRPMS update evolution

esemtee
12th December 2005, 08:30 PM
I have been using Yum in a terminal and still get the same thing. Moved to GUI because it is easier to select and deselect repo's.

The error that keeps coming up is: "Error in Transaction" while it is downloading.

nlkrio
12th December 2005, 08:51 PM
what repos do you use?

esemtee
12th December 2005, 09:23 PM
These are the repo's that I have enabled currently:

dries
atrpms
nrpms
jpackage-generic-free
kde-redhat-all
flash
kde-redhat
dag
updates
freshrpms
jpackage-distspecific-fre
jpackage-generic-devel
extras
newrpms
release

smfinley
12th December 2005, 09:27 PM
Your are using atrpms which replaces core files in your installation. See this warning (http://stanton-finley.net/fedora_core_4_installation_notes.html#Warning) and this (http://fedoraproject.org/wiki/JohnMahowald/ATrpmsWarning) as well.

nlkrio
12th December 2005, 10:14 PM
atrpms is a repo of giving much trouble if you want to update,i only use it to install a package and then i disable it!