View Full Version : Linksys WMP54G and ndiswrapper 1.7 : problems !

9th December 2005, 12:41 PM
Hi there,

I am new to Linux (or almost), at least new to wireless networking in Linux.

I spent a few weeks with Ubuntu, happy with almost everything I seen there, but since I am planning to run a small website and an ftp server for private purposes, plus samba to make a file repository accessible from windows machines in the house.

After having trouble activating wireless cards in Ubuntu, I was advised to try some red hat/fedora core distribution.

The machine running the server currently can dual-boot win2003 server or FC4. There is an onboard fast ethernet NIC, and I added the Linksys PCI WLAN card. Under windows, both devices are configured with fixed IPs and the setup works fine.

Under FC4, the built-in NIC works like it should, fixed or DHCP. I installed ndiswrapper 1.7 according to the wiki directions, then installed the WMP54G winxp driver (from the CD, tried also later builds from Linksys).

The wlan0 interface is created, and iwconfig tells me my network is found, essid is correct, signal and quality are as goos as they get. Unfortunately the WAN card won't get an IP from the router, although all security is down, and all MACs are allowed to pair with the router.

dhclient just puts me in a look where I get no IP from the router. Using a fixed IP doesn't work either. Any suggestion ? The problem was identical in Ubuntu, but I know the card works fine, since in win2003 the wireless link is excellent.

I already ordered a cheap A-Link http://www.a-link.com/uk/WL54H.html which uses a different chipset and is apparently easier to install with the 2.6 kernels.

Any help appreciated !


12th December 2005, 09:47 PM
Well considering the numerous answers, here is my own one. And thank you scorpio for your suggestions.

So I did a reinstall again, and after that played with the /etc/sysconfig/network-scripts/ifcfg-wlan0 file until I felt the need to delete the wireless interface from the network adapters list, and re-add it manually. And this time it worked... but not for long. System froze after a few minutes.

After a reboot, network was not found, so I disabled and re-enabled, and this time it worked ("auto" rate was unfortunately only 11 MBps), but it worked. And then it froze again. Did this a few times only to end up with a frozen system.

So I deleted the network adapter, I am getting ready to uninstall ndiswrapper and to install the el-cheapo A-Link 54MBps WLAN PCI adapter I got from the local hardware shop.

Not happy at all with the WMP54G failure, so any suggestions about what went wrong are welcome.

12th December 2005, 10:48 PM
Are you running a 16K stack kernel? Some XP drivers have trouble with the 4K stack size that fedora kernels are compiled with. Try installing a 16K kernel from linuxant.