View Full Version : yum only checks local files, will not check repos

7th December 2005, 05:21 PM
I have installed FC5 without any problems and have kept it up to date with yum.

Except! Except that I am now hung with the recent cluster of unresolved dependencies. I see from the rawhide report that they are fixed, but when I run 'yum update', yum only reads the local files before "Resolving Dependencies", at which point it complains it needs some libs, and then it quits.

How can I provoke (or command) yum to get out of the funk it is in?

7th December 2005, 08:12 PM
Have you tried 'yum clean all' ?

7th December 2005, 09:06 PM
Yes, after backing up the /var/cache/yum directories (for use on other local FC5 boxes).

Running 'yum update' now fails because yum cannot find repomd.xml

Any suggestions? I can restore this file from the backup.

8th December 2005, 02:22 AM
try 'yum makecache'. I think that is what I did,

It will only look for new files once every 8 hours now. It can be overridden in the config files.

Alternatively in /var/cache/yum for each each repo you wanna rescan, in the relevant directory delete the yum cookie file, and yum will look for an update for the repo.

8th December 2005, 05:12 AM
Thanks, deleting the cookie helped to resolve this problem.