PDA

View Full Version : reboot/shutdown problem



ardchoille
29th November 2005, 03:37 PM
I had a problem with my computer as follows:

When I shutdown/reboot my system (AMD CPU), the system would go through all the steps and print something like "rebooting system please wait.." and then it would hang (never reboot), I even let it sit like that for hours to see if it was just slow. This only happened after the system was up for more than a day. I went to CTRL+ALT+F1 and did telinit 3, waited, and then "shutdown -r now" and it rebooted some of the times I tried that, not every time. I also noticed that, when this happened, the CMOS clock was wrong, it was set back to the last time this happened and required me again to reset the time and date.

I started up the system and manually launched no apps, just let the box sit there, for a day and then tried to reboot and the same thing happened. It rebooted fine when the system was up less than 12 hours. No Internet-facing servers (apache, ftp, etc.) were ever running.

I replaced the CMOS battery, didn't help. I made sure the system was up to date, didn't help. I made sure the fans were running and the box was getting plenty of ventilation, didn't help.

This all started during the last three kernel (15xx-FC4) updates and I still had the problem this month (November 2005) with the latest kernel.

Three days ago I switched this box to Ubuntu 5.10 (Breezy Badger) and I noticed the problem has completely disappeared, which makes me think the problem is either with a Fedora core app or the latest Fedora kernels. This Ubuntu box shutsdow and reboots normally.

My current uname -a output on the Ubuntu 5.10 box is:

Linux localhost 2.6.12-10-386 #1 Fri Nov 18 11:51:02 UTC 2005 i686 GNU/Linux

I don't know exactly what was causing the problem. I had lots of suggestions from lots of people but nothing helped. I have older computers (PII and PIII) that are running Fedora 4 and they don't have this problem, but they are all on the 2.6.12-1.1447-FC4 kernel because something in the later FC4 kernels has changed and the NIC's on those older boxes aren't recognised (the boxes hang at getting IP info).

I love Fedora, but someone needs to fix this type of problem or I will have to stay with another distro for this box - I'll keep Fedora on the older boxes. I have been using Linux since FC1 but I am not knowledgable enough to be able to diagnose and repair this problem on my own.

I just wanted to let the community know about this in case someone else is having a similar problem.

Thank you.

bob
29th November 2005, 04:37 PM
Best thing would be to open a bugzilla on it - might check to see if similar ones already exist.

erik187
29th November 2005, 07:58 PM
I too have a similar problem but my computer hangs every time I try to log out. I don't get any output, just a black screen. My mouse also fails to work sometimes. I am using Fedora 4 with Athlon 3000+ & Radeon 9600XT. Never had these problems with Fedora 3. I'm having trouble installing the ltmodem drivers to get my modem to work to try and update. I get a NO DIALTONE message.

giulix
29th November 2005, 11:06 PM
Tried the usual "press a key" and/or "restart X" (Ctrl-Alt-Backspace) stuff ? If it still doesn't work, have a look at your /var/log/messages log for a source of inspiration.... If that still doesn't help, post the logs here and/or submit a bug to Bugzilla.

ardchoille
29th November 2005, 11:22 PM
Best thing would be to open a bugzilla on it - might check to see if similar ones already exist.
I am a total noob when it comes to bugzilla.. I've never been able to figure out how to post anything there. Oh well, I'm happy for now. I'll keep checking out the newer Fedora releases and hope someone more knowledgable than myself has been able to find a fix. That's one of the great things about Linux.. if one distro doesn't work for me, most likely another will.

schlongsalami
30th November 2005, 01:02 AM
I have a few suggestions to try.

The first suggestion is to turn off acpi.

/sbin/chkconfig --level 2345 acpid off
/sbin/service acpid stop

The second suggestion is to turn prelinking off. Prelinking is usually done through a cron job usually at night. To do this edit the file /etc/sysconfig/prelink and change the line:
PRELINKING=yes
to:
PRELINKING=no
and then run the command, as root, to undo the prelinking:
prelink -ua

bob
30th November 2005, 01:20 AM
Okay - here's a link to Bugzilla for FC http://bugzilla.fedora.us/ - easy to post one and might get the solution!

gavinw6662
30th November 2005, 08:40 AM
i would think that ACPI is the ticket for you. I have an older (dual P2 400 MHZ) server running FC3 (not 4 I know) and i boot it with 'acpi=force' cause whenever I would shutdown the machine it would shutdown the processes and then post a message like "shutting down" and never power off. Once I added that line to my kernel - it worked beautifully.

iva2k
6th February 2006, 03:36 AM
I have discovered similar problem to yours on my FC4/AMD box (LanParty UT nF4 Ultra-D). I have display go blank occasionally. My box is a server, so it goes for weeks without attention. Once it happens, FC4 has problems during reboot - display turns black when GUI mode should come up. I can get it out of this mode by swapping monitor connector from VGA to DVI or vice versa.

By slim chance I discovered that I can trigger this problem by changing clock, specifically, when control panel changes date in CMOS. I guess, my screen also goes black when automatic time synchronization happens. Should be very rare event to change dates when syncing.

I was blaming screensaver, but turning it off did not help.

I will post it to bugzilla.