PDA

View Full Version : Java for Firefox



rappermas
22nd November 2005, 11:23 PM
How do I enable Java for Mozilla Firefox? I downloaded the file, extracted it, and installed it. Apparently, Firefox was supposed to restart with Java enabled, but it still doesn't have Java enabled, even after I rebooted the computer.

So, I'm just wondering if anyone could help me out here?

Avix
22nd November 2005, 11:24 PM
what versions of Fedora and firefox are you using?

Brian1
23rd November 2005, 12:32 AM
What version of java?
Are you using firefox, mozilla, or both?
What steps have you done to install java?

See if anything in this post helps. http://www.fedoraforum.org/forum/showpost.php?p=147709&postcount=12

Brian1

smfinley
23rd November 2005, 01:35 AM
See the Java section of Fedora Core 4 Installation Notes (http://stanton-finley.net/fedora_core_4_installation_notes.html).

rappermas
23rd November 2005, 02:17 AM
Thanks Brian1, that link gave me what I needed.

I'm wondering...would I take similar steps to install java and flash in Konqueror?

Thanks.

Brian1
23rd November 2005, 02:49 AM
Not quite, In konqueror I would do it this way.
1. Open a konqueror window.
2. Select Settings at the top
3. Select Configure Konqueror in the pulldown menu.
4. Define where your java executable is in the java section.
5. In the Plugins section make sure your plugins are in one of the listed locations in the box.
6. Hit the scan for new plugins button. It will search in all the locations for plugins.
7. Select the plugins tab next to the scan tab to see listed plugins.

Normally all plugins should be placed in /usr/lib/mozilla/plugins. Mozilla and firefox will look for this directory when searching for plugins at startup of either program even though they have their own plugins directory. Reason is when updating either you don't need to copy your plugins from the old install to the new install.

Only time I every needed to define a plugin for specifically to either mozilla or firefox was with a java plugin. Mozilla wanted to use the ns7-gcc29 (because of the way I compiled it) and firefox needed the ns7 one.

Brian

joshua197
23rd November 2005, 11:40 AM
Brian1,
I have FC4 64 bit with Firefox 1.04 and followed the link on your post.
I downloaded jre-1_5_0_05-linux-amd64-rpm.bin to /opt and set the permissions as detailed.
My plugin folder appears to be /usr/lib/mozilla/plugins.
As you can see from the following contents of my console window the test at stage 10 fails with dependency issues. Have I done something wrong here?

Output from console follows
----------------------------------

[root@thor opt]# ./jre-1_5_0_05-linux-amd64-rpm.bin
Sun Microsystems, Inc. Binary Code License Agreement

for the JAVA 2 PLATFORM STANDARD EDITION RUNTIME ENVIRONMENT 5.0

SUN MICROSYSTEMS, INC. ("SUN") IS WILLING TO LICENSE THE SOFTWARE
:
: I have removed the bulk of the license terms for the sake of brevity
:
Do you agree to the above license terms? [yes or no]
yes
Unpacking...
Checksumming...
0
0
Extracting...
UnZipSFX 5.50 of 17 February 2002, by Info-ZIP (Zip-Bugs@lists.wku.edu).
inflating: jre-1_5_0_05-linux-amd64.rpm
Preparing... ########################################### [100%]
1:jre ########################################### [100%]

Done.
[root@thor opt]# rpm -ivh jre-1_5_0_05-linux-amd64.rpm --test
Preparing... ########################################### [100%]
package jre-1.5.0_05-fcs is already installed
[root@thor opt]# rpm -Uvh jre-1_5_0_05-linux-amd64.rpm --test
error: Failed dependencies:
java >= 0:1.4 is needed by (installed) jessie-1.0.0-8.noarch
jdbc-stdext is needed by (installed) struts11-1.1-1jpp_7fc.x86_64
jdbc-stdext is needed by (installed) tomcat5-5.0.30-5jpp_6fc.x86_64
jdbc-stdext is needed by (installed) avalon-logkit-1.2-2jpp_4fc.noarch
jndi is needed by (installed) ldapjdk-4.17-1jpp_2fc.noarch
jndi is needed by (installed) tomcat5-5.0.30-5jpp_6fc.x86_64
java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp_31rh is needed by (installed) java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_31rh.x86_64
java-1.4.2-gcj-compat is needed by (installed) openoffice.org-core-1.9.104-2.i386
java-1.4.2-gcj-compat >= 1.4.2.0-40jpp_24rh is needed by (installed) eclipse-platform-3.1.0_fc-0.M6.22.x86_64
java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp_31rh is needed by (installed) java-1.4.2-gcj-compat-src-1.4.2.0-40jpp_31rh.x86_64
[root@thor opt]#

Brian1
24th November 2005, 01:55 AM
Actually if I follow your post, you are following may install directions. You started a step 1 and have done all to step 9. Now after that step jump down to step 12. Steps 10 and 11 are used if you have and existing java rpm. Since you installed the rpm at step 9 then you have installed and ready to define the mozilla plugin.

I will look it later and see if I make it a bit clearer instead of having all bunched in there together. Thanks for your input on the post.

Hope this helps. Have a Happy Thanksgiving
Brian