View Full Version : Can't Find Wireless Card (ADM8211) Under Updated Kernel (2.6.12-1.1381_FC3)

20th November 2005, 06:36 PM
I am a Linux Newbie, and I have recently installed Fedora Core (2.6.9-1.667). I was able to get my wireless network card working with the ADM8211 drivers. Everything was working fine until I updated the kernel to 2.6.12-1.1381_FC3. Now, linux doesn't recognize my card, and I have tried reinstalling the drivers, but with no success. Once again, I am relatively new to Linux, so I do have a general understanding of the commands and how to use the terminal, but not much. Any help would be appreciated.


20th November 2005, 08:55 PM
You'll need to recompile your network drivers against your new kernel source. You say you've had no sucess reinstalling them - do you mean you've already tried recompiling?

If you installed the kernel via rpm, make sure you also installed the src rpm - kernel-devel-2.6.12-1.1381_FC3. Recompile and install your drivers and you should be good to go.

Post any errors back here if you have problems.

20th November 2005, 09:01 PM
Thanks for the help! I was able to figure out what was going on. I needed a newer version of the driver that worked with the newer kernel. Older driver did not work with the newer kernel. I'm able to connect to the wireless network. Now I'm having another interesting problem. I seem to be unable to access any websites through any of the browsers. However, if I were to ping a server, I will get a reply from that server. Fix one problem and out comes another. ;)

20th November 2005, 09:11 PM
Glad you got your card working. Sounds like a dns issue, check ur /etc/resolv.conf entry / DHCP setup and pray you don't get slow dns - http://forums.fedoraforum.org/showthread.php?t=85727 :(