PDA

View Full Version : startup programs



karl_marx
15th November 2005, 02:21 AM
i want a couple of programs to run at startup, so i opened the "rc.local" file. here's what i did:


[root@localhost ~]# cd /etc/rc.d/
[root@localhost ~]# kate rc.local

then in the config file:


#!/bin/sh
#
# This script will be executed *after* all the other init scripts.
# You can put your own initialization stuff in here if you don't
# want to do the full Sys V style init stuff.

touch /var/lock/subsys/local
/usr/sbin/pure-ftpd & 'this is an old change, and it works fine
/usr/bin/kmix 'added this
/usr/bin/xmms 'added this
'carriage return, not sure if i need this


kmix and xmms do not start when i log in, in fact there is no indication that i even changed the config file. how do i make them run at startup? and how do i stop this red hat network up2date thing in my system tray from running at startup since it doesn't work anyway?

nandowong
15th November 2005, 03:56 AM
try desktop, preferences, more prefs, session, startup programs and add them there. this is for gnome, but im sure kde has something similar

mjmwired
15th November 2005, 04:49 AM
Hi there, you are misunderstanding what 'rc.local' does. Basically it is launched at the end of the init process. However it has no idea if your X-server has started or not, so launching 'xmms' and 'kate' will not work. Furthermore, everything put in there will be run as root.

(** I really hope you're not running root as your own user login **)

A better way is to use KDE (or Gnome) to setup your desktop. I think both can preserve your desktop. Just open xmms and kate and when exiting, tell it to save your desktop, then each time you login it will open those (this is how I do it in Gnome).

The reason 'pure-ftpd' works is because it is a daemon (a service) and it requires no user output or X-server to run. However there is a BETTER way to run that also.

If you use 'chkconfig' (command line) you can control many services. Also 'serviceconf' in the gui will work.

To properly run pure-ftpd:
[root@charon ~]# chkconfig --level 35 pure-ftpd on

This runs it for both runlevel 3 (no xserver) and runlevel 5
Then for more help on how to control it:

[root@charon ~]# /etc/init.d/pure-ftpd help
Usage: pure-ftpd {start|stop|restart|reload|condrestart|status}

---

To disable up2date, start with disabling the Redhat Network daemon.

[root@charon ~]# chkconfig --level 35 rhnsd off

You can also remove any rpms you may not want

[root@charon ~]# rpm -qa | grep up2date
up2date-4.4.23-4
up2date-gnome-4.4.23-4

# rpm -e up2date-gnome
# rpm -e up2date

I hope this helps.

Alerander
15th November 2005, 07:26 AM
Hey, Miranda!
I think i also learn some new stuff from your reply, thank you!

karl_marx
18th November 2005, 11:17 PM
well i fixed that config file and then i looked around for a gui that would add a program to startup, but i didn't find one. is there a terminal command, or a config file? (the right one this time!)

why not use root as my user login?

bitrain
19th November 2005, 11:11 AM
You're using kde right? If you don't close the programs, they will open after a restart of kde. :)


why not use root as my user login?Cause it's dangerous to be root, you can screw up you're entire system. If you are a normal user you can do most normal things to (expept (un)installing programs). Just type 'su -' in a terminal to become root for those things.