PDA

View Full Version : fatal IO error 104 (connection reset by peer) on X server



mlf
3rd November 2005, 08:13 PM
Hi,

I get this error after loging in as root and typing startx to begin linux, I found many articles that state it is a driver issue and say the Xorg.conf file should be edited in the display and video card sections. but /etc/X11/Xorg.conf doesn't open and says 'access denied' and I have no clue what to edit in this file?! Do you know how do I enable my FC4 GUI and begin using Linux?

b_martinez
3rd November 2005, 08:33 PM
Are you booting into a command line environment? Or trying to boot into GUI and ending up in command line? What card are you using? Can you get the specs ofyour monitor off the I.D.plate? Will you post them? Do you know how to use vim? Lotsa Questions, but the info is necessary to try to fix your problem.
Bill

mlf
3rd November 2005, 08:45 PM
Until now I don't get any GUI interface. the installation was in text mode and when I boot I get no GUI interface, all text and command line. video card is Ati X700 Pro and Monitor LG F700P. I don't know what is vim. but please don't make it hard, I just want to enter Linux in GUI mode.

b_martinez
3rd November 2005, 09:11 PM
vim is a command line type editor. Boot into FC and log in as root. after you are logged in, type in
/etc/X11/sysconfig (I think) to set up your GUI. If this doesn't work , then type in (the hard way)
vim /etc/X11/xorg.conf
and hit the "enter" button. it will open the file for you. Use the arrow keys to scroll down to the device section. Make sure you have the correct driver installed. Scroll down again and look under the "screen" section" and make sure that you are not trying to fry your monitor by going too high of a "modes" resolution. I have never used an ATI card, so I don't know if a "vesa" driver will work. If it will, change the driver (under "device") to vesa.
To edit the file while using vim, you need to hit the "Insert" key. When done inserting (editing) hit the "esc"ape key. Type in
:w
to write out the file and then
:q
to exit the vim editor.
or
:wq
to write out the file then quit the editor.
B4 you do any of this, try (as root)
kdm
K Desktop Manager or
gdm
Gnome Desktop Manager

mlf
4th November 2005, 12:13 AM
/etc/X11/xorg.conf does not exist and /etc/X11/sysconfig is empty, I used vim to see directories and entered gdm command that said:
"I can not start the X server (your graphical interface). It seems that your pointer device (your mouse) is not setup correctly. Would you like to view the server output to diagnose the problem?"
then showed the x server output file that had five error lines, one of them "(EE) unable to locate/open config file" and four errors for the input device.
After that, a mouse setup screen appeared and I selected the mouse as "generic 3 button ps/2Ē and repeated for a USB mouse and Ďno mouseí selections but Linux failed to start.
I doubt it is a mouse problem, So it seems that Linux can not create the config file and configure my devices for some strange reasons.

b_martinez
4th November 2005, 01:54 AM
I have no probs with my mouse. PS/2 is a type of connector. I don't know why , but it makes a lot of difference. There is also a difference in the driver set-up when you use a mouse/keyboard/screen combination.( 1 hookup - multiple screens/keyboards/mice). Anyways...... 1) Has this system ever worked for you? If yes.... 2) boot up in multiuser/CLI mode (3) and after logging in as root type in
cd /etc/X11
this will get you into the X11 directory. then type in
ls -asl |less
the | symbol is above the \ on U.S.English keyboards. use the arrows to scroll down to find out if you have a file named
xorg.conf~
just below one named xorg.conf. IF you do , then this command will restore your original xorg.conf (hopefully) if you didn't edit the file more than once. [DON'T LEAVE THE /etc/X11 DIRECTORY]
cp ./xorg.conf~ ./xorg.conf
cp=copy
Bill

mlf
4th November 2005, 11:57 AM
The xorg.conf~ or anything similar was not in the X11 directory and cp Ö command didnít worked.
Maybe Linux should load at least once to create these files.
But the file /var/log/Xorg.0.log exist and it shows all of the process for booting, in the graphic card section there are many ati drivers listed except X700. But it seems that a driver loads anyway. At the end of the file, when comes to loading pointer drivers there are many errors, I think it is because a wrong graphic driver loaded and it can not draw the mouse pointer on the screen.
So maybe FC4 does not support ati X700 cards.

b_martinez
5th November 2005, 12:08 AM
The only way I can think of for you to get it working now is to
1) insert 1st FC install cd and boot from that
2) at boot prompt type in " linux rescue "
3)after system boots into rescue mode type in " /mnt/sysimage "
4)log in as root and then type in " lspci |less " [ ls=list pci=pci cards pipeline located above backslash on US keyboards ] ths will let you scroll through the listing using the arrow keys. Look for the X700 card listing and post everything shown about it. [ Hopefully , someone who knows about ATI cards will check this out tonight and help you further. I'm not abandoning you, I must work the next 3 nights from 7PM to 7AM, so I probably won't be online when you are.]
OR
bott up and re-install in GRAPHICAL mode. [just hit enter at prompt] since you already have the system installed, just hit upgrade existing FC installation. Unless you have some tweaks done, this SHOULD load in an acceptable video driver, and you can use that system to trouble-shoot the problem from inside the OS. Much easier.
Will check back at 8:00 a.m. Saturday morning MST.
Good Luck
Bill

mlf
5th November 2005, 09:22 AM
Up to now, I have done the reinstallation for several times but it doesnít seem to change anything, every time the install program begins with a series of simple screens instead of a true graphical interface.
These are the information from the lspci command:

04:00.0 VGA compatible controller : ATI Technologies Inc : unknown device 5e4b
04:00.1 Display controller : ATI Technologies Inc : unknown device 5e6b

Also they are the two last lines of the output info.

b_martinez
5th November 2005, 05:18 PM
Since you are posting, I assume you are using a fuly functioning computer. Here is a link to Linux Driver from ATI

https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&folderID=27

and here is a link to ATI's FAQ about their driver

http://www.ati.com/products/catalyst/linux.html

If you can get both boxes online at the same time (assuming that you are NOT double booting one box) ,and you have lynx installed on your FC box, at command line type in " lynx " to open a command line web browser and download the ATI driver of your choice. If multi-booting , the go to these sites and read everything you can. Then either d/l and burn to cd the stuff you need, or open the FC side, and d/l using 'lynx', then install as RPM.
Easiest way to surf with 'lynx' is , at command line
lynx http://www.ati.com/products/catalyst/linux.html
for FAQ and
lynx https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&folderID=27
for driver page.
Lynx is not too user friendly, but it does have instructions on how to use it at bottom of screen when you open it.
Sorry I could not be of more help.
Bill

mlf
5th November 2005, 08:15 PM
I've downloaded a 51mb file with the .run extension but don't know how to install it from command line, now I have it on the cd, There are instructions on how to install RPMs from command line and how to mount the CDROM, but I get an error when executing this command:

[root@localhost ~] # mount /mnt/cdrom
error:
can't find /mnt/cdrom in /etc/fstab or /etc/mtab

Do you know how can I install this driver from cdrom?

b_martinez
5th November 2005, 10:55 PM
As root type in
lsmod |less
ls=list mod=kernel modules.Remember pipeline? [above the backslash] (should have had you do this 1st, my bad.) and look for ATI module. Try
modprobe ATI
command. you may have thenecesary files loaded, just not installed. If you get a not found or similar message then:
I THINK this is the one you need.It is for the xorg x-server. Notice that it is an 'rpm' ending,not a '.run'
ending. Download this to your computer,and burn it to cd. In linux, boot into run level '3'.

https://a248.e.akamai.net/f/674/9206/0/dlmdownloads.ati.com/drivers/linux/fglrx_6_8_0-8.18.8-1.i386.rpm?
As root tpye in
cd /media then
ls -asl |less to list your cd/dvd drives and floppy, and USB hard drives, etc....
As root, type in /mnt/hdX /media/cd[recorder] where X is the drive letter of your cd-rw [or cd-rom, dvd-rom,dvd-rw....]
a=master - 1st ide interface
b=slave 1st ide interface
c=master 2nd ide interface
d=slave 2nd ide interface
then
type in "cd /media/cdX"
to change to the directory [ read the files on] that cd. write down the file name for the driver.
type in "cd"
will return you to root directory.
type in "cp /cdX/("file name on cd") /root"
cp=copy from
/cdX/("file name on cd") <- this is the location and file to be copied
/root <- is the root home directory, this is where you will copy the file to. [notice the space between
cp /cdX/("file name on cd") and
/root. [ Don't run it all together.]
then to install
rpm -ivh /root/"name of driver file"
rpm=command to install a binary file in the RedHat Package Manager format
-ivh = install verbose-output hashmarks(for pretty, I guess)
If this message seems to ramble , my apologies, I have been up for almost 26 hours. [no work tonight!!! Yippee!!]
Bill

mlf
6th November 2005, 11:08 AM
The command /mnt/hdx /media/cdrecorder gets an error:
-bash: /mnt/hdx : No such file or directory
I repeated this command for x=a,b,c and d letters and got the same errors.
Using vim I looked at those directories, there are cdrecorder and floppy in the /media directory but /mnt directory is empty.
it seems like linux didnít recognized the cdrom.
At the bios the Primary IDE Master is for the cdrom and the Third IDE Master is for the hard disk, hard disk is a SATA drive and disk druid shows it as sda.
So cdrom should be hda, if linux recognizes it, then I can continue to install the rpm driver.

b_martinez
6th November 2005, 03:31 PM
Told you I was losing it! Too tired to think, I guess.Try
mount /mnt/hda /media/cd*
[the asterisk will act as a wildcard and the computer will (should) fill in the rest]
Sorry for the mistake.
Bill

mlf
6th November 2005, 04:27 PM
It says "filesystem type should be specified" or something similar. I entered iso9660 and got a help output instead, I think mounting was not successfull because the cp command: cp /media/fglrx_6_8_0-8.18.8-1.i386.rpm /root ends with 'no such file or directory' error. the file fglrx_6_8_0-8.18.8-1.i386.rpm is on the cd.

mlf
6th November 2005, 04:28 PM
sorry cp /media/fglrx_6_8_0-8.18.8-1.i386.rpm /root was infact:
cp /media/cd*/fglrx_6_8_0-8.18.8-1.i386.rpm /root

mlf
7th November 2005, 12:10 PM
using the command:
mount /dev/hda /media/cdrecorder (note /dev, you said /mnt)
cdrom mounted and rpm file copied to /root directory but when I want to install it I get an error:

error: Failed dependencies:
libstdc++.so.5 is needed by fglrx_6_8_0-8.18.8-1.i386
libstdc++.so.5(GLIBCPP_3.2) is needed by fglrx_6_8_0-8.18.8-1.i386

Why I get this error? now I have the driver file on the /root directory and it is ready to install.

b_martinez
8th November 2005, 03:19 PM
You need to install these 2 files.

yum -y install ibstdc++.so.5 is needed by fglrx_6_8_0-8.18.8-1.i386 libstdc++.so.5

This command will tell yum to get these files from fedora servers and install them. The "-y" thell yum to assume 'yes' to all questions. For example, one of these two programs may need another program, or a library to solve ITS dependencies.Sooner or later we will get you up and running.
Bill

b_martinez
8th November 2005, 03:29 PM
Dependency hell.
yum -y install libstdc++.so.5.i386
will install the library, will make sure that you get the .i386 version, and the -y will ensure that you get any dependencies required by the library 'libstdc++.so.5'
Bill

mlf
9th November 2005, 10:16 AM
I got another error:

file /usr/X11R6/lib/libGL.so.1.2 from install of fglrx_6_8_0-8.18.8-1 conflicts with file from package xorg-x11-Mesa-libGL-6.8.2-31.

b_martinez
9th November 2005, 06:38 PM
ATI driver and MESA driver will not work together. You nedd to remmove the Mesa driver libraries. As root type in
whereis xorg-x11-Mesa-libGL-6.8.2-31 [locate the mesa libs]
mv /(location of Mesa libs) /root/xorg-x11-Mesa-libGL-6.8.2-31 [just in case you do need them](mv=move)
yum -y clean all
then re-try installing the ATI driver
Bill

mlf
10th November 2005, 07:30 PM
I tried to remove the conflicting package but got a lot of errors that shows many other packages are depend on this package, So driver is still uninstalled, but I am now suspect to BIOS because sometimes a post message appears and says it canít probe video card.
I tried to downgrade bios to previous versions but was not successful, I used many windows and dos utilities but yet I canít replace bios with an older one.
I think it is a bios or chipset issue that prevents Linux and graphic driver from contacting with the video card.

mlf
11th November 2005, 11:23 PM
Thank you very much for your replies.

clever215
16th July 2013, 08:28 AM
I find if VGA interface is not got touched very well will also caused this issue.:cool:

glennzo
16th July 2013, 08:33 AM
8 year old thread. Closed.