PDA

View Full Version : Unable to install - no yaboot - kernel panic



Monsieur_Benoit
24th October 2005, 08:13 PM
Hello all.

I'm trying to install FC4 on a Blue&White G3, SCSI HD.
I can't boot directly from cd: when I'm holding the "c" key the sceen flashes and prompt an error message "/pci@800000 ..... /disk@2:,yaboot.conf: unknown or corrupt file. can't open file system."
It returns a blank "boot:" line.
Hitting tab do nothing, just a new "boot:" empty line.
Then I launch installation typing "cd:,/ppc/mac/vmlinuz".
The installer starts, but stops with the error: VFS cannot open root device "NULL" or unknown block (8,1).
Here is a picture of the screen : http://img398.imageshack.us/my.php?image=img21903ik.jpg

I tried the Ubuntu live cd and yellow dog 4.0.1 : same thing, no direct boot from holding c, so it starts from ("boot:,/whatever/vmlinux"), but same crash during installation.
The HD is partitioned, half is free space, half is OsX. First half is the free space.

Am I missing something ? on tutorials, it seems that it sould boot directly from cd.... what's wrong with my system ?

Thanks for your replies.

faby
24th October 2005, 08:49 PM
But it looks like the well known Syslinux Crash ... See the General Installation Help
http://forums.fedoraforum.org/showthread.php?t=62400

Monsieur_Benoit
24th October 2005, 09:38 PM
Thanks for the reply.
The "garbage trick" does not work. I also tried the boot.iso cd, but I have the same kernel panic.

I have the same problems with Ubuntu Live cd and Yellow Dog.

Any other idea ?

fedoraforme123
11th November 2005, 12:43 PM
I might be able to help, but what is causing the kernal panic Apple OS or Linux?

-Andrew

Zakarth
11th November 2005, 04:54 PM
I could be wrong but I believe your actual problem here is you're openfirmware (kind of like the BIOS for Macs) in the Mac is too old to boot Linux from the CD/DVD correctly. You can still install Fedora Core 4, or any other distribution of Linux, but you'll need to search around in the Forum to hear what other people have said (I don't specifically remember.)

Monsieur_Benoit
13th November 2005, 06:52 PM
I finally managed to install yellow dog linux on another G3 B&W. I had no sucess with fedora.
On my first G3 I had no success, I finally installed yellow dog on its HDD with the "working" G3, and then put the HDD back.

Not that perfect solution, but it work not so bad... I think the problem was in openfirmware, but I don't know exactly where.

I finally gave the "not working" G3 and kept the other one, on wich I can easily install YDL or MAC OsX.

Thanks

Regards,