View Full Version : Nvidia video card wont work after messing around with yum

22nd October 2005, 04:36 AM
Today I made the mistake of installing my video driver (for nvidia - v7676) via yum (from atrpms). I figured it would mean I would not have to reinstall my video driver after every kernel update.

Well, now I totally stuffed it. X wont work at all.

I have since uninstalled the driver I installed via yum (using "yum remove *nvidia*), and manually reinstalled the 7676 driver downloaded from nvidia. Now it just plain old wont work.

when I do a "modprobe nvidia", it gives me:
"FATAL: Module nvidia_1_0_7676 not found.".

Can anyone help me here?


22nd October 2005, 04:58 AM
If you tried installing the nvidia installer then you tried the livna's package. You will need to re-install. Mixing those two screws up the driver.

22nd October 2005, 05:33 AM
I will have to re-install what? The nvidia driver? Or Fedora?

Cause I have tried reinstalling the driver (sh NVIDIA-etc-etc), to no avail.

22nd October 2005, 05:49 AM
updating the kernel will cause all sorts of unpredictable problems with nvidia. i made that "mistake" and it took me many hourse of trial and error to get nvidia working with the new kernel. the headers were incompatible with the kernel version and some such...

first off, you can get X running for now simply by modifying your xorg.conf file: in Section "Device" change nvidia to nv. Now you can start X normally only without 3d acceleration.
DO NOT change nv back to nvidia until you are sure the drivers are installed correctly.

Second, i also tried installing nvidia via yum and i didnt like it and i dont suggest it so try to refrain from yum install nvidia (thats just imo).

honestly i don't remember the exact steps because i took sooo many, but roughly..

update your kernel + kernel-devel
ensure selinux is disabled
reboot (very important)
try to install nvidia driver using sh NVIDIA....
if it installs fine, then change nv to nvidia in xorg.conf

report back the exact error, if any and i will try to help.

good luck

22nd October 2005, 06:08 AM
Thanks rayyes,

This may seem like a silly question, but how do I update the kernel? I have already updated to the most recent one using yum.

I just did a "yum list *kernel*", and it still has all the kernels I have gone through there - should I remove the latest one, and then update again?

22nd October 2005, 06:30 AM
update like this:
yum update kernel kernel-devel

check that you have the latest like this (this is my output)

rpm -qa | grep kernel

if the out from the rpm -qa command lists other older entries then you will need to remove them
yum remove kernel-xxxxxxxxx

make sure you only have the two mentioned above.

22nd October 2005, 06:48 AM

When I do the "yum update kernel kernel-devel", I get nothing - I already have the latest version installed.

When I check what version I have, I get:
# rpm -qa | grep kernel

So your saying I should remove everything there, except "kernel-devel-2.6.13-1.1532_FC4" and "kernel-2.6.13-1.1532_FC4"? That will help? I would have thought it was the latest kernel that I am running (and hence that I have stuffed up by playing with yum to install my nvidia driver).

Before you had replied, I had stumbled across the rpm -e command, and had used it to remove the *latest* version only, and re-install them, to no avail.

If you are confident that removing all the previous versions will help, I'll give it a go.

22nd October 2005, 07:20 AM
thats a lot of kernels! but you still don't have the latest. compare your most uptodate one to mine.. i have 1600-fc5. yours is fine anyway. go ahead and remove everything except the latest. rpm -e has the same effect as yum remove so use whichever you like.

22nd October 2005, 07:32 AM
Yeah - I see that I dont have the same latest version as you do. But your version has "FC5" at the end, which to me implies you are using Fedora Core 5. Which, well, I'm pretty sure doesnt exist right now.

Which would prompt me to ask - how did you get the "kernel-2.6.13-1.1600_FC5"? Did you enable some development repositries?

One question before I do this - I beleive the error I'm having is in my current kernel - kernel-2.6.13-1.1532_FC4. I've stuffed it by installing the nvidia driver in two different ways - how does removing all the other kernels help?

22nd October 2005, 08:13 AM
i believe i did enable the development repo to obtain this kernel. dont worry about fc5, its just the one after fc4 :) its not available yet but i guess the kernel is.

as for the other q, well you never mentioned what errors you recieved so i don't know if it will help you. it did help in my case. in any case, it won't hurt.

out of curiosity, whats the reason you are so emotionally attached to the older kernels?? they're useless, let them rest in pieces.

22nd October 2005, 08:32 AM
I have no emotional attachment to the old versions - I just never knew they were there up until now. Right now, I want to address the issue at hand, which is getting my video working properly. I'll probably clean up the old kernels, after I get my video working.

The errors I'm having now, is that it wont boot up in X with the nvidia drivers. Whenever I try to boot up with the xorg.conf file having "nvidia" in the driver settings thing, X fails. If I put "nv" in there, x loads up, but the video isnt quite right (I use this as a pvr). No matter what I do, it wont work.

when I do a "modprobe nvidia", it gives me:
"FATAL: Module nvidia_1_0_7676 not found.".

What other information do you need?

22nd October 2005, 08:45 AM
this error is just saying that it can't find the nvidia driver because well, its not installed, which we have established. btw you don't need to modprobe nvidia as part of the installation process.
i dont know what else to tell you. this is how i solved the issue feel free to try it my way.

anyway im off to bed now i will check back this thread tomorrow. good luck.

22nd October 2005, 08:56 AM
The modprobe isnt part of the installation process - its part of the process of me trying to work out whats wrong.

What I find curious about that error message, is that it knows which version of the driver is missing - I'm only modprobing nvidia, and it knows that it is v7676 that is missing.

I might give your attempt a go soon...

7th March 2006, 08:13 AM
You probably didnt install the right module for your kernel if you used yum.

rpm -aq kernel
You should get something like this...



rpm -qa | grep nvidia
and you should see this along with some other nvidia files I omited...

This show the 2 modules and the kernel they correspond with. If they dont match, then they wont load

7th March 2006, 12:39 PM
All the kernel modules you need are :
rpm -qa | grep kernel
if you do: uname -r
I would suggest you read this also:
That should answer alot of questions you are having.
My video works fine with the above modules.

13th April 2006, 03:31 AM
So if I've installed the proprietary nvidia drivers off of nvidia's site, am I s.o.l. and have to reformat? Or is there a way for me to remove them and install the nvidia drivers from say livna?

15th April 2006, 08:53 AM
So if I've installed the proprietary nvidia drivers off of nvidia's site, am I s.o.l. and have to reformat? Or is there a way for me to remove them and install the nvidia drivers from say livna?

no, you can install from livna regardless of what you preinstalled. How to remove your origianl attempt at intalling driver from NVidia im not sure. Im so used to package managers its sad.

It wouldnt be hard. just a matter of deleting where ever the files unpacked to.