View Full Version : Master boot record problem while INSTALL

24th February 2004, 03:27 PM
Thanks to get into this message, it's maybee nothing...
Our team have made some installation of Fedora Core 1 on desktop and
laptop, all is great, but if the drive was not empty before this
install, we have a big problem, on all computer, and it's not depend
of the pc's contructors. The only solution that we've found is to
install Suse Linux 8.2 (minimal), just to create partition, and after
run again the Fedora Core installation, and that way get all perfect.

This is a major fail if the mbr is beeing corrupt while the install, at the partition step.

24th February 2004, 11:03 PM
are you using grub or lilo?

Fedora has never corrupted my mbr (yet..), even though I'm running
several different Os'.

if you can reproduce the problem, you should file a bug in fedora's

21st March 2004, 09:48 PM
If your talking about not getting a boot (grub or lilo) prompt this is due to the bios version not properly identifying the parameters of the hard disk. On huge disks, Change BIOS setting to Auto, LBA, and then reinstall. If it still don't boot, the drive and the bios combo is at fault. Upgrade the bios or try a smaller hard disk in the system.

Also, suggest you download Autoclave. There is a floppy boot version. Booting from the floppy you can swipe the hard drive, totally destorying any previous installs, and blowing away the FATs. If your upgrading from WinXX always boot from it's emergency floppy and do a "fdisk /MBR" to get rid of anything it put in the boot sector. Then you basically have a clean hard disk drive on which you can install any OS.

Always create the boot diskette when prompted. If you can boot off the boot diskette, though slow; you can still have a working system. And you can use that if you run into problems later on. Remember to recreate the diskette if you add/change the hardware or OS.

24th March 2004, 03:35 AM
Do not clean the disk of data with any other disk than one downloaded from the drive manufacturer's site. With all due respect to the other poster, there are no third party utilities that do this properly and/or reliably. Unofrtunately for Linux only users they are only Windows images for floppy installation. Get a friend to do it for you. They are at the most two floppies.



24th March 2004, 02:01 PM
Not to ruffle any feathers, if the thread was about totally destroying the data, then i would have recommended a sledge hammer, or thermite. Telling someone to stick with one's drive manufacturers routine is like tell them that they can only load "windows" on the drive.

Autoclave works fabulously on any drive giving you boot problems, or you have need to blot the data; unless of course you have a bad block on the first or last track of the drive.

Besides, my recommendation for the use of the program is reinforced by the crew at The ScreenSavers. Leo, Patrick, Yoshi, and Kevin have all recommended it to eliminate the data on any hard drive.

If you run enough interations of the program it could also make the disk a challenge for the NSAs data retreival folks. That's a pretty high recommendation if you ask me. But if I was that worried, I'd get the thermite.

25th March 2004, 02:31 AM
It seemed to me that the question also had to do with the integrity of the drive. Read the instructions on the drive manufacturer's site before you make up your mind. Evidence Eliminator had all kinds of converts in Windows and still does despite it failing a thorough forensic analysis. I don't care if you come up with an army of satisfied customers. When it comes to dealing with expensive hardware you should follow the mnaufacturer's instrctions and with 3 year warranties, don't give them a bailout by not using their software.


18th December 2004, 01:04 AM
there is no doubt about the drive functionality in any of the previous posts. The only drive related issue is if the drive is a big disk, and whether the parameters are being set properly.

The only thing that "joking" is saying to do is write all zeros over the drive, or wipe it to total oblivion, so that there are no hidden sectors set up with fancy MBR tricks or whatever, which may be screwing up the boot.

I had this problem as well, and have not figured it out. I tried the MBR trick and all possible settings with a Dell Dimension system and didnt get it to boot after an initial install. I can install fedora, or older redhats with the same physical drive on other systems, see that they boot, the reinstall on this system. But a drive which has not had redhat on it in the 915 system or Dimension system is not going to boot. Something is not getting set correctly when either the MBR is built, or the boot record for grub or lilo is set up. I tried both lilo, by the way.