View Full Version : IPW2100 Showing up as ethernet device

14th October 2005, 06:39 AM

I've read a bunch of posts and have been struggling with this problem for hours now and could use some help.

When I try to set up my wireless device using either the network set up device (neat) or the SystemTools->Internet Configuration Wizard I find that my wireless device doesn't show up as a wireless device. Instead it's listed under the ethernet device as:
Intel Corporation PRO/Wireless LAN 2100 3B Mini PCI Adaptor (eth1).

I have tried installing these rpms:

but that doesn't seem to affect anything

A few other notes

1) I'm running a thinkpad T41 with a built in wireless chip ipw2100
2) Previously eth0 was the wireless card and eth1 was the ethernet card, now they seem to be reversed
3) Uninstalling the above rpms seems to make no difference
4) I got it to work once with an earlier kernel but now I can't even get that to function
5) I have tried using NetworkManager and that doesn't seem to help in any consistent manner.

Has anyone run into a similar problem?
Does anyone have any idea what the heck is going on?



14th October 2005, 06:45 AM
I've got the same problem but nevermind...

Configure the eth1 as ethernet and it will work fine !
it's what I've done...

Shadow Skill
14th October 2005, 02:06 PM
You would have to edit a configuration file to make it show up as wlan0 [you vould name it anything really.] in the gui. If you check out the faq section http://ndiswrapper.sourceforge.net/ it should provide the info on what file to edit to make wlan0 appear in the tool properly.