PDA

View Full Version : When type in sevice



namit
12th October 2005, 07:30 PM
I can not seam to start of end services that are running on my computer. I type man service and it does not work it comes up no manuals. I try service httpd and it does not work i can not get any command with service to work.

skoona
12th October 2005, 08:15 PM
For fedora systems service is in '/sbin/service' to stop the httpd (webserver) try '# /sbin/service httpd stop'. If that fails become the superuser { # su - } and try the command; unless you have sudo configured { # sudo /sbin/service httpd stop }

namit
6th November 2005, 09:05 PM
it was because i was using su and not su -

namit
11th December 2005, 05:20 PM
do not know what the difference is but as long as it works

codergeek42
11th December 2005, 08:43 PM
'su' merely changes your effective user ID to 0 (so you have root access priveleges). 'su -' invokes a login shell as root, so you also gain root's environment settings, including the $PATH.

Hope that helps.

w5set
11th December 2005, 09:30 PM
If trying to stop services permanently--look at the chkconfig command
chkconfig --levels 2345 httpd off
chkconfig --levels 2345 sshd off
etc.etc.
this keeps them from starting next boot.