PDA

View Full Version : RHN Update Error



ocdavi
30th September 2005, 05:10 AM
This is the error I get whenever I try to update with RHN:

There was a fatal error communicating with the server. The message was:

An HTTP error occurred:
URL: http://ftp.belnet.be/packages/dries.ulyssis.org/fedora/linux/3/i386/dries/RPMS//createrepo-0.4.3-1.2.fc4.rf.noarch.rpm
Status Code: 404
Error Message: Not Found


Any solutions? I tried updating everything except dries, but got the same error message. It appears as if RHN is trying to make a connection to a bad url (there is a // after RPMS)!

Spoon!
30th September 2005, 09:07 AM
Did you try using Yum instead? (Up2date is deprecated)

Demz
30th September 2005, 09:29 AM
Use YUMEX to Update which is a YUM GUI

ocdavi
30th September 2005, 10:14 PM
This is the error I got with yum!

Error Downloading Packages:
tetex-doc - 3.0-6.FC4.i386: failure: RPMS/tetex-doc-3.0-6.FC4.i386.rpm from updates: [Errno 256] No more mirrors to try.

ocdavi
30th September 2005, 10:55 PM
I fixed the problem by removing the option to update dries. What are dries?

Thanks for the help

Firewing1
30th September 2005, 11:40 PM
Use SmartPM: smartpm.org
it's much better then yumex
Firewing1

rega451
1st October 2005, 12:46 AM
I fixed the problem by removing the option to update dries. What are dries?

Thanks for the help

Dries is one of the unofficial Fedora rpm repositories. It sounds like the network connection from a mirror site was down, that sometimes happens. :D

As was mentioned in the other posts, yum is the way to go. If you need some help getting it configured you can find more info on the Unofficial Fedora FAQ (http://www.fedorafaq.org/#installsoftware) site. As Firewing said, SmartPM is also a good GUI based application but keep in mind, it has a different approach to accessing the repositories by using channels and doesn't use the yum repo configurations (/etc/yum.conf or /etc/yum.repos.d/*.repo) like yumex does. I'd keep both smart and yumex around as well as the terminal based yum to cover all contingencies. ;)

ocdavi
1st October 2005, 02:00 AM
Yum works fine, but thanks for the advice and answer!