PDA

View Full Version : Fedora Core 4 - Crashed - Help!



dayal_78
30th September 2005, 01:59 AM
Hello,
Environment: Fedora 4
Kernel: 2.6.11

Hi I installed fedora 4 on my new Dell Dimension 5100 and I am dual booting with XP.
My audio wasn't working so I downloaded a driver and tried to install it. The install failed for some reason but I think it messed some things up. So when I rebooted and tried to log on I am getting the message:

Your session only lasted less than 10 seconds. ....

When I view details ~/.xsession-errors file

"/usr/bin/gnome-session: error while loading shared libraries : libasound.so.2: cannot open shared object file: No such file or directory"

Can you please let me know how to correct the above instability and log on to Fedora 4 again?

Thanks
Dayal

rayyes
30th September 2005, 02:45 AM
you need to provide more specifics. what driver? how did you download and install it? did youtry uninstalling? can you login as root?

dayal_78
30th September 2005, 03:38 AM
Hi,
Its an intel audio driver available at:

No.33 on the page below:

http://downloadfinder.intel.com/scripts-df-external/Filter_Results.aspx?strOSs=All&strTypes=All&ProductID=2068&OSFullName=All%20Operating%20Systems&lang=eng&page_nbr=2

I can't even login as root!

Thanks
Dayal

dayal_78
30th September 2005, 03:46 AM
Hello,
I think when I was trying to install the driver, It removed some old files which apparently are being shared (??). I am a linux newbie, so I really dont know how to solve this problem.

Any help would be greatly appreciated!!

Thanks
Dayal

rayyes
30th September 2005, 04:09 AM
the file refused to download so i couldn't look at it.
anyway it doesnt' seem like a permission problem, which would have been easier to solve.
it seems like a start up script is looking for that file and can't find it. I would try KDE or some other WM to determine wether the problem is specific to gnome or not. i would try to uninstall the program to see if it solves the problem > make uninstall if its source OR rpm -e <programname> if its rpm. i dont use gnome so i don't know where it stores its startup script but i suggest you look it up on google and try to delete any references in the script to the mentioned file.

also login as root (even if in text mode), and try this:
grep -r '<filename>' /

this will return all the files on your drive that contain inside them the text <filename>. perhaps one of those files is te startup file?

dayal_78
30th September 2005, 05:13 AM
Hello,
The problem happened when I was using KDE.
When I extracted that driver file there was a file 'audio_install' in the extracted directory. I ran this file to install the driver. After I ran the install (which failed) I deleted both the tar and the extracted directory.

can you please let me know How I can uninstall??

Thanks
Dayal

Iron_Mike
30th September 2005, 05:15 AM
I agree with rayyes, try to get to the root prompt and remove the driver you installed. If you can't, boot the cd or dvd and select rescue and try to remove the driver that way.

dayal_78
30th September 2005, 05:33 AM
Iron_Mike,
What do you mean by 'boot the cd...' - you mean the fedora 4 install DVD that I used?
As as I explained above I havent used rpm to install the driver. The download came with a file 'audio_install' that I executed. I can get to the root prompt by using the 'fail safe terminal' session. But I really dont know how to uninstall this driver.
Please explain how to do this.

Thanks
Dayal

nyinge
30th September 2005, 07:15 AM
If it is the problem because of the shared libraries used by the GUI startup, try appending the number '3' (w/o quotes) to the kernel line at the GRUB menu (assuming you're using GRUB as your bootloader). This way, you might be able to boot into the pure command-line mode and possibly gain root.

dayal_78
30th September 2005, 01:23 PM
nyinge, I can use the command line as root using the fail safe terminal session mode. But as I am a newbie command line is kind of asking a right handed rookie pitcher to pitch left handed in a world series game 7. I just started on linux and I am greatful to all you guys for the suggestions and advice.

Thanks
Dayal

Iron_Mike
30th September 2005, 02:08 PM
Since you can get to the command line, remove the sound driver depending on how you installed it either with yum or rpm. Either yum remove "filename" or rpm -e "filename"

dayal_78
30th September 2005, 02:53 PM
Iron_Mike,
When I extracted the tar ball there was a file in the extract - "audio_install". I have used this file to install the driver by running:

./audio_install

The above tried to install the driver but it failed midway. Then I got a gui message saying '...sound crashed...'. Unfortunately I deleted both the tarball and the extracted directory. After this I tried to reboot and ran into the above problems.

Also -

If this sort of a problem happens in Windows, I can go to Control Panel->Add/Remove Programs and uninstall the software. But on linux it seems that there are multiple ways to do install/uninstall - rpm/yum/make install/install program that comes bundled with that software etc etc.

If there are these many ways of installing/un installing software and if a problem like the one I am having happens then how can I revert my changes? In other words isn't there a centralized DB that all these different installs write to?

Let me know your thoughts.

Thanks
Dayal

Iron_Mike
30th September 2005, 06:02 PM
Download the tarball again and extract it. Look in the docs and see if they provided a option to uninstall it.

niko123456
30th September 2005, 06:11 PM
Hi Dayal,

reboot your computer, when you're at the grub prompt to choose your kernel, press 'a', add a 3 to the end of the line, hit enter. this puts you in text mode.

it'll ask you to login, so login as root.

then run 'yum install libasound.so.2' and see if that does anything. then try 'yum update'.

nyinge
1st October 2005, 04:00 PM
Dayal_78,

The file "libasound.so.2" is part of the package "alsa-lib", which is the Advanced Linux Sound Architecture library.
First make sure you have an internet connection. Try pinging a few places. Then proceed:

1. Remove the library package by typing "rpm -e alsa-lib" (w/o quotes). If successful, it will complete with no error output, otherwise, "error: package alsa-lib is not installed". This is just to make sure that the dmaged or missing library is removed before installing/updating.

2. Type in (as root) "yum install alsa-lib". This will install your sound library with the latest version, 1.0.9rf.

3. Check to make sure it is installed by typing in "rpm -q alsa-lib". This should return the installed sound library name such as "alsa-lib-1.0.9rf-2.FC4" or something similar.

4. Reboot and cross your fingers :P

Post back your results here.
I just started to get into Linux.. just like you. I understand your frustration. In windows, there's a central DB which keeps track of all the installed software, if those software use windows installer.
Fedora also has this DB and only for software that are installed using rpm, a linux installer (yum uses rpm to install packages, I suppose). If you type in "rpm -qa", it will show you all the packages/software on your computer.

dayal_78
1st October 2005, 05:27 PM
nyinge..
I just updated my alsa to the latest alsa (lsa-lib-1.0.9rf-2.FC4) just like you mentioned above using yum and restarted my machine.
But the sound still isnt working

Thanks
Dayal

nyinge
1st October 2005, 06:57 PM
Seems like you can now load your gui (X window / KDE or GNOME) fine now. I'm not really sure how to fix the sound problem now, but post your lspci output here (type: lspci at command-line).
See if there's a line for your audio. Mine's like:
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)

dayal_78
1st October 2005, 08:11 PM
Hi,
heres the output for lspci

00:00.0 Host bridge: Intel Corporation Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation PCI Express Graphics Port (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Integrated Graphics Controller (rev 02)
00:02.1 Display controller: Intel Corporation Integrated Graphics Controller (rev 02)
00:1b.0 Class 0403: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) Serial ATA Storage Controllers cc=IDE (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
03:03.0 Modem: Intel Corporation: Unknown device 1080 (rev 04)
03:08.0 Ethernet controller: Intel Corporation 82801G (ICH7 Family) LAN Controller (rev 01)

there seems to be a line for audio in the above:

00:1b.0 Class 0403: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

Do you think it has to deal with a problem with the driver?

also it was suggested to me to :

rmmod snd_hda_intel snd_hda_codec
modprobe snd_intel8x0 snd_intel8x0m snd_ac97_codec

But when I do the above I keep getting the error:

cannot remove module..module is in use.

Now I can remove the module if I logon using fail safe terminal mode. But then when I do the above and reboot the changes will not be stored permanently.

Please advice

Thanks
Dayal

nyinge
2nd October 2005, 05:16 AM
I believe this means that your sound module is loaded successfully.

To make sure, go to menu > System Tools > Hardware Browser, and choose "Sound cards". There should be a line describing about your sound card driver under "Selected Device".

Next, go to Menu > System Settings > Soundcard Detection.
There should be a description and you should be able to "Play test sound".

Make sure your speakers are connected/setup properly and your volume high enough. I can't find a place to adjust volume and mute/unmute program in KDE, but there's one in GNOME.

I once had a sound problem, just like you, where I can't hear anything even though the sound module is loaded. So I played around with the settings, mute/unmute and stuff, and finally I got it. That was quite unprofessional but it worked. :)

dayal_78
2nd October 2005, 06:43 AM
Hi,
The volume and everything should be fine because I can logon to windows XP partition and hear some blazing sound. I tried all those mute/unmute options ..but no luck.
Well the sound card seems to be detected but do you think there is some driver mismatch?

Thanks
Dayal

nyinge
2nd October 2005, 04:27 PM
what a coincidence... i just lost sound on my laptop all of a sudden. i mean i had it a couple of days ago, and today when i turned it on, i couldn't play any music files and no sound whatsoever. we're on the same boat right now. i also have an Intel board, and all the drivers are detected, but there is just no sound. oh my... leme see how things go and i'll post my results here. i'm gonna have some time to fix things today. don't count on me much though, because i just started Linux, just like you... wish me luck ;)

dayal_78
2nd October 2005, 04:38 PM
nyinge..All the luck's with you. I hope you fix the sound problem.
In the mean time I am configuring my FC 4 with JSE 5.0, eclipse, NTFS mounts etc.
Hope u can fix the audio.

Dayal

nyinge
2nd October 2005, 04:48 PM
I'm also trying to figure out a way to deploy NTFS package. I've installed the package, but it still needs to become LKM (Linux Kernel Module) first. And also, I don't want to modprobe it everytime my kernel changes. So I'll have to try to modprobe along with an option " -f " .

dayal_78
2nd October 2005, 04:50 PM
I just used the utility 'system-config-soundcard'
and the console printed...
amixer: Unable to find simple control 'Master', 0
amixer: Unable to find simple control 'PCM-2', 0
amixer: Unable to find simple control 'DRC Range', 0

Playing WAVE.........

Does the above has anything to do with the audio probs??

Thanks
Dayal

nyinge
2nd October 2005, 08:34 PM
I'm not sure about the output from your console, but here's the post about our similar sound problem. I just asked him to explain more about it. I think i did the same before, but I forgot what I did :(.

here's the post:
http://www.fedoraforum.org/forum/showpost.php?p=376341&postcount=1

nyinge
2nd October 2005, 11:40 PM
Ok. I got it solved, thanks to FastFreddie. You have to choose Alsa Mixer as your sound mixer in the volume preferences.
Then, open up Volume Control, and make sure that "Headphone Jack Sense" (under the tab "Switches") is unchecked, and make sure the volume is unmute.
I've also attached a screen shot.

dayal_78
3rd October 2005, 02:04 AM
Hi nyinge,
I dont have 'alsamixer' as an option in my volume preferences. I see only'PCM'

nyinge
3rd October 2005, 04:50 AM
dayal_78,
check your PM please.