PDA

View Full Version : Default panel configuration



HaMBoNE79
28th September 2005, 11:59 PM
I hope this is the right forum for this...

I have a fileserver running FC4 that supports several engineers. This machine serves CAD models/drawings, personal files, and is configured to act as a VNC terminal server. Everything is working great except for one little issue that is annoying all of my users. Whenever a user logs in through VNC (logging into a GNOME desktop), they get an error saying no sound device was found. I have traced this problem back to the mixer applet being loaded by default, so I would like to change the default panel configuration so that it does not load the mixer applet. My only problem is that I have no idea how to change the default configuration.

Another problem I would like to address is that fact that I need to place icons for a few programs on everyone's desktop, but I don't see how to do this. I would like to do something sort of like the "All Users" Desktop folder on Windows. Anybody know how to do this?

jim
29th September 2005, 12:50 AM
you could create a folder on the desktop pointing to the /home/ALLUsers folder
make the permissions to 777 for the folder and any link to a application you want.

HaMBoNE79
4th October 2005, 01:25 PM
Well, that's not exactly what I was looking for.

Twey
4th October 2005, 05:56 PM
To disable the mixer applet, right-click the panel, go to remove->applet->mixer (or similar). I don't know if this will suit you, but you can have GNOME use a single o+rwx directory as everyone's desktop, or link the ~/Desktop directory to it. This would mean, however, that all users would have the same desktop files. They could chown/chmod to control access, if they needed to.

HaMBoNE79
4th October 2005, 07:23 PM
I know how to disable the applet for a single user, but the problem is that the applet doesn't even show up when you are logging in through VNC. It still gives an error saying that it can't find a sound device, but it never actually starts the applet. I have also tried to remove the applet for invidual users using the gconf-editor, but it doesn't seem to do anything. I have even followed a set of directions on Red Hat's website about customizing the default panel for all users, but it didn't do anything either.

Why is it so hard to change the default configuration for all users???

HaMBoNE79
5th October 2005, 05:54 PM
I have tried everything now! I even followed the directions on the GNOME website on how to change the panel configuration, but nothing works! WTF? Is this hard coded into GNOME or what?

HaMBoNE79
5th October 2005, 07:14 PM
Ok....I've been working on this for a week so I'm about to say the hell with it. Before I do, I would like to point out that the the .gconfd/saved_state file for all of my users that are having the mixer problem has several lines for the mixer applet. My user account (which doesn't have the mixer problem) doesn't contain any references to the mixer applet. I figure that gconfd is keeping the settings in memory some where, but after deleting everything in /tmp, killing gconfd-2, and removing the saved_state file, it still comes back. Can someone tell me how the hell to fix this before I completely lose my patients?

Twey
5th October 2005, 07:45 PM
I don't think this is to do with the mixer applet. Does it happen if you disable esd?

HaMBoNE79
6th October 2005, 06:28 PM
Trust me, it's the mixer applet. The error message has the little gnome mixer icon in the title bar and the mixer applet will not load on these accounts.

BTW, I fixed the problem this morning. The problem is that I removed the mixer applet from panel-default-setup.entries, but never removed the /etc/gconf/gconf.xml.defaults/apps/panel/default_setup directory before I tried to reload the default panel setup with gconftool. If you don't remove this directoy and let it re-write everything, you will only be able to add new panel applets, but won't be able to remove them.

Now that I finally have the applet removed, my users no longer get an error message.