PDA

View Full Version : Screwed up my xorg.conf file



dhamilton
28th September 2005, 01:25 PM
I need help. I jacked around with the xorg.conf file and now x won’t start. I did this same thing before and got lucky by typing some command and a hardware wizard started that allowed me to select my monitor and video card. Does anyone know what that command is? I thought is was xorgconfig but that doesn’t seem to work. Please help.

brandor
28th September 2005, 01:42 PM
What run level do you have it in?

If it's 5, it should come up with a message saying it can't start X and ask if you want it to run the config program.

It used to be xf86config. But, I think it's different in fedora... I can't remember off the top of my head.

Err.. So just put it into runlevel 5. :D

mach_zero
28th September 2005, 01:43 PM
Try "system-config-display".

dhamilton
28th September 2005, 01:57 PM
I am not sure what run level I have it at. I believe 5 since it shows a 5 durning the boot process. I didn't go out on my way to change it to any run level, it is at the one that is default after installation. I am at work and durning lunch I will go home and try the commands listed above. Thanks guys!

dhamilton
28th September 2005, 02:07 PM
PS this might be a long shot but I recall running the program from inside kde and in the past. If you click the menu button on the taskbar and extend the system or settings menu, there should be a icon for the "Display" program. Maybe if you right click the icon and select "place in run command" or whatever it says, you can post the path to the program and maybe I can run it?

mndar
28th September 2005, 02:22 PM
I don't know if you'll be able to run 'system-config-display' if you don't have a fuctional X. You could try to do the following.
In the command line, type X -configure. This will generate a sample xorg.conf.sample file in your current directory. Test if its proper using X -config xorg.conf.sample. If it works , good. Just copy this file over to /etc/X11/xorg.conf.
If not, check the file. Most of the times it does not have the Modes line which lists the resolutions. You may have to manually add it. Sometimes it doesn't detect the mouse well. The problem is the mouse device is listed incorrect. You must be knowing the correct mouse device (/dev/input/mice etc. Anyway you can find that out) .After you have finished editing it, copy it over to /etc/X11/xorg.conf

dhamilton
28th September 2005, 05:38 PM
system-config-display worked. I tried that first since it was easiest of the two solutions. I must have really had the xorg.conf file messed because it took a system-config-display a few tries to get the program loaded. Thanks everyone!