PDA

View Full Version : up2date bugs??



billquinn
28th September 2005, 03:03 AM
I recently installed FC4 ("everything"), not as an upgrade but from scratch. There seems to be a number apparent bugs with the up2date feature. These problems did not exist with FC3. I will list them below. I'm interested in whether anyone else has had these problems and whether they are really new bugs introduced with FC4.

(1) The little up2date check mark in the blue circle in the upper right-hand portion of the Gnome desktop does not seem to work. I use DSL, so I am always online. With FC3, it would automatically change to an exclamation mark when new updates were available. It never does that anymore. I have checked for updates a number of times. They were available, but the check mark was still there.

(2) When I click the check mark to start up2date, a window opens up called "Subscription Alert," saying, "Your subscription has not been activated." First, there was no such thing under FC3. Second, every time I start the up2date process, I check "Activate now." But the next time a check for updates, that same window pops up again. It seems that this window pops up only if I've logged out and then back in. But that still shouldn't be happening. The activation is with Red Hat. Once done, it should remain in affect for my system.

(3) Sometimes the check mark turns into a "no" slash, "Unable to connect to RHN." Why not? I am always online. I can click it, then click OK in the window that opens, and the check reappears. What's going on here?

(4) Here's a minor point, but it does seem to indicate a very glaring programming error. During the part of the up2date process called "Retrieving Packages," the progress bars are not correct. The top bar gives the progress on the current package being retrieved; the bottom bar is supposed to give the total progress. However, once the FIRST package is completely downloaded, the total progress bar totally fills in and remains that way while all the remaining packages are retrieved. The top bar works properly by always starting over for each new package. On the other hand, during the process called "Installing Packages," the two bars work correctly.

(5) The scan for available updates does not always seem to catch all of them. Once I checked again immediately after I did an update, and more packages were found, not just one or two, but ten or fifteen.

(6) The very first time I tried to update after installing FC4, a whole series of "conflicts" stopped the process. "Test install failed because of package conflicts." A huge number of packages were listed, all "conflicting" with a single KDE package about Polish (or was it French?). Once I deleted this package from my system, the up2date worked. Why did I have to delete it? There should have been no conflicts.

(7) A yellow "badge" sometimes appears next to the check mark. When clicked, it says, "You are currently authorized to configure system-wide settings..." What's this all about? The up2date has always asked for a root password. Who is authorized? Me as a user? Why should a user have this authority? On the other hand, root ALWAYS is authorized to do anything!

Well, this has been a lengthy post. I hope someone can shed some light on these items. If they are bugs, how does one go about reporting bugs?

Thanks.

Bill

Demz
28th September 2005, 03:41 AM
with Fedora its better to use YUM than the up2date feature, you can use or download the YUM GUI which is YUMEX go to Terminal an search for that package

multescugeorge@
29th September 2005, 05:10 PM
if you just want to (quickly) update your system, type in a terminal as root:
(optional, but advised: rpm --import /etc/pki/rpm-gpg/RPM* )
yum -y update

rega451
29th September 2005, 09:39 PM
For a brief explanation of the RHN situation look in the Unofficial Fedora FAQ (http://www.fedorafaq.org/#up2date) . As I understand it the up2date icon doesn't change because the RHN is no longer polled for updates. Same thing basically with the subscription alert, the RHN is not used anymore. As far as the "slash-no" goes, it just means that the network connection failed to the RHN alternate update site, nothing to do but try again or wait for the connection to be restored. To address your 5th question, sometimes the connection to the download site will fail and that site is skipped. The fact that you have an "always on" connection does not insure 100% reliability, especially when the connection problem initiates from the site you are trying to access.

The "yellow badge" in the system tray is normal. When you are prompted for your root password to perform a root level operation such as installing an RPM or doing some other administrative level function this icon appears in the tray to give you the option of retaining root privileges for further system-wide action. It is valid only for the session you are currently in and if you don't click to retain the system-wide privilege it will simply time out and go away soon after you exit the root level.

Your package conflict problem is common when you try to install everything. This is not a recommended practice partly because of the conflict problem and partly because you will end up with a lot of unused and generally unwanted "stuff" that just takes up hard drive space and can sometimes cause unexpected glitches in applications you are trying to run.

Anyway, as was previously said, you should probably use yum to update. I simply dumped the 'cutezy' up2date icon...Sure miss that little guy. :( If you want a GUI updater, try yumex and/or Smart Package Manager. Again, the info in the Unofficial Fedora FAQ is most definitely worth reading since many of your questions and resolutions to them are addressed there. ;)