PDA

View Full Version : di-624 with wpa_supplicant?



Jeff Sadowski
27th September 2005, 06:24 PM
Ok I have wpa_supplicant working with madwifi-cvs-snapshot-2005-07-01.tar.bz2 for my D-Link AG660(the newer madwifi drivers seem to break my wpa connectivity), wpa_supplicant-0.4.5.tar.gz with my Linksys WRT54G with firmware 4.20.6 (I'll have to upgrade and see if it still works, I'm 1 behind the latest is 4.20.7 but I try and keep all up to date)
I can not however get wpa_supplicant to work with my D-Link DI-624 ver C1 I tried the latest firmware 2.70 for it but it is still not allowing me to connect. Older versions of the firmware didn't have the options for TKIP vs AES Cipher Types TKIP works with my Linksys but still didn't work for this D-Link AP has anyone got wpa working with one of these D-Link access points
and if so what settings do you have in your wpa_supplicant file?
and what settings do you have on your D-Link AP?
My wpa_supplicant file looks as follows

ctrl_interface=/var/run/wpa_supplicant
ap_scan=0
network={
ssid="WifiAP"
scan_ssid=1
proto=WPA
key_mgmt=WPA-PSK
psk="0123456789"
priority=5
}

works for Linksys AP but not D-Link AP

My D-Links config is as follows

Security: WPA
Cipher Type: TKIP
Passphrase: 0123456789

I also tried WPA2-Auto
but that did the same thing I get the following in my wpa_supplicant output

Wireless event: cmd=0x8c02 len=83
Custom wireless event: 'MLME-REPLAYFAILURE.indication(keyid=1 broadcast addr=ff:ff:ff:ff:ff:ff)'

repeatedly

I tried WPA2 also but with that setting wpa_supplicant didn't even try to connect.


For my Linksys I have the following settings

Securtity Mode: WPA Personal
WPA Algorithms: TKIP
WPA Shared Key: 0123456789
Group Key Renewal: 3600

this works

If anyone has a clue why my Linksys works but why my D-Link does not I'd like to know

Thanks

Jeff Sadowski

Iron_Mike
27th September 2005, 06:45 PM
Try adding pairwise=TKIP to wpa_supplicant.conf

Jeff Sadowski
4th May 2006, 03:57 AM
I found with the newer madwifi drivers I had to set ap_scan=1