PDA

View Full Version : FC4 yum online update problem



reitherm
27th September 2005, 02:43 PM
Hi,

on a 4 CPU INTEL Xeon-based IBM server system I just did a full install (all packages) of Fedora Core 4 successfully.

After that I tried a complete online update of all packages using "yum update" (with the slightly modified
yum.conf from FedoraFAQ), but I got the following errors:

(...)
Importing Additional filelist information for dependency resolution
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package kernel.i686 0:2.6.12-1.1447_FC4 set to be installed
--> Running transaction check
Error: Unable to satisfy dependencies
Error: Package gnbd-kernel needs /lib/modules/2.6.12-1.1447_FC4, this is not available.
Error: Package dlm-kernel needs /lib/modules/2.6.12-1.1447_FC4, this is not available.
Error: Package cman-kernel needs /lib/modules/2.6.12-1.1447_FC4, this is not available.
Error: Package GFS-kernel needs /lib/modules/2.6.12-1.1447_FC4, this is not available.

Thank you very much in advance for any ideas to solve this problem!

-- Steffen

normandro
27th September 2005, 10:21 PM
I have the same problem ! Fresh install and yum fails to satisfy dependencies

smfinley
28th September 2005, 12:47 AM
As root do a "yum remove gnbd-kernel dlm-kernel cman-kernel GFS-kernel". Then do a "yum update", reboot, and finally do a "yum install gnbd-kernel dlm-kernel cman-kernel GFS-kernel" if you want them back. (You probably don't need these. They are cluster related kernel modules included with the initial FC installation.) If you remove your old kernel after you have installed the new one they will be removed anyway as dependencies. To remove your old kernel after you have installed the new one with "yum update" and rebooted do a "rpm -qa | grep kernel". This will tell you what kernels and kernel related stuff you have installed. Then do a "yum remove kernel<old> kernel_devel<old>. (Of course substitute the right suffixes for <old> in that command.)

reitherm
28th September 2005, 10:50 AM
Thanks for your hint which will solve the problem, too,
in another forum I got the following short tip
which worked well for me and solved my problem immediately:

yum update kernel*
yum update

-- Steffen

normandro
29th September 2005, 12:02 AM
Yes that solves the yum update problem for my installation as well
Normand